Windows 10: DistributedCOM permission settings Error 10016 -should I resolve this? Solved

  1.    21 Dec 2016 #1

    DistributedCOM permission settings Error 10016 -should I resolve this?


    Inside W10's Event Viewer, I see an error with ID of 10016 (DistributedCOM). Its error description is -

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
    { (long number) }
    and APPID
    { (long number) }
    to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    This error message says that I can modify security permission. As this topic is over my head, I don't know if I should do this or not. Thanks for any comments on this issue.
      My ComputerSystem Spec

  2.   My ComputersSystem Spec

  3.    21 Dec 2016 #3

    Thanks, that fixed the problem! BTW, at the end of those instructions, under the heading "Change DCOM Permissions", where it says to give the newly added System full control, I decided to give it full local control only, rather than full local and also full remote control. I don't know what I'm doing, but it seemed like a good idea, and when I rebooted the PC, I now see no errors inside the error section in Event Viewer, so the problem has now been resolved.
      My ComputerSystem Spec

  4.    22 Dec 2016 #4

    Whoops, I have made an error in my reporting of the solved problem. Although the problem was solved on a reboot, when I did a "cold boot" the next day, the problem returned. But I've just realised something else. The CLSID and APPID in the event viewer error message are different to the ones that are used in the example above. Mine are:

    CLSID {8D8F4F83-3594-4F07-8369-FC3C3CAE4919}
    APPID {F72671A9-012C-4725-9D2F-2A4D32D65169}

    There's a discussion about this issue with those IDs here, on tenforums. I followed the advice, which was similar to the advice given in the example above, but it didn't solve the problem. The advice also said that if the problem wasn't resolved, you could go ahead and delete the key in the registry. I haven't done that yet, and probably won't. I expect I'll just leave it, as it doesn't seem to be causing any issues.
      My ComputerSystem Spec


 

Related Threads
I am having a number of events that seem to be located repeatedly with the source: DistributedCOM Event ID: 10010 and Event ID: 10016 also getting repeatedly Service Control Manager Event ID: 7031
I do THANK all whom has helped me on my memory DUMp Error it was bad memory!!T This has happened serval time this month so far Now I have one more BSOD error details in ZIP thanks for all the Help :( Error 9/22/2015 3:40:32 PM...
Hi, Is this something I should be concerned about ? I've tried the following solution to no avail my event viewer is still flooded with this error LogName: System Source: DistributedCOM EventID: 10016 Immersive Shell
Hello fellow forum users I am not sure where to begin but I'll start out by saying that I have been googling this one for a few days now. Followed the guides I've found and have not had success fixing this event. Problem: Windows 10's event...
Event 10016, DistributedCOM in Performance & Maintenance
Since upgrading to Windows 10, my error log is flooded with this message. Over 520 incidents in the past week. The instructions provided for that error in Windows 8 do not work with 10, since it is impossible to grant full permission to the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:25.
Find Us