Windows 10: Win 10 v1803 Update - refused to restart, now says not reqd??

  1.    02 Jun 2018 #1

    Win 10 v1803 Update - refused to restart, now says not reqd??


    Hi all. Windows offered the 1803 feature update late last night, I unknowingly let it run without disconnecting a USB stick and external hard drive, and ran into reboot problems. The sequence of events is set out below.

    I'm unsure of what has happened, and of what (if anything) I need to do to sort it out.

    Perhaps 1803 will present itself again in due course, or is it already installed? As matters stand Win update thinks Win is fully up to date, but the update history contradicts this by saying that the 1803 feature update failed.

    Could it be that the update history is now somehow corrupted, and needing a reset?

    Did Win conclude after the problems with 1803 (after the fact) that quality update V1709 KB4103714 was needed to resolve some underlying issue, and does this explain why it installed it?

    Can anybody say what the position is please?

    Thanks

    Sequence of events:

    • The 1803 update downloaded and installed, but the laptop failed to reboot - stuck on a black screen.
    • Boot manager opened, said failed to boot, error 0xc1900101
    • Switching off and on somehow enabled a normal looking Windows restart.
    • Win update said the 1803 feature update had failed to install, also quoted the above error number.
    • Tried the 1803 feature update again, it stuck on the black screen again (waited for hours), same boot and win update error message.
    • Found a troubleshooting piece, and implemented recommended fixes - disconnected the external drives, but Device Manager brought up nothing to suggest driver issues. (why if it's important does Windows not say upfront to do this???)
    • Win despite this out of the blue (don't think I did anything) started to install 2018-05 cumulative update Win 10 V1709 x64 KB4103714.
    • This ran through just fine, Windows now seems to be working OK.
    • Widows update at this point claims that the device is up to date, although update history contradicts this by showing the 1803 feature update as having failed twice.
    • Running the Win update trouble shooter brings up two problems - potential Win update d/base error, and Win update components must be repaired. It claims to have fixed both problems, but repeated running of the troubleshooter keeps on bringing up the same problems, and the same claimed fixes - which doesn't make much sense.
    Last edited by ondablade; 02 Jun 2018 at 09:33.
      My ComputerSystem Spec

  2.    02 Jun 2018 #2

    Hi, a reasonable guess is that you're back to 1709, which you can confirm as follows:
    Windows key + R, winver

    You can also run
    SFC /SCANNOW
    from an admin command prompt to check/repair the integrity of your OS files, and probably should.

    Regarding Windows update: try
    Reset Windows Update in Windows 10 | Windows 10 Tutorials
    (This will reset your Update History as well)
    then try running the WU troubleshooter again to see if that still reports anything.

    Once happy with your 1709, please, as we strongly recommend, if you don't already do disk imaging routinely, please create a base image with Macrium Relflect (free) - external disk/storage needed.

    Then if sthg goes horribly wrong- or even if your disk fails- you can restore a working state relatively quickly and painlessly hopefully without technical help.

    Windows update at this point claims that the device is up to date, although update history contradicts this by showing the 1803 feature update as having failed twice.
    - that's normal- not a problem.

    If you wish to apply the upgrade manually, you can download the 1803 iso. (If you don't know how, there's a tutorial on that). This will help if you need to attempt the upgrade several times or on several PCs with similar Windows. (base language, x64 or 32) as it save downloading each time. A Windows bootable medium can also be useful for some repairs.
      My ComputerSystem Spec

  3.    02 Jun 2018 #3

    Hi D, that all worked well. Many thanks.

    Windows is confirmed as being back to 1709, SFC /SCANNOW found nothing wrong, and the .bat file reset Windows update.

    The Update Troubleshooter threw up a few problems, I'm unsure of the significance of 'could not find the network's proxy settings'.

    The remainder seem likely to be OK - 'check for pending updates' was presumably just the result of my not letting the update run during the troubleshooting process, and it also says it fixed some security settings, an update d/base error and update components.

    Will run Macrium reflect if that all sounds OK.

    The 1M$ question is whether or not to risk running 1803 again.

    It's possible that the problem was caused by the USB stick and external drives connected during the update process, but instinct suggests given the mayhem it's causing it's probably best to prevent it running for a while.

    Best to give MS a while longer to debug it...
      My ComputerSystem Spec

  4.    02 Jun 2018 #4

    Good idea to wait- however you have Home, so can't defer it. I recall there is a way to hide the upgrade, which has been documented on this forum. It's just a bit awkward.

    Whatever you do, make sure you set up a disk imaging routine, just in case.
      My ComputerSystem Spec

  5.    02 Jun 2018 #5

    Hi D. As it happens D I have Win 10 Pro, but even on that it seems (I've just tried to apply a procedure outlined on a Chris Hoffman help page 'How to Prevent Windows 10 From Automatically Downloading Updates' from Spring 2017) that Group Policy Editor no longer offers the option to set it to 'notify for download', and 'notify for install'.

    It looks like you can either set the connection as 'metered' to force this, or there's a registry editing procedure which does it too. Chris also mentions in his piece that MS also has a downloadable tool than can block updates by uninstalling and quarantining them.

    'Metered seems to mess with the OneDrive connection, the download sounds as though it brings it's own risks, and I'm wary of playing with the registry.

    Think I'll have to leave it down to the gods of MS, and hope they are smart enough not to try again until 1803 works more reliably....
      My ComputerSystem Spec

  6.    02 Jun 2018 #6

    Hi, I thought you had Home 'cos that's what it say under your avatar on the left- but your computer details do say Pro.

    Windows Update - Defer Feature and Quality Updates in Windows 10 | Windows 10 Tutorials

    Could you provide a screenshot of your GP editor? (U only have 1709.. deferring the upgrade...! (Also for reasons of compatibility with Aeroglass). (The first is notify). I'd be concerned if MS has removed Notify..
    Click image for larger version. 

Name:	1.jpg 
Views:	3 
Size:	211.4 KB 
ID:	190985

    Click image for larger version. 

Name:	1.jpg 
Views:	4 
Size:	169.3 KB 
ID:	190983

    Click image for larger version. 

Name:	1.jpg 
Views:	40 
Size:	41.3 KB 
ID:	190984
      My ComputerSystem Spec

  7.    03 Jun 2018 #7

    Hi D. It seems after all of that that I was mistaken last night - but I couldn't for the life of me find the Configure Automatic Updates in WIndows Update in the GPE then.

    It came up now, I've set it to notify both downloads and installs.

    My apologies....

    Click image for larger version. 

Name:	2018-06-04 (2).png 
Views:	2 
Size:	516.3 KB 
ID:	191066
    Last edited by ondablade; 04 Jun 2018 at 09:18.
      My ComputerSystem Spec

  8.    03 Jun 2018 #8

    Glad you found it.
      My ComputerSystem Spec


 

Related Threads
UPDATE 6/05/2018: Cumulative Update KB4338548 Windows 10 v1803 Build 17134.83 - June 5 - Windows 10 Forums Source: https://support.microsoft.com/en-us/help/4100403/windows-10-update-kb4100403 Direct download links for KB4100403 MSU...
UPDATE 5/23: Cumulative Update KB4100403 Windows 10 v1803 Build 17134.81 - May 23 - Windows 10 Forums Source: https://support.microsoft.com/en-us/help/4103721/windows-10-update-kb4103721 See also: KB4100347 Intel microcode updates for...
Source: https://support.microsoft.com/en-us/help/4037237/surface-surface-laptop-update-history Update for Surface Laptop (10 May 2018) Surface Manual download: Download Surface Laptop Drivers and Firmware from Official Microsoft Download...
Why 'Refused To Connect' ? in Network and Sharing
I have a win10 machine. It has two adapters - one onboard ethernet and one plugin usb wifi. Both adapters are enabled and both seem to be working fine. The wifi is allowing internet access and here I am writing this via it. The ethernet...
Network Connections Refused in Network and Sharing
Testing 2 PC's with 10 on a network of 24 users. Both machines were running 7 and updated prior to the upgrade. Both have reset network connections to some strange IPV6 setting including ## signs, wiping out the IPV4 settings. Now they wont allow...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:18.
Find Us