Page 1 of 2 12 LastLast
  1.    24 Oct 2016 #1
    Join Date : Oct 2016
    Posts : 4
    Windows 10 Build 1607

    Corrupt NTUSER.DAT file in Default Folder


    After reading the 7Forums link I cannot find a similar instruction set w/in Win 10; yet I know that this forum is far better than the 'like' Microsoft forum since people responding on the MS Forum seem incapable of actually answering the question and provide real-life solutions.

    Bottom line: I'm suffering from the dreaded "The User Profile Service failed the logon" message.

    The error occurs only during the creation/log on attempt for a new profile. Current admin and standard profiles continue to work (though more about this later.)

    Well, the real culprit appears to be the C:\Users\Default\NTUSER.DAT file was somehow corrupted. Several steps have been taken to try corrective action, and they work somewhat. The new profile, when logged on after re-creating the Default folder, still can't launch (and keep launched) the System Settings.

    I have the most current version of the Win 10 Pro x64 .ISO file. Yet, can't seem to find/figure out how to get the core Default folder back from there. Of course, not sure I'm on the right track either.

    REAL QUESTION:
    Any one have any idea how to get my system capable of creating a new local profile without triggering a system error that prevents if from being used?


    A LITTLE MORE BACKGROUD:
    I went through the process to create a new profile, selecting no MS Account, and choosing to make it local. When the profile was created, the system somehow got confused. I did this from my Admin Profile. Since my profile was physical name was the same as a Hotmail account I have, it suddenly figured I should be using that account for my local system admin too. I didn't ask it to, did not expect it to, and sure as heck didn't want it to.

    Somewhere in the "smarter than me" mode of Windows 10, it decided all the pieces weren't aligned properly, and not only linked my admin account to my email account, it corrupted the NTUSER.DAT file in the Default folder.

    I've done this before w/o any issue (I've several family members which use my PC.) I'm a fairly knowledgeable individual when it comes to PCs (I'd say moderate level.)

    And the initial trigger for all of this was somehow the Start Menu became stupid. Try to move an icon from a location I'd deleted a previous link from, and suddenly the icon I moved disappeared as the entire Start Menu greyed out (though it did let me launch apps.)

    My system is running Windows 10 Pro Build 1607 (updated last week.)

    Any ideas, suggestions, guidance or help is more than appreciated!

    Jim
      My ComputerSystem Spec
  2.    24 Oct 2016 #2
    Join Date : Aug 2015
    Spring Valley
    Posts : 558
    Windows 10 Pro/Windows 7 Ultimate

    Is WIndows loading a "Temporary Profile?
    Even if this is not happening, the Fix for that issue may fix yours.

    You've been signed in with a temporary profile - Fix - Windows 10 Forums

    This fix entails simply creating a new user, then moving your entire user folder sans the NTUSER.DAT files to the new location. I've had to do this twice with Windows 8, and once with 7. This problem has been around since Vista.

    This might work for your problem, which appears similar. You can't log in or a Temp Profile is created and you are shunted to that profile. It all depends on if you can log in to your Administrator account, this has to be done all from there and in Safe mode.
      My ComputerSystem Spec
  3.    24 Oct 2016 #3
    Join Date : Oct 2016
    Posts : 4
    Windows 10 Build 1607
    Thread Starter

    Thank you!

    It does look promising, though there is one question behind the potential workaround.

    When a new profile is created, the actual folder (e.g. C:\Users\<NewProfName>) is not created until the initial log on is made with that profile. The error being issued by the Profile Service occurs before what ever steps take place to create the profile, build it with the shell components, and open the initial desktop.

    Reading through it though, there was a nugget of information. Specifically the location of Service Profile models (C:\WINDOWS\ServiceProfiles\LocalService\). As of yet, I've not been able to attempt a use of this as a core model for Default, though I am hopeful.

    Any further guidance is greatly appreciated!
      My ComputerSystem Spec
  4.    24 Oct 2016 #4
    Join Date : Aug 2015
    Spring Valley
    Posts : 558
    Windows 10 Pro/Windows 7 Ultimate

    Try going into Safe Mode, log in as Admin, and see if you can make the Admin account visible from there. Then you might be able to log in to THAT profile and create the new account.

    I see what the issue is, you can't log IN at all. You might want to keep trying and see if it eventually creates a Temp Account, I don't know if that will happen. It's what *should* have happened, but it's not doing it in your case.

    If you have an install medium, you could try booting to that, and then use some of the recovery options, system restore, etc. If you don't have one, they are easy to find online to download, I don't think you need the exact version to get the to the recovery options. The medium I have includes both Home and Pro versions, it's what I downloaded through the Windows 7 GWX app.
      My ComputerSystem Spec
  5.    25 Oct 2016 #5
    Join Date : Jun 2015
    UK
    Posts : 1,834
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    I had a problem in Windows 8 where I couldn't create a new user account due to a corrupted default user profile. I copied across ntuser.dat from another working account I had and I was able to access my account and create new accounts which were previously prevented. You might need to do a repair install if this doesn't work. I think MS needs a Troubleshooter tool to sort out account problems like this.

    TIP - create a backup admin account on your PC which you don't normally use. If your main admin account goes haywire then you will have another hopefully working account to use.
    Last edited by Steve C; 19 May 2017 at 09:37.
      My ComputerSystem Spec
  6.    25 Oct 2016 #6
    Join Date : Oct 2016
    Posts : 4
    Windows 10 Build 1607
    Thread Starter

    Quote Originally Posted by Steve C View Post
    I had a problem in Windows 8 where I couldn't create a new user account due to a corrupted default user profile. I copied across ntuser.dat from another working account I had and I was able to access my account and create new accounts which were previously prevented. You might need to do a repair install if this doesn't work.
    I had hoped to avoid a repair update from my Win 10 Pro image as that has not always identified, then solved the issues (in my past that is). Yet, it is looking like the best approach - haven't tried it yet.

    Windows is really finicky when it comes to their profiles. A lot of hidden stuff which links a lot of different keys and stuff. I think this is why the copy/paste of the NTUSER.DAT file may work. After placing it in the C:\Users\Default folder, the profile stuff comes along and links the HKLU information to the NTUSER.DAT file in the newly created profile.

    What I ran up against when I tried this before, is that the System Settings wouldn't work on the new profile. Specifically, when I selected it, the Settings panel would display for a few seconds then simply vanish. Process Explorer didn't show it active, nor any other component needed. The Control Panel worked, though for UAC it would not allow me to create a new profile.

    The key here is that I'm hoping a copy of the folder tree from C:\WINDOWS\ServiceProfiles\LocalService\ to a new Default folder, followed by a copy of the Administrator's NTUSER.DAT file will set things correct, or perhaps a copy of the folder tree from C:\Users\Default.old followed by a copy of NTUSER.DAT from the Administrator's profile will be a successful combination. Otherwise, I'll have to return my system to the state it was in right after all this mess started.

    My last resort though, is a complete restore of the OS drive (which I have). It is in a state that had now profile hiccups. Yet, would hate to go through the several hours it would take. - - - - Hmm, a new thought. Perhaps I can copy the NTUSER.DAT file or at least the C:\Users\Default from my on-line version of backup... Wow, it really does help to 'voice' the issue to other colleagues in the PC world!

    Looks like I'll need to move forward with the repair option though, and see where that leads.

    I'm going to give another day or two to see if other folks can chime in too.

    Right now, the system is operational - albeit in a Windows unwanted state (e.g. My profile now linked to my MS account which is totally unacceptable - to me.)
      My ComputerSystem Spec
  7.    03 Nov 2016 #7
    Join Date : Oct 2016
    Posts : 4
    Windows 10 Build 1607
    Thread Starter

    This past weekend I updated my OS to build 14393.351 [Win 10 1607].

    This appeared to correct the issue with the moving around Start Menu pinned applications. The approach was provided via elsewhere, with the following steps:

    Open the Settings menu and go to Update & security > Windows Update. If not already shown, the select the option to Check for Updates. On my system, the update was already pending.

    I also restored my C:\Users\Default folder from my backup archive, though I had to go back about 3 generations to find a viable version. Apparently, the issue was triggered some where between Aug and Sep backup versions, though it remained dormant until needed (Oct). This didn't solve the problem entirely, as I eventually had to create the new profile via Safe Mode, from the built in Administrator account (tried before the restore w/o effect.) This required the definition of a new profile via Computer Management, Users.

    My system still is a bit sick, though I'm making progress.
      My ComputerSystem Spec
  8.    12 Dec 2016 #8
    Join Date : Jun 2015
    UK
    Posts : 1,834
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    I had this problem again yesterday in upgrading my desktop PC to the AU - I couldn't login to a new user account due to having a corrupted default user profile. I copied the default profile from my laptop and it now works. I'm wondering what is the best source for a default user profile - see https://www.tenforums.com/user-accou...r-profile.html

    In reply to Post 1, I discovered how to extract the default profile from the ISO:
    1. Mount the Windows 10 ISO image
    2. Find install.wim in the sources folder
    3. Open install.wim using 7 Zip
    4. Navigate to Folder 1 / Users
    5. Extract the Default Profile


    I haven't tried using this 'clean' default profile yet since I'm awaiting advice form the forum.
      My ComputerSystem Spec
  9.    07 Mar 2017 #9
    Join Date : Mar 2017
    Posts : 1
    10

    After chasing this for a while i have finally gotten it fixed... or at least its working for me in my scenario

    The scenario:
    i tried to create users, but when i tried to login, i got an error "The user profile service service failed to load. The profile could not be loaded"
    So the system created the users, however the folder structure and the registry entries were not created.
    This is because the c:\users\default folder was corrupt, and so all new users were not able to be created from a copy of the default folder.

    What i tried: updating windows, creating a new account, logging in as administrator to copy the NTUSER.dat, using windows repair tools for ACL's, permissions on folders and others of the like

    What i found out along the way:
    • somewhere in the update process win 8.1 to 10, and then the latest versions, the NTUSER got corrupted, and so no users could be added at all, even the hidden administrator would not load because i had never logged in with it.
    • If you extract the install.wim from the ESD using DISM (mentioned later), you Cannot open the extracted WIM with 7Zip, you must mount the wim using DISM


    Quick guide on how to get it sorted:
    1. create backups of the c:\users\default folder by renaming it, and appending it with .bak or similar
    2. Using the Windows 10 media creation tool, download and create an ISO of the OS version you are running
    3. Mount the ISO, or open it with 7zip
    4. Extract the ESD inside the ISO - (just extract it with 7zip is the easiest, its located in the ISO under )
    5. Use DISM to extract the install.wim of the version you require (there are many tutorials that cover this, just google DISM extract install.wim)
    6. create a folder to use as an offline mount location for the wim file. (when you mount the WIM in the next step, it wants to create a virtual link between the mount and a folder. I would recommend keeping it simple, like c:\offline or similar
    7. Use DISM to mount the install.wim
      1. dism /mount-wim /? will give you the command line to type

    8. If done properly, you should be able to browse to the folder you created in number 6 and you will have the mounted WIM.
    9. Use Xcopy to copy the default user folder to the c:\users folder
      1. Open raised command line then type
      2. xcopy c:\offline\users\default c:\users\default /E/H/O/Y

    10. unmount the WIM (unless you want to keep it there)
      1. Dism /Unmount-Image /MountDir:C:\offline /discard

    11. Try and login, or create the users again if you want to make sure. Mine worked straight after on both machines i was having the issues.
    12. Run an SFC /Scannow in a raised command prompt to check things over


    If anyone wants more of a breakdown, just say and i can split it up more, however all the things are easily searched for in google because everyone is trying them.
      My ComputerSystem Spec
  10.    19 May 2017 #10
    Join Date : May 2017
    Posts : 5
    W7 Pro

    Just to add a couple of notes to this:

    A friend's PC had gone through an 'involuntary' upgrade to W10, leaving it in a fairly sad state. One of the problems was the "The user profile service service failed to load. The profile could not be loaded" when a new user was created. I tried replacing the default-user folder from another W10 system but it didn't work (possibly I used a copy from a W10 Pro system, and I later realized that the bad system is W10 Home).

    In the end I d/l the W10 iso from MS, with the plan of extracting the required folder as per Steve C (above). I then discovered that MS now packages it as 'install.esd' , not 'install.wim'. No probs, a quick search finds that 'ESD2WIM-WIM2ESD.cmd' and DISM.EXE will convert the .esd to .wim. Except that it didn't work (on my W7 system). A bit more searching revealed various versions of DISM, and I eventually found this site ( https://markthetech.com/how-to-conve...o-install-wim/ ). Their cmd file link ( MEGA ) translates to ESD2WIM-WIM2ESD-v2.zip and when you open that, you find that they have also packaged a compatible version of DISM together with the cmd file.

    That worked, and I now had an install.wim. (There are actually four versions of W10 in the iso from MS, so I had to select the correct version - all part of the cmd file and DISM operation.) I then extracted the default-user folder using 7-zip ( as per Steve C), and replaced the faulty folder in my friend's machine. Viola, I could now create new users, and log in ok, ....... EXCEPT left-clicking on the START button produced absolutely nothing. Right-click gave the usual short menu. A quick look at the new 'default' folder showed that it was an extremely minimalist version, and specifically did not include the ' default\AppData\Local\TileDataLayer ' folder and its database files, which are required for the START button to work. Whether that folder is normally included in the default folder on a good W10 system, or whether the initial login of a new user is supposed to build it into the new user's profile, I don't know. I simply copied the TileDataLayer folder from one of the existing accounts that did work, into the default folder structure, and now the START button works in new accounts that are created.

    Of course, that means that every new account immediately has all installed applications available (and working) on their start menu. I haven't seen anything like the ' all users ' arrangement on earlier versions, so I don't know if it is possible on W10 to install software ' for all users ' or ' for this user only '. But right now, I don't really care.

    Earlier in the process I had done an 'sfc scannow' which said it had repaired some files (the log file was pretty large, > 1MB if I recall), but whatever it had repaired, it wasn't associated with the main problem that I was looking at.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
File explorer - setting a default opening screen to particular folder
I was able to do this in Win7 but can't figure out what to do in W10. Problem is that I want File Explorer to start with the display at a particular folder. In my case that is D:\Tony\Pictures. And with the contents of that folder in the right-hand...
Software and Apps
Solved Can't delete ntuser.dat from old unused User Account folder?!
I'm only using local accounts. I have an unused user account folder called "Anna". It's been migrated since ages ago in Windows 8 and it shouldn't be in use. I only use my present user folder called "Anastasia". Now I want to create a fresh new...
General Support
Solved How to Delete Corrupt/Broken File/Folder
Here is a problem you might encounter: "Currently, I'm having problem deleting an old Folder. Previously, I used its parent as a shared folder, but one day when I tried to clear that folder there is one folder that has duplicate. The problem is one...
General Support
Solved location of NTUSER.DAT file?
I'm trying to fix a Windows 10 app problem and want to delete/uninstall completely. The problem is with an app installed by a second user of the PC. In order to do this I want to edit registry for this user. So, I want to load the hive for this...
General Support
Solved File Explorer: "This PC" Documents folder link corrupt
I tried to move my Documents folder to another partition, but stupidly specified E:\ instead of E:\Documents. I moved it back to the default location and fixed the Quick Access link but can't fix the folder link in "This PC". The icon is E:\...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:21.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums