Windows 10: Java Installer doesn't run

Page 1 of 2 12 LastLast
  1.    29 Jan 2017 #1

    Java Installer doesn't run


    Win 10 Pro x64 1607. Java Installer won't run, period. Well, the 32 bit one will start, per Task Mgr processes - Java Platform SE Binary (32 bit) - but disappears in a few seconds. The 64 bit version doesn't even do that much. My problems with installing Java started with the current update, version 8 update 121. I was doing fine up through v8 update 111, but 121 returned a (known) 1603 error and the Java methods for fixing it didn't work. I removed Java from my computer via CP and JavaRa and Java's own uninstaller and did a bit of additional removal via file manager searching. Now, in Event Viewer when I try an install file, it shows application error 1000 (screenshots). Btw, this problem started in Win 10/1511 and continues in Win 10 1607. To save time, assume I need Java.

    Here's what has NOT solved it:
    - Run offline versions and online versions
    - Run as administrator
    - Run in Safe Mode
    - Run in elevated Command Prompt from root directory (C:\)
    - Run with Ninite
    - Run with JavaRa (JavaRa is not installing anything now, but before it only installed update 111 - and in wrong drive)
    - Run with Windows Firewall and Defender disabled
    - Disconnected all other drives and USB connections (for the 1607 update, but they are still disconnected)
    - (I'm probably forgetting something)

    Any other ideas? Thanks,


    Click image for larger version. 

Name:	Java install doesn't work error - details.JPG 
Views:	1 
Size:	65.5 KB 
ID:	118992Click image for larger version. 

Name:	Java install doesn't work error.JPG 
Views:	2 
Size:	95.1 KB 
ID:	118991
    Last edited by highstream; 29 Jan 2017 at 14:53.
      My ComputerSystem Spec

  2.    29 Jan 2017 #2

    I see you ran JavaRa. Maybe Java's own uninstall tool will handle better. Second paragraph of this link.

    https://www.java.com/en/download/help/log_files.xml

    I see all these error are happen in Temp. WIth it fully backed up what about running something like CCCleaner to delete all files. ( or manually)

    Interesting that the different screen prints have failures in different sub-directories of Temp.

    Do you think installing in Safe mode might provide a different outcome?
      My ComputerSystem Spec

  3.    29 Jan 2017 #3

    Thanks. I did run Java's own uninstaller and have edited my OP to include that. It won't run now either - 1000 Application Error.

    Safe Mode is in my list. I run CCleaner a lot. Is there something specific I would check in the choices?

    Concerning the difference in screenshots, I tried the install with x32 and x64 several times from two different folder locations, which generated a number of Event entries. In addition, I took the Details screenshot a few minutes after the other, so probably they weren't from the same Event. Would that explain what you noticed?
      My ComputerSystem Spec

  4.    29 Jan 2017 #4

    Sorry I missed the Safe mode. In CCCleaner I was after the deletion of all temp files. I wonder if Revo Uninstaller would find something?
      My ComputerSystem Spec

  5.    29 Jan 2017 #5

    Nothing in Revo Pro or Programs & Features after uninstalling Java and the updater, I think it was. Other programs are installing, so it's puzzling what's with Java. Could it be something in the registry that's not being found or liked?
      My ComputerSystem Spec

  6.    29 Jan 2017 #6

    That would be the most likely spot. You've deleted everything inside out, I assume the Temp files are cleaned, you likely swept through programs and Programsx86 and killed all folders. I would check programdata as well and for thoroughness I would trace down through the different AppData paths and ensure if any folders are there they are empty. Of course I would make sure I have back ups or would rename.

    Maybe its time to present to their forum

    Space: Java | Oracle Community
      My ComputerSystem Spec

  7.    29 Jan 2017 #7

    In my searches (before going from 1511 to 1607), I had done what you suggest. Before going further, I've run another search on the system drive for "java" and taken screenshots of the results. Would you mind taking a quick look to see if anything jumps out at you that needs deleting? Click on each to enlarge. Thanks,

    Click image for larger version. 

Name:	Java search 1.JPG 
Views:	2 
Size:	227.9 KB 
ID:	119053Click image for larger version. 

Name:	Java search 2.JPG 
Views:	2 
Size:	244.2 KB 
ID:	119054Click image for larger version. 

Name:	Java search 3.JPG 
Views:	3 
Size:	231.3 KB 
ID:	119055Click image for larger version. 

Name:	Java search 4.JPG 
Views:	2 
Size:	159.3 KB 
ID:	119056
    Last edited by highstream; 29 Jan 2017 at 16:54.
      My ComputerSystem Spec

  8.    29 Jan 2017 #8

    To be honest, not understanding all of the required and not required files for Java its a bit of guess.

    I see all these files in Programdata\microsoft\windows\wer\Report Archive. I looked up and these reports are in machine code so I can't read.

    I also see javaRa log files, in pic 2, name javaRa-1-28-2017.log

    Have you opened one of those to see what it says.

    This got me thinking what about the java install log. It is mentioned in that link I provided. Can you run the install again, find that log and see what is has to say. According to their site it gives through information. Hopefully it will have something meaningful to you ( or us forum members). To get the log you have to kick the install off manually and add some options. Instructions in that link.
      My ComputerSystem Spec

  9.    29 Jan 2017 #9

    Log file attached.
    Java Installer doesn't run Attached Files
      My ComputerSystem Spec

  10.    29 Jan 2017 #10

    Wow.

    You notice it detects 8.111. You have to really follow but I wonder now that it has been swept clean it can't delete or even find.

    Interesting that it is producing Warnings about not find the home directory, would this be where 8.111 was?

    I read you needed java, so much so that you would do a clean install. Yes nuclear option.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
My netbook is DENVER NBW-10004N. It was running Windows 10 64-bit but the boot file was corrupted so i had to format and install clean Windows 10 32-bit. Now i got another problems. Audio driver is not working, battery icon not showing and...
Java Installer Won't Run in Software and Apps
Anytime I try to install Java on my friend's computer, the installer doesn't even work. I get the loading wheel for a split second, then nothing happens. Her computer seems to be corrupt or something, but when I run the sfc, it doesn't find any...
Tried installing a program and received an error message advising that JRE needs to be uninstalled and reinstalled from the off-line installer. I did this and then tried to install the program again, but received the same result ... 74879 I...
Mediamonkey installer doesn't run in Software and Apps
I downloaded Mediamonkey and when I run its setup file, nothing happens and antimalware service starts to steadily use 50% CPU , I waited for 10 minutes and still the same. Does anyone know what's up here? Thank you.
Installer doesn't have permission to write to the startmenu located in C:\ProgramData\Start Menu Avg & some other software wouldn't install at all, tell I used the take ownership registry file. I also notice, Windows updates keep not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:37.
Find Us