influencing cpu load Solved

  1.    21 Oct 2016 #1

    influencing cpu load

    During video conversion the cpu load raises close to 100%. Because of high cpu temperature I reduce the load to 50% using Battle Encoder Shiraz. Works fine.
    Recently I discovered the following setting: settings, system, power&sleep, additional power settings, change plan settings, process power management, maximum processor state, there I put setting at 50%.
    Now I see that in spite of this last setting cpu load still is 100% during conversion.
    Any idea why this setting does not work?
    Therefore I still continue to use Battle Encoder Shiraz; that works.
      My ComputerSystem Spec

  2.    21 Oct 2016 #2

    Hi, that's a useful setting.. I've just used it for exactly the same reason. Not that the CPU was getting terribly hot- this laptop has specially good ventilation (and is relatively new).

    But using that did indeed reduce CPU load from 99.9% to under the 80% I set, and stopped the fan running hard.

    Battle Encoder Shiraz is pretty unique.

    It might be a matter of low level compatibility under Win 10... just a guess.. yours is probably an older desktop as you mention Win 7. However this feature has existed since at least Win 7.

    Power Options - Add or Remove
    - this mentions a relationship between virtualisation in the BIOS and the option being available or not.
    This does suggest looking at this a different way- if sthg were amiss somehow, could the function be disabled, but the option still present? You could check your BIOS to see if virtualisation is enabled- if not, it's not that that's stopping this working.

    - which video conversion program are you using? Does it use CUDA - GPU acceleration?
    I did some conversion with such programs and the fan wasn't running.
    The program I'm currently running does not support CUDA, and I very quickly found the fan was running.
      My ComputerSystem Spec

  3. Posts : 11
    Windows 10 Professional
       22 Oct 2016 #3

    If you have high CPU temperature you need to check the heatsink to be sure its not clogged with dust and reapply thermal paste to the processor, I would even invest in a better cooling option like a heatpiped heatsink, which are almost silent and will keep your processor running at decents temperatures.
      My ComputerSystem Spec

  4. Posts : 582
    Windows 10 Pro 64bit; Windows 10 TP; KDE Neon
       22 Oct 2016 #4


    In my system, shown in my System Specs, it works. Setting the maximum processor state to 50% brings my i7-4790K down to 1900 MHz, which is approx. half of its factory non-turbo default speed (4 GHZ).

    Here's my favorite stress test, encoding, at the state of max = 50%

    Click image for larger version. 

Name:	half.png 
Views:	5 
Size:	306.7 KB 
ID:	107150

    And here it is, running at its full potential, on my per-core OC : x50 x50 x49 x48, cache x44

    Click image for larger version. 

Name:	nor.png 
Views:	4 
Size:	284.1 KB 
ID:	107151

    So, it works.
      My ComputerSystem Spec

  5.    23 Oct 2016 #5

    Thanks for all reactions so far. I realize that setting max. processor state works for others.
    To answer some questions: I use Freemake or Handbrake. In principle Cuda could work there, but not for my rather old videocard (GTS 450). Conversion at 100% cpu load for for instance 20 minutes raises the temperature rather high, so I prefer a 50% cpu load during a longer time. Thermal paste was recently replaced. Since the conversions or DVD rips have a frequency of about once per 3 weeks, the urge to replace videocard or improve cooling conditions is not big. I can live with it.
    I will check the suggestions of dalchina, but donot understand that virtualisation in the Bios might be an issue, but I will check it. I donot use that.
      My ComputerSystem Spec

  6.    24 Oct 2016 #6

    First, virtualisation was not set in the Bios. When I put the max. processor state at 50%, I did not check the value of the minimum processor state. It appeared to be 100%. Setting this value to 5%, things changed but not the way I want. I use as a temperature monitor RealTemp which also monitors the cpu rate (MHz). What appears? Max. processor state at 50% halves the cpu rate for ALL processes and the PC becomes slow. Max. processor state does not provide a limitation for only high cpu loads and is therefore not an alternative for Battle Encoder Shiraz, which limits the load for those specific processes you set.
      My ComputerSystem Spec

  7.    24 Oct 2016 #7

    Hi, you asked
    Any idea why this setting does not work?
    - no one suggested it was equivalent or an alternative to the pretty unique Battle Encoder Shiraz.

    Unless you can find sthg else that answers your question (I can only quote the article, not justify it) it seems no one else who's read this has any ideas. You might yet get an answer. Good luck!
      My ComputerSystem Spec


Related Threads
Not able to load webpage.PLEASE HELP in Network and Sharing
Hi guys, I am having a problem with my browser or wireless adapter. Here is the problem Whenever I try to load any website or webpage in my PC via my wireless adapter to connect to my home wifi ,the webpage just loads half or 1/4 and my browser...
as per title what i have tried is checking the installation media is good which it is checked it on another rig running windows 10. okay so what happens is it will go through the normal boot up procedure my rig that is, bios will post normally and...
Windows 10 will not load? in Installation and Upgrade
I received confirmation that i could now download the new windows 10 os. When i click on the windows icon in the bottom r/h corner of my screen it opens a box " your free windows upgrade is here .... ok lets continue" When i click lets continue it...
Mail app won't load. in Browsers and Email
As of today, the Mail app, when opened just stays on the splash screen and doesn't load. Any fix for this? I would try to uninstall/reinstall but as far as I know, Windows won't let you do that with this particular app.
MS Edge Will Not Load in Browsers and Email
Installed Win10 again yesterday after a glitch on the auto-install Wednesday. Uninstalled Win and reinstalled last night. Now, MS Edge will not open up. When I click on the Edge icon in the tray, it appears for a brief second and then disappears....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:40.
Find Us