Windows 10: One computer cannot access other network computers. Solved

Page 1 of 3 123 LastLast
  1.    04 Apr 2016 #1

    One computer cannot access other network computers.


    I have three windows 10 PCs and one NAS on my network. One PC (Lenovo 220X) and the NAS are hardwired. The other two are wireless (Surface Pro 1 and Surface pro 4)

    The surface pro 4 can see but not access either of the two other PCs. The other PCs can see and access each other and the surface pro 4. All the PCs can see and access the NAS.

    What gives? The network settings are identical (as far as I can see) and the SMB is enabled on this machine as well. for some reason, the surface pro 4 cannot connect to any other machine but every other machine can see and access it.

    Not sure what to do here. Thoughts?
      My ComputerSystem Spec

  2.    05 Apr 2016 #2

    So, I made a bit of progress last night. I was able to access the network shares from my Surface Pro 4 but only via IP address. This changes the game and I think that there is a solution to this somewhere. I'll keep working on it.

    Any help would still be appreciated.
      My ComputerSystem Spec

  3.    06 Apr 2016 #3

    What you describe (doesn't work with computer names, does work with IP addresses) almost unequivocally confirms it's a name resolution issue of some kind, probably at the NetBIOS level. I'd suggest making sure all machines are in the same local WORKGROUP, which may fix your issues all by itself. Let us know what you find or figure out.
    Good luck with your troubleshooting efforts.
    --Ed--
      My ComputerSystem Spec

  4.    07 Apr 2016 #4

    Thanks for the input. It's def not a workgroup issue b/c it's only a one way problem (ie the other machines can see and access the trouble computer by name) but it is likely some netbios issue. I've had this problem before but don't remember how I solved it.
      My ComputerSystem Spec

  5.    14 Apr 2016 #5

    So I've tried every troubleshooting step I know:
    • Double checked that Net Bios was enabled
    • Ran a bunch of network commands:
      • flushed DNS
      • registered dns
      • pinged and located the named computers successfully

    • Reset my router to factory settings


    Nothing works when I try to access via explorer. I'm still baffled by the fact that every other computer can access each other AND access this computer. It's just the outgoing connection from this machine that doesn't work.

    Any thoughts?
      My ComputerSystem Spec

  6.    16 Apr 2016 #6

    Hi there

    I needed a bit of help from Linux to sort this out using SAMBA.

    Messing around with SAMBA I found that Windows doesn't use NETBIOS any more and by disabling it from SAMBA I could connect and see rest of network.

    What you need possibly to do is disable NETBIOS -- W10 doesn't use NETBIOS any more.

    flush DNS etc on everything in the network and re-boot all computers.

    Then what does work (usually) is after a few minutes go into RUN from the menu and then type \\compname
    You should then see the rest of the network.

    After that it probably will work normally.

    Windows Networking (IMO) is still a hit and miss affair I'm afraid. I know this doesn't explain why just one machine wasn't working properly though. With Windows Networking I just do anything that fixes the problem --I can't be bothered to find out WHY there was a defect in the first place. Just get it working !!.

    Cheers
    jimbo
      My ComputerSystem Spec

  7.    17 Apr 2016 #7

    thanks for the tip @jimbo but no joy. Turning off Netbios jacks everything up. When I turn it off, everything on the network disappears (remember, I could see everything on the network and just not access the windows shares).

    With Netbios off, I can't even access my NAS which was working perfectly prior. Nothing works.

    I then switched Netbios to default, instead of enabled, and then it behaves as it did before - everyone can see and access me, I can see everyone but access only my NAS.

    back to the drawing board.
      My ComputerSystem Spec

  8.    18 Apr 2016 #8

    I'm facing the same sort of issue. Cannot share files with SP4. Can see machines fine on the homegroup, but SP4 won't open shared folders. I can access the SP4 and read/write files though.

    At this point I'm thinking it's just the SP4 being a bit crap, rather than a Win 10 issue itself. All sorts of stupid niggling little issue with this expensive, 'professional class' machine.

    Apologise to MS, it seems related to Kaspersky Internet Security. Disabling it on the SP4 enables access. KIS is also running on the win 7 machine which may be preventing file sharing on it.
      My ComputerSystem Spec

  9.    19 Apr 2016 #9

    Wait, so @Shifty, are you saying that you solve it by disabling KIS? If so, then you and I probably have different problems as I have no 3rd party security software.
      My ComputerSystem Spec

  10.    28 Apr 2016 #10

    Still nowhere on this. I've tried turning the firewall off on all machines and still no luck. I am completely baffled. I can ping the damned thing using the network name and still I can't access via name in explorer.
      My ComputerSystem Spec


 
Page 1 of 3 123 LastLast

Related Threads
Hi, I have a desktop and a laptop setup at home, I have recently upgraded both to Windows 10. Both were previously running Windows 7 Home Premium and could identify each other on the network and I could access files on either PC from one or the...
Hi everyone, I have a strange issue on my Windows 10 computer: I can only see 1 computer under my home network, but other computers do not appear at all. However, I can access them fine typing in the address bar manually. Also, for some...
I recently upgraded my upstairs desktop (formerly Windows 7) and my laptop (formerly Windows 8.1) to Windows 10. Since then I have spent hours and hours trying to get them visible to each other on my home private network (no homeGroup). I have a...
I have two laptops recently upgraded to Windows 10 (one was previously running 7, the other 8.1). I can connect both to a Homegroup, and they can access each other's files for a time, then (usually after one goes to sleep) they cannot access each...
I am locked out of other computer through the network. Originally it asked for my credentials (username/password), which did not work. I found out I have to give it the machinename\domain. So, when I entered that, I still put the wrong name (or...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:14.
Find Us