Windows 10: Can't connect to network drives

  1. Posts : 9
    Windows 10 Pro x64
       14 Feb 2018 #1

    Can't connect to network drives

    I recently lost access to my 2 network drives. Both are connected to the router via Ethernet and I myself am connected to the router via Ethernet as well. Internet access is not a problem nor is file sharing with my girlfriend's laptop connected via Wifi.

    I doubt it's router-related because my girlfriend still has access (via Wifi) to the 2 NAS. Although, I'm not sure but I think the problem started maybe after yesterday's Windows update but for which I can't find much useful information about: KB4087256 & KB4074588 (Security Update). Another reason I feel it might explain something is that my girlfriend has been unable to update her Win10 laptop for a while now because of lack of space so she doesn't have this latest update.

    There where the difference is very visible is when clicking 'Network' in Windows File Explorer. I no longer have my 2 NAS show up as 'Computer' and am therefore unable to browse them and map a drive letter to them.

    This is the way it looks on my PC now (look at top row):
    Click image for larger version. 

Name:	My Network.png 
Views:	36 
Size:	22.0 KB 
ID:	177083

    And this is my girlfriend's view from her laptop (those 2 other items in the top row are the NAS):
    Click image for larger version. 

Name:	Network.png 
Views:	36 
Size:	26.0 KB 
ID:	177084

    Any idea what could be wrong?
      My ComputerSystem Spec

  2. Posts : 642
    Microsoft Windows 10 Pro 64-bit
       14 Feb 2018 #2

    Have you tried typing the computer name or IP in " File Explorer "

      My ComputerSystem Spec

  3. Posts : 9
    Windows 10 Pro x64
    Thread Starter
       14 Feb 2018 #3

    Tried now and I get this error:

    Click image for larger version. 

Name:	Network error accessing PCH-100.png 
Views:	24 
Size:	7.5 KB 
ID:	177122
      My ComputerSystem Spec

  4. Posts : 4,963
    Win10 Home and Pro, Win10 Insider Preview, WinXP Home Premium, Linux Mint
       14 Feb 2018 #4

    Some folks have fixed it [including myself] by going to Control Panel, Programs and Features, and in Turn Windows features off or on assuring a checkmark is in SMB 1.0/CIF but also unchecking the sub entry of Automatic Removal. Having that SMB 1.0 unchecked is a default of latter updates.
      My ComputerSystem Spec

  5.    14 Feb 2018 #5

    If the machine name isn't decoding properly it's fair (and reasonable) to suspect NetBIOS name resolution problems. You could cobble up a quick LMHOSTS file to see if that's what's causing your problem. You'll need to look up the IP addresses for those two devices -- namely PCH-100 and V00-USB -- for this to work. For the following example, I'm going to give the first one an address of and the second one an address of (when you see <tab> use a TAB character instead). <tab> PCH-100 <tab> #comments are OK, but must be preceded with hashmark <tab> V00-USB

    Save the file in your text editor as "LMHOSTS" (no extension) into the
    folder. In fact, you should find a sample LMHOSTS file there named LMHOSTS.sam. Here's a nice tutorial on all the details: Easily Edit the Hosts File in Windows 10 - Petri.

    If this doesn't work -- and it very well might not -- there's more than simple NetBIOS name resolution problems involved. Indeed, turning SMB 1 back on (it's off by default in Win10 now) might help. There are lots of other fixes to try, too -- a distressingly large number, in fact!
      My ComputersSystem Spec


Related Threads
93207 As you see in the screenshot Explorer just sits there trying to load the folder I've requested. This happens, seemingly, randomly, at least I haven't been able to find a pattern. If I unmount all network drives the problem disappears....
How do I connect to a shared network drive I have setup on my Windows 2012 R2 standard server at home, from my Windows 10 pro laptop is at work? Do I have to setup a vpn on windows 2012 server and connect to it from my laptop? Someone told me...
Unable to connect to mapped drives in Network and Sharing
Well, not exactly. I have NAS drives and mapped them just like I did on my Windows 7 laptop. It all works fine and the NAS drives show up just fine in network link too. Everything is Ethernet connected. But I see anomalies. If I reboot my machine,...
I cant connect to network drives in Network and Sharing
it was working back on 10049 and then i updated to 10051 and it still was working fine. but recently i did a fresh install and now i can re add a network device i have a "New" Nintendo 3ds and i cant setup the MicroSD management which requires...
I am having this issue with a Surface Pro 3 on a dock, that when it is plugged in to a certain port it doesn't recognize the internet connection. If I take the surface to a different port and plug it in it works, if I get a different surface and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:53.
Find Us