Windows 10: Group Policy Deployment to Windows 10 Enterprise PC

  1. Posts : 3
    Win 10 Enterprise
       26 Aug 2015 #1

    Group Policy Deployment to Windows 10 Enterprise PC

    Hi All,

    I am currently testing a Windows 10 Enterprise PC to see how it performs with our companies internal applications as we are looking to upgrade to the new operating system in the future. One snag I have come across is Group Policy, we don't utilise this probably as much as we should, however we do use it to deploy logon scripts which quite simply map 3 network drives which everyone in the business has access to and additionally copies Company Handbooks, Health & Safety manual etc to users desktops. These same two tasks aren't running on the Windows 10 PC, therefore when I login there are no mapped drives and no documents on the desktop. I am no expert on GPO so really could do with some help, if I run the scripts manually (by navigating to \\domain_name\SYSVOL\domain_name\Policies\{Policy ID}\USER\Scripts\Logon) the network drives map, the documents that should copy to the desktop don't.

    I have been reading up as much as possible with regards to the administration templates, however I'm not entirely sure we use them (as when I browse to \\domain_name\SYSVOL\domain_name\Policies\{Policy ID}) there is only the following folders visible:
    - Group Policy
    - Machine
    - User
    - GPT (configuration settings)

    I'm after any real guidance that could help get this (hopefully simple task) up and running for the Windows 10 PC. All our other PC's\Laptop run Windows 7 and the scripts work as they should.

    Many thanks in advance ,

      My ComputerSystem Spec

  2. Posts : 3
    Win 10 Enterprise
    Thread Starter
       27 Aug 2015 #2

    OK, I have managed to get the documents to appear on the desktop at Logon which is one of my two goals achieved however there is still no mapped drives. Can anyone possibly shed some light on this? Do the drive mappings deploy differently to Win 10 PCs?

    Thanks again,

      My ComputerSystem Spec

  3. Posts : 3
    Win 10 Enterprise
    Thread Starter
       27 Aug 2015 #3


    To expand a little on our setup which will hopefully help the explanation, we use Win 7 Enterprise throughout the business, all PC's\Laptops run a logon script which firstly maps 3 network drives using the standard command below:

    net use P: \\Server\Share /persistent:yes
    net use R: \\Server\Share /persistent:yes
    net use H: \\Server\Share\%username% /persistent:yes
    net config server /autodisconnect:-1

    All these work as they should, however this same command is not running for the Windows 10 Enterprise PC that I'm testing.


    This same script also includes 4 lines which copies company PDF's (from a network location) to users desktops, this part of the script is working on the Windows 10 PC, it's just not mapping the drives. Does this basic script still require me to copy the ADMX and ADML files into the necessary location?

    Hope this adds to a further explanation of my problem.

    All help is much appreciated.

      My ComputerSystem Spec

  4.    16 Nov 2015 #4

    Hello try following link

      My ComputerSystem Spec


Related Threads
I am using the Group Policy Editor to disable Windows Mail and Windows Calendar. However, both programs are still available. Is the GP Editor completely worthless?
Hi, I'm trying to access my gpedit.msc again but I get this error. It was working before, but when I try it today it's not working. I try to restart, run as admin and still not working. Here is the error. 33040
Hello, I just upgraded my windows 8.1 to windows 10 home. On windows 8.1 i get a notification balloon. Now i want to get the notification balloon back in windows 10 home I can't open the group policy because windows 10 says it doesnt...
Group policy :/ in General Support
Thanks to topgundcp Which got me piddling around with the whole group/ user policy crap I have found to get rid of the silly lock screen at startup...
I am currently having an issue with OneDrive using all my bandwidth when syncing large files. As in, if I were to turn syncing on right now, I wouldn't be able to load a single webpage. I don't know if its mostly a OneDrive issue, or maybe an ISP...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:17.
Find Us