1.    4 Weeks Ago #1
    Join Date : Oct 2017
    Posts : 4
    Windows 10 x64

    Synaptics driver, can't disable palmcheck


    Hi everyone.
    I want to turn off Palm Check in my laptop, because it doesn't allow me to use keyboard and touchpad in the same time.
    I have Synaptics drivers (latest ver. v19_0_19_1__C) on my Lenovo Z50-70, Windows 10 x64 Pro, fresh install.
    I cant move the slider in the Synaptics driver menu, neither can i find the option to turn it off in windows' settings section. I simply dont have that option in the menu (maybe the most recent versions of windows dont have it? The tutorials were kinda outdated).
    What can i do in this situation? I looked for something appealing in Regedit, but no luck. Anyone have any idea what to do?

    PS. I also have Ubuntu on dualboot, but i doubt the problem is connected.
    Also, screenshots of the menus i mentioned:
    Click image for larger version. 

Name:	Untitled.png 
Views:	3 
Size:	48.3 KB 
ID:	159753
      My ComputerSystem Spec
  2.    3 Weeks Ago #2
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,006
    Windows 10 Pro Build 1703

    Hi Viral. Welcome to the TenForums @Viral

    Head to Lenovo and get your touchpad driver from them. Check driver version before and after install to ensure it takes.

    Test. If this works you will have to disable Window Driver updates.

    Ken
      My ComputerSystem Spec
  3.    3 Weeks Ago #3
    Join Date : Oct 2017
    Posts : 4
    Windows 10 x64
    Thread Starter

    If i uninstall Synaptics i still can use trackpad however all gestures don't work. Lenovo provides older version of synaptics, but its the one i updeated with the version i had posting this topic (hoping it would solve it). So i rebooted my PC and it installed the older version od Synaptics (i couldnt even install the ones downloaded from levono page, casue i had to reboot beforehand). So basically i just reverted to the older version where it occurs anyway.
    I'd like to keep the gestures functionality aswell, so disabling synaptics isn't a good solution for me...
    I find it odd, because i had it all running like a charm before i formatted my laptop 4 days ago :/
      My ComputerSystem Spec
  4.    3 Weeks Ago #4
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,006
    Windows 10 Pro Build 1703

    Try uninstalling and removing all the software. Then install the older one from Lenovo. I'm very sure this is a driver issue.

    All sub models of your device also have an Elan driver. You know for sure yours is Synaptics? (Have to ask, please excuse me.)

    Ken
      My ComputerSystem Spec
  5.    3 Weeks Ago #5
    Join Date : Oct 2017
    Posts : 4
    Windows 10 x64
    Thread Starter

    The problem is, the older one is the one having issues aswell. It's also the one that gets installed automatically when i remove the currently installed drivers :/ One of the resons I'm certain i got synaptics. Also I didn't have this problem before reinstalling Windows few days ago, with synaptics.
      My ComputerSystem Spec
  6.    3 Weeks Ago #6
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,006
    Windows 10 Pro Build 1703

    I think I would try to determine with certainty what hardware I had. If you try Elan driver and it can't find hardware it should just fail.

    Ken
      My ComputerSystem Spec
  7.    3 Weeks Ago #7
    Join Date : Oct 2017
    Posts : 4
    Windows 10 x64
    Thread Starter

    Alright, I redownloaded the drivers for different "machine type" and it updated the corrupted ones, enabling the palmcheck option. I wonder why it installed the wrong ones in the first place, heh.
    Thanks for pointing me into the right direction, otherwise I wouldnt bother to download the other one Case solved!
      My ComputerSystem Spec
  8.    3 Weeks Ago #8
    Join Date : Oct 2016
    Caledon, Ontario, Canada
    Posts : 4,006
    Windows 10 Pro Build 1703

    Hey excellent. This has always been an issue with Windows. It is a thousand percent better than is was. Several month ago I was working on a Toshiba laptop that had downloaded Lenovo touchpad. Say what??? I installed Synaptics and life returned to normal.

    Glad the forum could help.

    Ken
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Disable Palmcheck
Hello! I play games on my laptop, but the touchpad does not work if i press any button. It happened before but i fixed it. It happened again and the thing is, i forgot how i fixed it. I have been to the synaptics settings<advanced<palmcheck...
Drivers and Hardware
palmcheck (synaptic) will not disable
so ever since i updated my laptop (Toshiba) to windows 10, my palm check will not disable, i have tried around 4 versions of the synaptics palm check and none will let me disable it. even with the setting turned all the way to the left it still does...
Drivers and Hardware
Synaptics touchpad windows 10 wont disable
i understand i have asked this before, but my touchpad still refuses to disable. i have tried 5 different versions of the synaptics driver, and i believe im currently running on the best version (according to my laptop). if i go to control pannel...
Drivers and Hardware
PalmCheck won't disable
I just recently got the Windows 10 update from Windows 8, and found that changing my settings doesn't seem to work like it should. The best example of this that I can find is that even when I disable PalmCheck in this window: 28148 and save...
Drivers and Hardware
Synaptics V7.5 PalmCheck Won't Disable- No Solution?
I have a HP Pavilion laptop with Synaptics Touchpad V7.5 on a PS/2 port. The driver version is 19.0.12.95. After installing Windows 10 and updating all of the drivers, I tried playing a game and found that I can't use my keyboard and mouse at the...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:58.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums