Windows 10: Bios Oddity

Page 1 of 3 123 LastLast
  1.    19 Mar 2017 #1

    Bios Oddity


    Just built a computer and when I boot it up it takes me to the splash screen which says press del to enter bios ect. Im using a wireless usb keyboard and when I press it and the speaker makes a typing noise but nothing happens?? How can I get it to actually enter bios because it obviously detects the keyboard. I tried all usb ports. Figured this keyboard would work as it's plug and play. Bios I'm using is American Megatrends.
      My ComputerSystem Spec


  2. Posts : 5,685
    Windows 10 Pro X64 16299.192
       19 Mar 2017 #2

    Is the receiver plugged into a USB 2 or 3 port? If 3, try 2.
      My ComputersSystem Spec


  3. Posts : 320
    Windows 10 Pro x64
       19 Mar 2017 #3

    It might depend on what wireless keyboard you use and if it works properly at boot time. Ive never had one not work, but you never know what some manufacturers do. Sometimes a single press of the BIOS key isnt enough to get the system to see it. Try to keep pressing the key about twice a second once the splash screen shows up and see if that gets you into the BIOS.
      My ComputersSystem Spec

  4.    19 Mar 2017 #4

    I tried all of them.
      My ComputerSystem Spec

  5.    19 Mar 2017 #5

    Okay I did this and it says entering setup.. hopefully it works
      My ComputerSystem Spec

  6.    19 Mar 2017 #6

    and in addition to post #3 also, don't wait for the screen to come up telling you which key to press. Just start immediately pressing it after pressing the power button.
      My ComputerSystem Spec

  7.    19 Mar 2017 #7

    I press it immediatly and now it just says "entering setup" forever, then eventually powers down
      My ComputerSystem Spec


  • Posts : 5,685
    Windows 10 Pro X64 16299.192
       19 Mar 2017 #8

    Time to try a wired keyboard then look at the BIOS setup for clues maybe?
      My ComputersSystem Spec

  •    19 Mar 2017 #9

    I dont own one. It just says entering setup.. Please Help
      My ComputerSystem Spec


  • Posts : 6,975
    Windows 10 Pro x64 Build 1709
       19 Mar 2017 #10

    You said this is a brand new machine. Go basic, no drives, nothing unnecessary, one stick of memory in the right slot according to manual. If that doesn't work switch memory module.

    What motherboard are you using?
      My ComputerSystem Spec


  •  
    Page 1 of 3 123 LastLast

    Related Threads
    Solved Partition oddity with GPT in Drivers and Hardware
    I was going to do a Linux Mint upgrade and ran into a partition problem. I had an overlapping partition. I got that straightened out, but when I run Gparted I get the following message and would like to repair the partition table accordingly. While...
    Printing oddity in Network and Sharing
    I use standard "Mail" and print via wifi - normally with no problems. (Epson WF - 2510)I have one particular email which will not print from my laptop. There is no error message on the laptop or the printer. All other emails print ok That same...
    Chkdsk oddity in Performance & Maintenance
    By chance checked diskpart commands on PS and found warnings regarding both USB drives (one a micro-SD). PS C:\windows\system32> Get-Volume DriveLetter FileSystemLabel FileSystem DriveType HealthStatus OperationalStatus SizeRemaining ...
    NewsGroupsRT oddity w/W10 in Software and Apps
    After I installed W10, all my apps worked fine with the exception of a very irritating glitch with NewsgroupsRT. When replying to a message and the line auto-wraps, the cursor goes to the top of the message instead of after the last character...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 11:39.
    Find Us