Page 2 of 3 FirstFirst 123 LastLast
  1.    24 Dec 2016 #11
    Join Date : Jun 2015
    UK
    Posts : 2,250
    Windows 10 Home x64 (Laptop), Windows 10 Pro x64 (Desktop)

    Quote Originally Posted by Galane View Post
    My motherboard has two SATA controllers. C: and D: are connected to a separate controller from the other two hard drives and one DVD burner.

    C: and D: show on the remove/eject menu. How do I get them off that?

    The last, and only other, time I encountered such a problem was with XP, when SATA was the newest thing. Then I just lived with it, wasn't a fix for that particular board because nobody saw fit to fix the driver or whatever caused it. Now? There's no excuse for this error with a mature technology.
    I had that problem when I had drives connected to the Marvell SATA ports on my Gigabyte motherboard. The problem was poor driver software by Marvell. I solved the problem by moving all drives to use Intel SATA ports and disabled the Marvell ports which I no longer use.
      My ComputersSystem Spec
  2.    24 Dec 2016 #12
    Join Date : Jul 2016
    Posts : 126
    Windows 10
    Thread Starter

    I have 5 SATA drives so not using one of the problem ports isn't an option. There's something to that command here https://support.microsoft.com/en-us/kb/3083627 but there must be something it's missing because it can only fix one at a time. Change it to get rid of one and the other comes back.

    Edit: I dug into the Registry and tried that again. Now I see the problem. Each time it's entered it toggles one value instead of adding another. It's a Multi-String Value. How do I add multi-strings to it? It needs to hold both 0 and 1 instead of one or the other.

    reg.exe add “HKLM\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device” /f /v TreatAsInternalPort /t REG_MULTI_SZ /d x <-What to put in place of X that inserts both 0 and 1 simultaneously?
    Last edited by Galane; 24 Dec 2016 at 06:02.
      My ComputerSystem Spec
  3.    24 Dec 2016 #13

    Account closed as requested
    Join Date : Dec 2015
    Posts : 72
    Windows 10 Home x64 v1511, many others virtualized

    0\01\02\03\04\05\06\07 ("\0" are separators).

    See reg add /? for further help.
      My ComputerSystem Spec
  4.    25 Dec 2016 #14
    Join Date : Jul 2016
    Posts : 126
    Windows 10
    Thread Starter

    I put 0\01 in and my C: and D: still show as removable.
      My ComputerSystem Spec
  5.    25 Dec 2016 #15
    Join Date : Aug 2015
    Posts : 623
    W10 Home 1709

    Install this driver (assuming you have a 64 bit OS):
    Click image for larger version. 

Name:	Image1.jpg 
Views:	3 
Size:	276.3 KB 
ID:	114749

    Don't be thrown off by the RAID label, or the floppy disk thing. The SATA RAID driver will install the AHCI capabilities you are looking for. It will not create a RAID array automatically or anything like that.
    You have an old motherboard and Asrock has not updated their drivers since W7. But the W7 driver *should* still work for W10.
      My ComputerSystem Spec
  6.    25 Dec 2016 #16

    Account closed as requested
    Join Date : Dec 2015
    Posts : 72
    Windows 10 Home x64 v1511, many others virtualized

    Drivers mentioned above are for blue SATA ports, not for white ones. Don't use them.

    White ports are connected to Marvell SATA controller. Which driver do you use for it, Marvell SATA or Standard SATA AHCI driver? If Marvell one, replace with the second one and restart.

    In regedit, check HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Enum - is there value of ypur Marvell controller? (PCI\VEN_1B4B.....) If not, you have to find where it is.

    Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\storahci\Parameters\Device (or similar). If TreatAsInternalPort multistring does not exist, create it manually. Fill it with numbers 0-7, each one at separate row.

    Restart.

    Click image for larger version. 

Name:	1.png 
Views:	11 
Size:	27.2 KB 
ID:	114769

    Click image for larger version. 

Name:	2.png 
Views:	11 
Size:	41.9 KB 
ID:	114770
      My ComputerSystem Spec
  7.    25 Dec 2016 #17
    Join Date : Jul 2016
    Posts : 126
    Windows 10
    Thread Starter

    Found it at HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\mvs91xx\Parameters\Device

    Added the value TreatAsInternalPort
    Tried 0 and 1 each on a separate line. Does not work. Regedit deletes all but line 1 and both drives still show as removable. Next I tried 0\01 and that also doesn't work, but Regedit does not delete any of it. 0\1 is rejected by Regedit as an "empty string".

    Looks like the Marvell driver is expecting to be told a different way. :P
      My ComputerSystem Spec
  8.    25 Dec 2016 #18
    Join Date : Jul 2016
    Posts : 126
    Windows 10
    Thread Starter

    This may be onto something. Get the Policies tab to appear on the Properties for the Marvell controller.
    FIX: AHCI/SATA drives showing in "Safely Remove Hardware" - Page 5

    Tried that, doesn't work, but it's not specific to Windows 10. (Also repeats of the TreatAsInternalPort things that's not working.)

    It's using the driver provided by Microsoft, according to the Details button.

    More info on the policies, that also didn't work to fix this Driver "Policies" Tab not showing in Windows - Super User
      My ComputerSystem Spec
  9.    25 Dec 2016 #19

    Account closed as requested
    Join Date : Dec 2015
    Posts : 72
    Windows 10 Home x64 v1511, many others virtualized

    Marvell driver mvs91xx (including one provided by MS) does not accept TreatAsInternalPort switch. Create restore point, then replace Marvell with Standard SATA AHCI driver which is part of Windows (use Update Driver button). Then insert all the eight numbers, not only two, into the right value in registry and restart.

    That's all from me, because you don't follow recommendations, although they are tested on other computer with Marvell controller and AHCI driver - see the picture.

    Click image for larger version. 

Name:	3.png 
Views:	26 
Size:	10.1 KB 
ID:	114820
      My ComputerSystem Spec
  10.    25 Dec 2016 #20
    Join Date : Aug 2015
    Melbourne
    Posts : 231
    Win 10 Pro X64

    For whatever it's worth try the following and hope it helps
    go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e97b-e325-11ce-bfc1-08002be10318} When you find this you'll have some folders for that reg key look for the one with Marvell all over it then make a new string value and name that DriverPolicySet and set the value as 1, then make 1 more new multi string value and name that IncludeInfs with a value of: machine.ini
      My ComputerSystem Spec

 
Page 2 of 3 FirstFirst 123 LastLast


Similar Threads
Thread Forum
Internal drive wrongly shown as removable
There is an icon in my tray to "Safely remove hardware and eject media". It is always there (even when no USB devices are plugged in) because Windows thinks my second internal SSD is removable. Is there a config setting or a registry edit to fix...
Drivers and Hardware
USB3.0 Issues and Internal HDD shows as removable
Hi all, I'm running Win10 64bit. My sig has all my system details. I use 2 SSD's and 1 internal HDD. Issue 1: My internal 2TB HDD is displayed in Device Manager as Portable Devices. This HDD hosts my User's Folders. Issue 2: I have an...
Drivers and Hardware
Solved New W10 Install - Hard Drives Show Up As Removable
I just completed an update installation on a desktop PC running Windows 7. Now my hard drives show up as removable drives. Normally this is due to the need to install an AHCI driver. And that is normally the Intel Rapid Storage Technology Driver...
Drivers and Hardware
Upgraded to 10, now none of my internal SATA hard drives show up in Ex
Hi, first post here. Looking for some help on a crazy issue where none of my other internal SATA hard drives are mounting and showing up in Explorer. I have 4 of them that are powered up, show up in Disk Management, but I cannot do anything with...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:16.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums