Windows 10: 'Safely Remove' - Blocked by unknown program Solved


  1. Posts : 71
    Windows 10 Pro x64 1607 (14393.693)
       14 Dec 2016 #1

    'Safely Remove' - Blocked by unknown program


    I have three external USB-3 HDDs connected via a powered USB-3 hub. Sometimes, not always, I am blocked from unplugging the hub from the PC because a program is using at least one of the HDDs. How can I determine what is preventing the 'Safe Removal' and forcing me to shutdown the PC? I do terminate all programs I have started and I have tried using Process Explorer but it shows nothing beyond PID 4 System.
      My ComputerSystem Spec

  2.    15 Dec 2016 #2

    With a hub it's all only one device no matter how many things you have plugged in, you can safely remove whole thing only, not only one device.
      My ComputerSystem Spec


  3. Posts : 71
    Windows 10 Pro x64 1607 (14393.693)
    Thread Starter
       15 Dec 2016 #3

    I think somewhere there is a miscommunication.

    I want to unplug all of the USB HDDs at the same time, therefore I use the 'Safely Remove' icon to dismount each of the HDDs. Then, when they ready, I unplug the hub.. I don't believe that it would be a good idea to just unplug the hub willy-nilly.

    What I am looking for is a means to identify what is preventing the dismount of a USB HDD.
      My ComputerSystem Spec


  4. Posts : 3,098
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint
       15 Dec 2016 #4

    I'd open File Explorer, right-click each drive and choose Eject, should give a message when one is tried that is holding things up.
      My ComputerSystem Spec


  5. Posts : 71
    Windows 10 Pro x64 1607 (14393.693)
    Thread Starter
       15 Dec 2016 #5

    I'm sorry but that won't work. 'Eject' is not available as an option in File Explorer for my USB 3 HDDs. One way I have found to force the issue is to go into Disk Management and take the each disk offline, but that is a pain because I then have to put each disk back online when I replug them.
      My ComputerSystem Spec

  6.    15 Dec 2016 #6

    yea, that can be a tough one to figure out. Sometimes I've found OpenedFilesView helpful (displays a list of open files, file handles and the the process that has it open). But also times the tool didn't show anything that helped. fyi.. I've found some background processes don;t seem to show up in the tool

    fyi.. sometimes i've also found it to be my a/v or other real-time tool i run that's scanning files in the background. I also run CrashPlan for continuous backups. Crashplan can also keep a large file locked while it backs it up in the background. Moral: Try identifying what programs you run that scan files in the background. Try disabling them when the problem occurs. Can take a short while (maybe up to 30 seconds? don't recall for sure) before disabling has made an affect.

    Of course, there are still (many) times when i can't figure out the culprit and have to shutdown to safely remove
      My ComputerSystem Spec


  7. Posts : 2,276
    10 Home x64 (1703) (10 Pro on 2nd pc)
       15 Dec 2016 #7

    When I've had the 'in use' message on trying to eject USB HDD's it's almost always been Task Manager that was the program keeping them open. Closed it and I could then eject.
      My ComputersSystem Spec


  8. Posts : 71
    Windows 10 Pro x64 1607 (14393.693)
    Thread Starter
       16 Dec 2016 #8

    Yes, an old problem, but I only run Task manager as and when I need it. Also, it's not all three of the HDDs that are hanging, usually it's only one, often a different one everytime.
      My ComputerSystem Spec


  9. Posts : 71
    Windows 10 Pro x64 1607 (14393.693)
    Thread Starter
       12 Jan 2017 #9

    OK, I have solved my problem. I haven't found a way of determining what is holding the USB drives up, but I have found out what was causing my problem.

    A little background.
    I use Calibre to manage my collection of digital books, and to transfer the books to my Kindle via USB. Lately I have been in the habit of using the Calibre facilities to eject the Kindle when any transfers were done. This was the mistake. Now I have gone back to shutting down Calibre and using the 'Safely Remove' icon to eject the Kindle and the problem went away.
      My ComputerSystem Spec


 

Related Threads
I have a tablet with 32gb internal memory. I bought s 64gb MicroSD card that has my Onedrive folder and system libraries on it. I will use a dab of hot glue to semi-permanently lock it in, as I have no intention of ever removing it. But the SD...
I was in the process of updating several sata controllers and chipset drivers. I also installed a new USB 3.0 hub and was in the process of moving around several devices between ports. I had a problem with my keyboard which uses USB 2.0 as a...
Hey guys! I'm trying to install a program but Windows says the publisher's been blocked. Problem is that there's no button to unlock it. There's just an OK button. Is there a way to go around this?
Safely Remove usb in General Support
Hi All All's good so far with Windows 10 upgrade, after coming here not been able to activate Windows but thanks to this site I was able to find a resolution, clicking like mad on the Activate button done the trick sounds weird but it worked :D...
How to safely remove W10? in Installation and Upgrade
I installed W10 in a E: partition and after trying it I prefer to remove it. I had boot problems lately in this laptop after formating and deleting the partition as I have always done to get rid of some testing OS. It didn't boot at all and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:28.
Find Us