Page 1 of 2 12 LastLast
  1.    15 Nov 2015 #1
    Join Date : Sep 2015
    Posts : 78
    Windows 10

    Audacity Error Initializing Audio when I have USB audio interface on


    A week ago I wasusing Audacity without any problems. Then midweek (Wed/Thursday) 11/11 or 11/12I launched Audacity and received the message "Error Initializing Audio.Could not find any audio devices. You will not be able to play or record audio.Error: Internal PortAudio error".
    I read several postsin this forum and on www.tenforums.comthinking "what changed" did a patch come out? In the process ofreading and trying to figure out what happened. I did the following.
    I am running Windows10 Pro 64 bit. I have been on Windows 10 now since the free upgrade in Augustwith no issues related to Audacity.
    I was on Audacity2.1.0 and I upgraded to 2.1.1
    I updated my RealtekHigh Definition Audio drivers to Version 6.0.1.7655 11/3/2015.
    I saw one post aboutRealTek HD Manager not have the Default Format set. I checked that and it wasokay.
    I have soundproduced through iTunes, Internet music streaming so everything checks on that.
    Because I play musicI use Cakewalk Sonar and use M-Audio Fast Track Ultra USB audio interface. Idecided to power that down and to my surprise Audacity came up without the errormessage and it showed the Audio Device info.
    I have notPersonally installed any new programs or updates on this computer except forwhat I mentioned above. I did notice that there have been some Windows patchesinstalled recently but nothing Windows 10 related. Just Printer, MS Office andWindows Malicious Software Removal Tool.
    Have there been any patches lately that could have caused this?

    Any thoughts?
    Thanks

    I posted this message on Audacity's forum site as well.
      My ComputerSystem Spec
  2.    15 Nov 2015 #2
    Join Date : Jan 2014
    Inverness
    Posts : 1,198
    Win 10

    I have a Sonar Platinum studio (using a Roland Studio-Capture).

    Normally (without any recording interface unit) Audacity defaults to the "Stereo Mix" (which should be set as the default recording device).

    With my Studio-Capture powered on, Audacity on my Win 10 Pro 64 bit the default recording device is still Stereo Mix (see screenshot below). I used to have an M-Audio Fastrack Ultra 8R and don't recall the problem you are having.

    Click image for larger version. 

Name:	Capture.JPG 
Views:	17 
Size:	38.9 KB 
ID:	48360
      My ComputersSystem Spec
  3.    15 Nov 2015 #3
    Join Date : Sep 2015
    Posts : 2,372
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    I think Audacity is set to "default windows source" or similar and has problem to identify the source when your USB audio card is connected. Try setting it to a specific device from settings and then connect your USB. If it can start without issues you could then change the device to your USB.
      My ComputerSystem Spec
  4.    15 Nov 2015 #4
    Join Date : Sep 2015
    Posts : 78
    Windows 10
    Thread Starter

    @fireberd. I do have Stereo mix set as recording default. And this was working last week so I don't understand what changed.
    Click image for larger version. 

Name:	Audio recording settings.jpg 
Views:	15 
Size:	48.7 KB 
ID:	48373 @spapakons, I'm not sure I understand what you are suggesting. Could you re-phrase your statements.
      My ComputerSystem Spec
  5.    15 Nov 2015 #5
    Join Date : Sep 2015
    Posts : 2,372
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    I mean, if there are any settings inside Audacity, you can try setting the recording source to a specific device, not let it in "windows default". Then it should use this device even when you have your USB card connected without error messages upon loading. When inside Audacity with your USB connected you can then change the recording source to your USB.
      My ComputerSystem Spec
  6.    15 Nov 2015 #6
    Join Date : Sep 2015
    Posts : 78
    Windows 10
    Thread Starter

    Understood. If I have my USB audio interface connected and turned on, I get the error launching Audacity and there are no devices available to select.
    Click image for larger version. 

Name:	Audacity Audio device info.jpg 
Views:	18 
Size:	30.9 KB 
ID:	48393
    If I turn of the audio interface I see the devices in Audacity.
      My ComputerSystem Spec
  7.    15 Nov 2015 #7
    Join Date : Sep 2015
    Posts : 2,372
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    Well, I haven't Audacity installed, so I cannot help you further.
      My ComputerSystem Spec
  8.    15 Nov 2015 #8
    Join Date : Jan 2014
    Inverness
    Posts : 1,198
    Win 10

    I can't duplicate your problem with my Roland Studio-Capture. Audacity always defaults to the Stereo Mix when I start Audacity.
      My ComputersSystem Spec
  9.    15 Nov 2015 #9
    Join Date : Sep 2015
    Posts : 78
    Windows 10
    Thread Starter

    Thanks for trying firebird.
      My ComputerSystem Spec
  10.    16 Nov 2015 #10
    Join Date : Sep 2015
    Posts : 2,372
    Windows 10 Pro 64-bit 1706 (CU build 15063.674)

    As I said before, try loading Audacity with the USB disconnected. Once there, look carefully at the settings/preferences/configuration (whatever is called). There should be a setting to select input and output source. Normally this is "windows default" or similar. Change it to a specific device so Audacity always uses this device ignoring any other devices. Close the program and connect your USB. Since Audacity now uses a specific device, it shouldn't search for other devices and give any error. Once successfully running Audacity with your USB connected you can then change the input and output to those of your USB from the same setting.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Realtek HD Audio onboard audio not displaying at all
Hello! After upgrading to windows 10 I was going through my Audio settings, I had noticed that the HD Audio from my motherboard both front and rear jacks are not displayed at all in the device manager nor the audio tab in control panel - it's as...
Drivers and Hardware
Announcing Dolby Audio for high performance audio in Microsoft Edge
Source: http://blogs.windows.com/msedgedev/2015/05/26/announcing-dolby-audio-for-high-performance-audio-in-microsoft-edge/
Windows 10 News
strange audio, missing enhancements in audio settings
hello, since ive installed windows 10 on my macbook, ive had a few driver problems. one really annoying one is sound. it works but the options in playback devices are missing such as the enhancements. i use speaker fill but the option is...
Drivers and Hardware
Realtek HD Audio audio output speaker issue on Windows 10 RTM 10240
Hello Everyone. I have a Jabra bluetooth speaker (the Solemate Mini). On Windows 8.1 I plug it in to my laptop using the 3.5mm to 3.5mm cable and then, when I watch a movie, it correctly outputs to the speaker and does not use my laptop speakers....
Drivers and Hardware
Solved Need audio driver for VIA VT1708S onboard audio.
My ASUS M4N68T-M V2 has a VIA VT1708S onboard audio. The driver I have that worked in Windows 8.1 v10_1200a won't work in 10. Windows doesn't even see the onboard video so it doesn't even look for a driver. It doesn't show up in device manager. In...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:41.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums