Really Bad Mouse Lag

Page 1 of 6 123 ... LastLast

  1. Posts : 17,133
    Windows 10
       #1

    Really Bad Mouse Lag


    Hi folks,

    I've been having a lot of trouble with my mouse lagging. Just moving it across the screen will sometimes cause it to lag. I wouldn't say that there is anything specific causing it sense it happens when I'm browsing the web, managing files on my desktop, and sometimes when I'm gaming.

    I know it's a problem with Windows 10, because it doesn't happen on 8.

    Any suggestions or should I notify MS. And see if they even take the time to read...

    -Chuck

    EDIT: This is the mouse I have. http://www.microsoft.com/hardware/en...t-desktop-5000
      My Computer


  2. Posts : 983
    Windows 7/64 Professional
       #2

    Have you installed Microsoft Mouse and Keyboard Center?
      My Computers


  3. Posts : 17,133
    Windows 10
    Thread Starter
       #3

    It doesn't show up in my programs, so apparently not. I'll go download it.
      My Computer


  4. Posts : 17,133
    Windows 10
    Thread Starter
       #4

    Downloading...
      My Computer


  5. Posts : 17,133
    Windows 10
    Thread Starter
       #5

    Alright, downloaded and installed. Now what?
      My Computer


  6. Posts : 2,790
    Linux Mint 20.1 Win10Prox64
       #6

    Try another battery to see if it helps.
      My Computer


  7. Posts : 17,133
    Windows 10
    Thread Starter
       #7

    topgundcp said:
    Try another battery to see if it helps.
    I have done that.
      My Computer


  8. Posts : 5,280
    Win 10 Pro x64
       #8

    Do you have anything else plugged in on your pc? Like headset, other USB devices, etc. Try unplugging them and see.
      My Computer


  9. Posts : 17,133
    Windows 10
    Thread Starter
       #9

    The only other things I have plugged are my external speakers and my wireless network adapter.

    I need my adapter plugged in to be able to keep y'all informed.
      My Computer


  10. Posts : 983
    Windows 7/64 Professional
       #10

    After installing it check Windows Updates. Then just use the settings in the program to set your speeds ect.
    If that doesn't work their is something else on you system that is causing your problem. I have the same mouse on W-7 and W-10 with no problems.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:47.
Find Us




Windows 10 Forums