Windows 10: Devices and Printers Icons missing following update to Windows 10 Solved

Page 1 of 2 12 LastLast
  1.    22 Aug 2015 #1

    Devices and Printers Icons missing following update to Windows 10


    I'm posting this in case it helps others encountering the same problem. I spent three or four days on this without success. Google searches on this forum and generally on the web and Microsoft came up with no working solution - although it appears to be a problem that has afflicted Windows 7 and Windows 8 users too. I finally solved the problem by comparing the services list of the PC with the problem to that of a PC that did not have the problem.

    I updated three Windows 8.1 PCs to Windows 10. All updates went fine but one PC had an annoying problem that (finally) I have now solved. This was a brand new Lenovo PC out of the box with Windows 8.1 pre-installed. My first step was to run the free upgrade to Windows 10. This appeared to work fine with one (at least so far) problem - all the following are related:
    1. In Printers and Devices (in the control panel) no icons for printers appeared after I installed them. The default printers like fax or PDF printer (pre-installed) did appear but a directly connected printer, a wireless printer and network printers did not appear after they were installed following the Windows 10 upgrade. However the printers did appear in Device Manager and in the print menus for programs (e.g. MS Word). And printing worked as normal. Uninstalling and reinstalling printers did not work. Nor did changing drivers (through Windows). These were all Windows 10 "approved" drivers in any case (and Windows would tell me the best driver was already installed).
    2. Trying to uninstall one of the printers that did appear (by right-click on the icon) would not work. The printer and the icon were unchanged. (I tried this because one forum thread I found suggested that a particular PDF printer driver "broke" Devices & Printers. Nonsense.)
    3. After a couple of days I spotted that the safely eject USB stick icon did not work properly. When a USB stick was inserted the safely eject icon would appear in the tray but either the device did not show or it was greyed out. The only way to eject was to use the right-click context menu from Windows explorer for the USB drive letter.


    Solution
    The problem turned out to be a Device service not running.

    • Right-click on "This PC" and pick "Manage" to open Computer Management. (I am using Classic Shell for a start menu so how you get to Computer Management may be different - you could try search from the start menu to get a link to open the console).
    • Open "Services" (under Services and Applications). In the main window of services scroll down until...
    • You should find five "Device" services: "Device Association Service", "Device Install Service", "Device Management Enrollment Service", "Device Setup Manager" and "DevQuery Background Discovery Broker". The first, third, fourth and fifth should have a startup type of "Manual (Trigger Start)". "Device Management Enrollment Service" is just "Manual".
    • On the problem machine the "Device Install Service" was shown as disabled. I set this to "Manual (Trigger Start)" (from the properties). (I have been typing so long now that I forget whether it was this or one of the others that was disabled - pretty certain it was this. In any case enable manual start for all of them and make sure none are disabled.)
    • After checking and (if necessary) changing the service startups, reboot the machine.


    Now check the Devices and Printers folder: all the missing printer icons should appear. I found that there were other things missing too that now appeared - e.g. a network NAS drive appeared that I had not realised was missing.

    Plug in a USB stick. You should find that now the eject device safely icon appears correctly in the system tray with the USB device and drive letter and clicking eject works as it should.

    I hope this helps anyone else who experiences the same frustrating bug.
      My ComputerSystem Spec

  2.    04 Nov 2015 #2

    Do you know of there is a way to get the Devices and Printers listed in the right click of the W10 Start Menu? It would be much faster to look at a problem printer if I did not have to go to the Control Panel. It would also work almost like all of the other Start menus in the past.

    Forget it as I found a way to get Devices and Printers into the My PC display:

    https://www.tenforums.com/tutorials/2...dows-10-a.html

    Thanks,
    Z
    Last edited by caveman88; 04 Nov 2015 at 09:39.
      My ComputerSystem Spec


  3. Posts : 2
    Windows 10 Home 64-bit
       23 Nov 2015 #3

    Hello Sam56. Thanks for posting your steps so all printers will display in Devices and Printers within Control Panel after the Windows 10 Upgrade is installed. However, those steps did not work for my PC after installing the newest-version 1511 Upgrade of Windows 10 yesterday (11/22/15). I made each change as you wrote them out, starting each service and setting them all to manual as needed, but once I restarted my PC, not only did my printer still not display in Devices and Printers, but those 5 services were reset back after the restart. I then tried starting them again and setting them all to automatic, but that must have caused a conflict because my PC restarted in "slow motion." Once it was finally up so I could look at Devices and Printers, my printer still was not displayed. To get my PC to right itself and run properly, I had to restart it again. And again, my printer was not there. As you mentioned, the printers embedded in Windows 10 are visible (Fax, Microsoft Print to PDF, Microsoft XPS Document Writer, and Send to One Note), but that's all. My printer runs, is set as the default, is visible in print-command dialogue box drop-down menus, etc., but that's it. I have no direct access to its driver. Another PC in my household that was running Windows 7 Home 64-bit, and got its Windows 10 Home 64-bit Upgrade a few months ago, has an external USB-connected printer that DOES show in Devices and Printers. The workhorse photo-quality printer I am using is my 1999 HP Deskjet 932c, for which HP no longer offers more than having Windows 10 identify it and load its basic driver from there, which it does do. The other printer that displays properly on the other PC is a 2008 Epson Stylus CX9400Fax 4-in-1 printer. So, to see what would happen, I disconnected the Epson from the other PC and connected it to mine. My PC loaded it and there it was, displayed as it should be in Devices and Printers. So, between never getting to see if your steps would make my HP printer visible because Windows 10 would not save the changes on restart, and the fact that my HP printer is 16 years old now, I'm wondering if the printer is simply too old for Windows 10 to "see" it in a way where it can display it, or, if there is still some kind of Windows Update patch from Microsoft, or another kind of hack to Windows 10, that would make it display like the Epson one does? In the meantime, all I've been able to do is click on "Add a Printer" in Devices and Printers, let windows populate the printer list so mine is among them in the menu of brands/models to choose from, and manually add it. However, that creates a "Copy 1" of the printer driver because it is the same driver, same port, and same printer. If I try to use the visible Copy 1 printer to print, it won't print unless I change its port from LPT1 (that the original driver uses) to USB001 (it also failed to print when I tried using port LPT2). As soon as I do that and/or set it as the default printer, it too disappears from Devices and Printers. The outcome is that the Copy 1 printer cannot be made useable without it dropping out of sight so both it and the original HP 932c no longer show. What's left - so far - is that I added the Copy 1 of my HP printer driver in Devices and Printers so the printer is visible there, and its driver's properties can be viewed by right-clicking on it, but I have to leave it disabled for it to remain visible. At least then I can see a representation of it, although I can't use any of the driver options in Copy 1 since it cannot be enabled to remain visible. Of note is that the Copy 1 driver shows in Device Manager under "Print Queues", but NOT under "Printers", even when I click the "View" option in Device Manager so that all hidden entries also show. I am not tech savvy enough to know what impact that has on all of this, but after reading what I've done and encountered, I would appreciate any replies you - and/or anyone else reading this - has. Is it just that my HP printer is too old, or is there still something that can be changed so Windows 10 will display it? Thanks for any help you can offer.
      My ComputerSystem Spec


  4. Posts : 2
    Windows 10 Home 64-bit
       23 Nov 2015 #4

    Duplicated message.
      My ComputerSystem Spec

  5.    04 Dec 2015 #5

    I have this problem too.
    Some Icons have started to reappear but most of them are still the generic ones. This was totally stuffed on Win7 - I had to manually set each icon myself. Are we back to that?

    I tried starting the Device Install Service but no go.
      My ComputerSystem Spec

  6.    04 Dec 2015 #6

    The method I found in post #2 worked again. I guess I will have to add this to a list of thinks to check after a new build.

    Windows 10 is not going to be a easy Windows edition to keep up with.

    Z
      My ComputerSystem Spec

  7.    03 Jan 2016 #7

    Any solutions for the latest Win 10?


    Nevermind.

    I thought there was a solution. There isn't. I have same problem as BKO772
      My ComputerSystem Spec

  8.    06 Jan 2016 #8

    In addition to the post from Sam56 . It worked for me but then I had manually to configure the port of every printer. i.e. in Control Panel > Device and Printer, right click on the printer => Printer properties. Choose port and either add a new port or configure one of the old ones. In this case you shall know the exact IP for the printer (if it's a network printer). If it's a local printer then choose the correct port (local, or COM or USB).
      My ComputerSystem Spec


  9. Posts : 1
    Win10 Ent eng 1511
       12 Jan 2016 #9

    I have the same issue. My "EPSON Stylus Photo 2100" is showing in "Device Manager" under "Print queues" and "Printers" but no icon in "Devices and Printers". Has anyone managed to fix this problem?
      My ComputerSystem Spec

  10.    22 Jan 2016 #10

    Yep, me too.


    Used to be that when I plugged in a printer there would be an icon appear so that I could manage that printer. Not with Win10!
    Like others I have Installed a new printer & that now appears in Devices and Printers. Printing a document now gives the option of [Printer] plus [Printer (copy)]. I have tried the option at top of thread including setting Devices to Automatic. Still not working.
    Just going to re-boot to see if that has any beneficial effect.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
devices & printers in Drivers and Hardware
Control Panel > Devices & Printers takes about 30 seconds to open. Any idea why? Never had this issue in previous Win versions. Thanks! ...Steve
Never seen this before in other OS, just noticed when i hook up my external WD Ultra Passport no icon shows in Devices and Printers just square white icon, same happens in notification area under Safely Remove. Also in Devices and Printers my Epson...
Hi I've just upgraded to build 10240 and have found I cannot access Devices and Printers and I need to install a new printer driver as well as remove unwanted drivers for devices I do not have. I've tried all sorts of ways to access the dialogue...
I had two printers hooked up in wireless mode, a Samsung ML-2525W and a Brother inkjet MFC_J870DW. Both were working fine until the recent update and both dropped off the network. I reinstalled the driver for the Samsung and providing I have it...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:59.
Find Us