Windows 10: Sound Issue in Windows 10 with Sound Blaster X-Fi Titanium

  1.    01 Aug 2015 #1

    Sound Issue in Windows 10 with Sound Blaster X-Fi Titanium


    Hello --

    After I upgraded to Windows 10 from 7 Pro, there was no sound. Obviously, Creative Labs has yet to release compatible drivers for many of their sound cards. Nevertheless, I found out that I'd make it work by changing its modes back and forth via its Audio Control Center. I have to do this every time I reboot the system.

    Do you think the problem is with the driver or Windows itself? If it's the driver, why world it work simply by re-setting / changing its option?

    Thanks in advance!
      My ComputerSystem Spec

  2.    01 Aug 2015 #2

    I too have the same issue only for me no one seems to be wanting to help me out with this one for some reason. I have a x-fi titanium pci express and I still would like to know why it has been taking so long for creative to get off their duff and get the windows 10 drivers and software out prior to its release this past wednesday because right now I have sound from only 1 speaker even though I have a 5.1 audio surround speaker setup for my pc.
      My ComputerSystem Spec

  3.    01 Aug 2015 #3

    Well, at least it's working, albeit partially.
      My ComputerSystem Spec

  4.    02 Aug 2015 #4

    yea; its only working partially for me too even though I configured it for 5.1 sound. And the sound is really low and crackling too.
      My ComputerSystem Spec

  5.   My ComputerSystem Spec

  6.    02 Aug 2015 #6

    Taurean75 said: View Post
    Hello --

    After I upgraded to Windows 10 from 7 Pro, there was no sound. Obviously, Creative Labs has yet to release compatible drivers for many of their sound cards. Nevertheless, I found out that I'd make it work by changing its modes back and forth via its Audio Control Center. I have to do this every time I reboot the system.
    I had the same issue, even with Daniel_Ks SB X-Fi series support pack 3.4. When Googling the issue I found people have the same issue when Windows Vista came out and there were two solutions that seemed to work for people.

    The first was to go to C:\Program Files (x86)\, right click on the Creative folder and go to properties -> security and give all Groups and User Names full control over the folder. The second was to swap modes to bring your sound back and then put the computer to sleep for five minutes.

    I tried both solutions in the order I posted them above so I'm not sure which one actually fixed my problem, but since I did them I have had no issues with my X-Fi Tatanium Fala1ty in Win 10 at all.
      My ComputerSystem Spec

  7.    02 Aug 2015 #7

    I tried both of them without success. The second one only worked temporarily. What I had to do was remove all previous drivers using a third-party software AND reinstall Creative software suite by Daniel. Now everything's normal -- at least for 2.1 speakers set up.

    I think it's both driver and permission issues.
      My ComputerSystem Spec

  8.    13 Aug 2015 #8

    Creative drivers.


    Matt Siegel said: View Post
    I too have the same issue only for me no one seems to be wanting to help me out with this one for some reason. I have a x-fi titanium pci express and I still would like to know why it has been taking so long for creative to get off their duff and get the windows 10 drivers and software out prior to its release this past wednesday because right now I have sound from only 1 speaker even though I have a 5.1 audio surround speaker setup for my pc.
    Simply put, they wont. Why would they want to spend thousands of man hours creating drivers for the millions of audio cards out there, when it would be far more profitable for them to do what they did when Windows XP, and Windows 7 came out? I too bought an X-Fi Titanium PCIE sound card when Windows 7 came out, and, that will be the last sound that I buy. If they can NOT make drivers for my 2 year old card that I paid $200 for, well, I guess I will be using the onboard sound that comes on the mobo. I'm not spending $200 for an audio card every time MS comes out with a new OS. My gaming PC still rocks with a quad core 3ghz CPU, 16 GB of ram, an R9 video card. I'm certainly not going to throw down money for another audio card.........
      My ComputerSystem Spec

  9.    14 Aug 2015 #9

    I am also considering ditching the Creative Labs soundboards for the same reason, It seems like with every OS upgrade they have the same issues and expect us to purchase new hardware. My computer was purchased in 2009 so have gotten good use out of, but other vendors provide better support.
      My ComputerSystem Spec


 

Related Threads
Solved No sound from sound blaster in Drivers and Hardware
I just installed the most recent windows 10 tech preview last night; but my sound blaster pci express sound card did not get installed correctly or something because i am getting no sound at all. Please help me fix this before I roll everything back...
sound blaster on build 10240 in Drivers and Hardware
I cannot get my surround 5.1 audio to work with this most recent build of 10240; and i cannot get into the enhancements that are supposed to be available for my card which is the x-fi titanium pci express sound card from creative. Is there any way...
Solved sound blaster in build 10166 in Drivers and Hardware
I can not get my sound blaster x-fi titanium pci express sound card to give me sound through the right channels even though Ive uninstalled the support pack for 5.1 surround audio that was compiled from another sb user that did work in the last...
When I first went from W8.1 to W10, everything worked except the sound. Now after several updates, the icon speaker in task bar has an x by it, and when I hover mouse over icon the message states that "no audio output device is installed." When I...
Sound issue in General Support
Hello fellow windows 10 users. So today I found out that my sound is acting very strange. Let me explain, my sound works perfectly normal on the internet(youtube) and on skype. But when I try to use an application like Minecraft, Counter Strike...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:00.
Find Us