BSOD results in endless loop and no access to drive Solved

  1.    #1

    BSOD results in endless loop and no access to drive

    Hi Guys,

    I have yet another Win10 BSOD problem.
    Haven't previously had any success with getting up and running with all my apps and settings intact.
    Have had to completely reinstall Win10 three times since mid June. (At least two previous episodes resulted from now corrected power supply issues.)

    Current problem began when I selected a Restart from the menu following an Emsisoft upgrade.
    Wanted to see if this time I could recover without having to re-install all my apps and settings.
    Found myself in an endless loop of 'Diagnosing your PC" etc, but no progress.

    While looking for my Win10 Boot USB, found one that booted up to Macrium Reflect.
    Accepted Macrium option to repair the boot sector.
    Now booted up to a different BSOD - complaining about lack of access to WINDOWS\SYSTEM32\Winload.exe

    Attached, and booted from, old Win8.1 HDD; as expected (and hoped!) all my Win10 partitions and data contents show up intact (I have D:, E:, G:, H: on a 1Tb HDD, and but for the odd app that insists on it, no data files are on C:.)
    Copied winload.exe from my partners Win10 PC to I:\WINDOWS\SYSTEM32\Winload.exe; no change - same complaining BSOD on Win10 reboot.

    Wondered if booting into safe mode may give me some options, but have never had success trying F8.
    Found and followed instructions on How to Get to Safe Mode in Windows 10 - Windows 10 for BCDEDIT /SET {SETDEFAULT} BOOTMENUPOLICY LEGACY
    An F8 reboot took me to 'WINDOWS BOOT MANAGER", with a black screen stating "Windows failed to start. A recent hardware or software change might be the cause. To fix the problem..." and then the text about using my installation media.

    I booted to Win10 USB, selected Repair from the second screen, then Troubleshoot > Advanced options.
    Startup Repair fell into an apparently ineffective "Attempting repair" which was endless... So I rebooted.
    Selected Troubleshoot > Reset to retain apps and settings; but the message is, "The drive where Windows is installed is locked. Unlock the drive and try again."
    So I checked again under Win8.1, and the 1Tb Win10 drive is still visible and accessible.

    Another F8 Safe mode boot took me back to WINDOWS BOOT MANAGER black screen. I pay more attention to a message lower on the screen:-
    "Status: 0xc000000e
    "Info: A required device isn't connected or can't be accessed."

    Back to Win10 USB, and similar info appears on a BSOD like the one previously complaining about winload.exe.
    I suspect that at least part of the problem may be the result of what Macrium did to the boot sector.
    So I'm stuck (except I suppose for doing a re-install yet again - and I've backed up the user settings on C: in anticipation!).

    One other fact which may be relevant/ helpful to a resolution.
    Ever since my last reinstall, my boot sequence includes an OS selection with two Win10 options. The first is labelled 'Win10'; the second one is labelled 'Win10 on Vol2'

    During the above troubleshooting, a similar selection (just without the 'on Vol2') appears. Selecting the second one avoids the message about the drive being inaccessible, and proceeds to 'Diagnosing... Attempting repairs', endless, with no progress. Very weird.

    If I have to do another complete reinstall (and then redo all the settings and apps over again), how can I eliminate the OS option screen with two choices for Win10?

    Any ideas/contributions will be much appreciated. And sorry but I obviously cant upload a diagnosis file.
    Last edited by okkid; 23 Oct 2016 at 23:40.
      My ComputersSystem Spec

  2. axe0's Avatar
    Posts : 14,117
    Windows 10 Pro

    Hi okkid,

    Welcome to the 10forums and apologies for the delay.

    Are you still in need of help?
      My ComputersSystem Spec

  3.    #3

    Thanks axe0,
    No worries - I sort of guessed I'd have to do a complete reinstall anyway, so when I realised this thread keeps you more than busy, I just went ahead.
    But its thrown up one thing. I mentioned having more two Win10 bootup options on a blue screen after post: well, now I'm presented with three options! And its dawned on me that these seem to be vestiges of my previous re-installs. The one that works is labelled 'Windows 10 on Vol 2'; the others default to a black screen like the one I described above. I should explain that I shuffled my partitions along to avoid a bad sector that was troublesome, so now there is 10Gb of unallocated space between the 500Mb recovery and C;\ partitions. This, I think, is why it is asking me about Vol 2? Do you know if there is any way to be rid of these artifacts from my previous installs? Its not a great problem, as I have set the delay on the blue options screen to about 5 secs; but it would be nice to know if I can do without it. Thanks,
      My ComputersSystem Spec

  4. axe0's Avatar
    Posts : 14,117
    Windows 10 Pro

    Could you provide a view of your disk management?
    Disk Management - How to Post a Screenshot of - Windows 10 Forums
      My ComputersSystem Spec

  5.    #5

    Thanks axe0, I hope this works ok for you.
    Attachment 108404
      My ComputersSystem Spec

  6. axe0's Avatar
    Posts : 14,117
    Windows 10 Pro

    Unfortunately, from the picture it is not clear to me what partition(s) you mean, or is the C: partition the working one?
      My ComputersSystem Spec

  7.    #7

    I have just one OS loaded; Win10 on the above C:\ boot partition. The blue screen I'm referring to may be one which routinely offers users with multiple OS partitions the opportunity to boot to the one of their choice, say Linux etc. But, now that I have re-installed Win10 yet again, I am presented with three Win10 options on that screen. The one that works is labelled "Windows 10 on Vol 2". It happily boots to my C:\partition. Why the others are there I have no idea. And why the reference to Vol2? Cheers,
      My ComputersSystem Spec

  8. axe0's Avatar
    Posts : 14,117
    Windows 10 Pro

    Open msconfig (search msconfig) and go to the boot tab, delete all boot options you don't use.
      My ComputersSystem Spec

  9.    #9

    So easy! Thanks axe0.
    Cheers, Ross
      My ComputersSystem Spec

  10. axe0's Avatar
    Posts : 14,117
    Windows 10 Pro

    Glad to hear :)
      My ComputersSystem Spec


Related Threads
Endless boot loop after reset in Installation and Upgrade
Ok so basically, after successfully installing windows 10 from windows 7, I decided to clean my hard drive and reset windows because I deleted my "edge" and thus my apps were not working. The problem then started, the reset went fine until it...
Endless Undoing Changes Loop after hard shutdown in Windows Updates and Activation
I am having issues with the computer I just purchased. It is an endless undoing changes loop that I can't get it out of. Please help! Thanks in advance!
User Account settings screen, in endless loop in User Accounts and Family Safety
I am trying to fix a friends computer that was upgraded to win10 automatically (not sure from what os before). It's an HP laptop and a mess, fixed most issues but can't figure this one. Start menu... settings... user accounts On this screen it...
In computer terms I am equivalent to a preschool child. So I would appreciate an easy to understand answer as much as possible. I ran the window 10 installation last night on my Lenovo Y50 laptop. Today it is stuck in an endless loop of trying to...
Solved Endless start loop in Installation and Upgrade
Have just installed 10 on a spare drive and installed that drive into my Sandy Bridge and the machine is now going through an endless loop of start up. I can hear it make some sort of noise as if something wants to go and I have again tried the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:53.
Find Us