1.    21 Jul 2017 #1
    Join Date : Jul 2017
    Posts : 3
    Windows 10 Home

    0x80070422 / 0xC1900101-0x20017 - Unable to update to version 1703


    I've been trying to install the 1703 creator's update for a couple days now and after trying a few solutions and re-starting the process about 10+ times, I've finally decided to ask for help.


    Update Methods:
    -I can't update to 1703 through the normal Windows Update, it says I have the latest version.

    -I've tried updating through the Update Assistant multiple times, it successfully downloads and then restarts my computer. I then see a quick flash of what looks like a cmd prompt after it loads the files (it's very quick, I have no idea if it's related but I thought I would mention it), and then it prompts me to select a keyboard language, and then prompts me to 1) Continue, 2) Troubleshoot, 3) Use a Device, 4) Turn off your PC, or 5) Use another operating system. I generally click Continue, and when I get back into the computer, nothing has changed.

    -I've also tried updating through the Media Creation Tool several times, this also successfully downloads and restarts my computer, and it also gives me a quick flash of a cmd prompt and then prompts me with keyboard and the above 5 options. After I click continue, it states that it could not update and displays "0xC1900101 - 0x20017".


    Additional Info:
    -I've checked all of my drivers. They're all up to date, although I'm also planning on looking into my Hidden Devices and seeing if there's something wonky going on.
    -I've tried an SFC Scan through the CMD while running in Administrator mode; it came back with zero issues.
    -I've tried the Update Troubleshooter multiple times, it states that it fixes issues each time and then the problem continues to persist the next time I try to update.
    -Not sure if this matters, but I recently created a dual boot system with Windows 7 on a separate partition. Yesterday, however, I realized I no longer had use of Windows 7 because this update fixes what the other issues I'm having, and thus have opted to (supposedly simply) update Windows 10 instead. I have since uninstalled Windows 7, wiped the old partition, and re-added it back to my main partition.
    -Under Services>Windows Update>Properties, Startup Type is set to Automatic, and First Failure is set to Restart the Service.
    -I've fixed all registry errors with CCleaner.


    My last attempted update was performed using the Update Assistant. Here is the setuperr.log:

    Google Drive

    The last two lines are the last lines before the entire log (setupact.log) finished logging.


    Please do not suggest a clean install. I understand that this may solve these issues, but I only want to use this as a last resort under the circumstances that it is totally impossible to solve this issue without a clean install.

    Help, tips, suggestions, really anything you might think is off about any of this: Please let me know, I would be extremely grateful for any and all help. Thank you.
    Last edited by Smexy; 21 Jul 2017 at 11:24.
      My ComputerSystem Spec
  2.    22 Jul 2017 #2
    Join Date : Jul 2017
    Posts : 3
    Windows 10 Home
    Thread Starter

    Update
    I've been speaking with Windows Customer Service for most of the day today, and these are some of the things that have happened:

    -A customer service agent added lines in my registry to allow my computer to update more smoothly.
    -An agent attempted to install update 1703 via a downloaded ISO file.
    -An agent also made some additional changes to the settings of multiple services in the services tab, but I can't remember exactly what.
    -An agent scanned my PC for malware, adware, and corrupted files, and removed them.
    -As per the instructions of an agent, I edited the advanced security options of the file mcupdate_GenuineIntel.dll located in Windows>System32. I changed "Owner" to my username and then proceeded to add a permission giving my username Full Control under the "Access" column, and finally, added .BAK to the end of the file changing its extension. This solved one of my first errors, and I was able to begin the updating process after re-booting my system. However, it cancelled and rolled back further into the process due to a new error, 0xC1900101 - 0x30017. The next agent was the one who edited my registry, and stated that he had run into this problem before, telling me that his fix would work. It might've, but I was unable to update again, and I went back to having the error 0xC1900101 - 0x20017. I checked my System32 folder again and discovered my system had created a new mcupdate_GenuineIntel.dll file, so I proceeded to do the same fixes to this file as I did previously. However, this time, the update didn't proceed after reboot, and I got the same error I usually do.
    -I have also removed all drivers for hidden devices, and cleaned my registry again with CCleaner after doing so.
      My ComputerSystem Spec
  3.    22 Jul 2017 #3
    Join Date : Jul 2017
    Posts : 3
    Windows 10 Home
    Thread Starter

    Update

    After no effective solutions were forthcoming, I had to result to a clean installation. I'm now on an updated version.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Anniversary update fails with error 0xC1900101 - 0x20017
Windows 10 1511 will not update to 1607 by any method. Updates always complete to 100% then revert. Computer is a Dell Vostro 1720. Background: The computer never appeared to update automatically, but there was never any error code. I tried to...
Windows Updates and Activation
Windows 10 install problem 0xC1900101 - 0x20017
Hello, I have a problem with installing Windows 10 (either upgrade or clean install). I think the problem has started 2.5 years ago when suddenly Windows 8 stopped installing updates. I think it stopped installing updates after the Windows 8.1...
Installation and Upgrade
0xC1900101 - 0x20017 happens every time I install.
Hey all. I reserved my copy of W10 a long time ago, and I just got back from vacation, so I thought I would just go ahead and install using the Media Creation tool. After running the tool and downloading it, it installed fine and proceeded to...
Windows Updates and Activation
0xC1900101-0x20017 Error during BOOT
35046Windows 10 goes through the entire download/installation process, restarts, blue screens with a "system thread exception not handled (iastora.sys). It then restarts and shows this error for windows 10. Am I screwed? It goes back to the desktop...
General Support
Win10 home will not install - 0xc1900101 - 0x20017
Please help me solve this problem which is driving me nuts. Yes, I have searched for solutions and have not yet found a reasonable one. I have Win 10 installed and activated on one computer - Asus z97 Deluxe/USB 3.1 mobo - but it ABSOLUTELY refuses...
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:13.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums