Windows 10: 'Unsupported Disk Layout for UEFI Firmware' yet BIOS Mode set to UEFI Solved

Page 3 of 3 FirstFirst 123
  1.    05 May 2017 #21

    Looks like I was finally able to upgrade to version 1607! Woo


    Heres my final DiskManagement and Disk Part screenshots. Let me know if anything doesn't look quite right. But so far things seemed to be all good.

    Disk Management


    Disk Part


    Thanks again, all 3 of you were incredibly helpful. I've learned a lot these last two days and I gotta say Macrium Reflect is super slick.

    I'm marking this as Solved, Thank You for helping me resolve a 6 month long issue!
      My ComputerSystem Spec

  2.    05 May 2017 #22

    You can delete the scond recovery partition that is at the end of the drive and extend the C: drive partition to fill that space. MiniTool Partition Wizard is a very easy program to do that with. When I get home tonight I could provide the diskpart commands to do it with.

    Best Free Partition Manager for Windows | MiniTool Partition Free
      My ComputerSystem Spec

  3.    05 May 2017 #23

    Either is fine, the information to do it through diskpart could be beneficial but I can also just use the link you provided. Thanks!
      My ComputerSystem Spec

  4.    01 Dec 2017 #24

    NavyLCDR said: View Post
    I would install Macrium Reflect Free. Make a backup image of your C: drive to your D: drive. Boot the computer in UEFI mode from a Windows 10 installation USB flash drive. Select the custom install option, delete every partition on the SSD and install Windows 10 to the resulting unallocated space.

    That should set you up with a GPT partitioned SSD and the proper partitions to boot in UEFI. Then re-install Macrium Reflect Free. Use the option to create a Macrium Reflect Boot Menu entry. Boot into the Macrium Reflect rescue environment. Restore the C: drive image you previously created back to the SSD, replacing ONLY the C: drive partition. Run the Fix Windows boot problems utility in Macrium Reflect.

    Reboot - you should then be able to update.
    NavyLCDR.. I wanted to say thanks for the idea. This worked great for me.

    I had 1703, and could not get 1709 through the regular update. After researching for a few days, found out that my C drive was an MBR drive. It was booting with the Windows bootloader in UEFI-bios.
    I could not get MBR2GPT to run, it was the dreaded 'OS cannot be found' error. Also, the 'disk layout is invalid.'
    Diskpart revealed there were only 3 partitions on the HD. No EFI partition existed, although windows said it was a UEFI boot.

    I had cloned the drive a few months ago, with Macrium reflect free, and apparently did not select the right things to do when cloning to a larger SSD. I also note that Macrium moves the boot files from C:\Boot to C:\Boot\Macrium\WA10KFiles\media. Therefore BCDEDIT, mbr2gpt, etc. could not find the boot files at all, although the actual computer was booting fine.

    Anyway, last ditch effort and ending my searching, I happened across you guys' comments, and as I knew that macrium was involved with the booting since I had cloned, I did what you detailed above. I already had macrium installed on another drive, so there was no need to reinstall it, fortunately.
    It is important folks follow your steps IN ORDER, as a rescue USB created PRIOR to the re-install of windows will not work, you will get an error of 'Can not continue, C drive is in use...'. You must create the rescue USB AFTER you install windows 10 and re-install or restart Macrium.
    Noted while removing partitions, I deleted every one of them, and one said it was on a different drive, drive F. No idea why it assigned it that way, I noticed that in rescue mode the letters were different, fortunately I knew the difference from the drive models in my 5 disk system, and as C drive as Disk 3, I used that method of telling which drive to remove partitions from. (Diskpart through command listed C drive as disk 3 as well.)
    I IMAGED the C drive to start this, from one SSD to a larger SSD, and 90gig took about 6 minutes to image. It took almost the same time for the image to be restored back to the C drive.
    Another comment from essenbe was right, when restoring the image ion Macrium, UNCHECK the little partitions, only leaving the primary (drive) partition checked before you do any dragging, and drag the bottom image partition to the top, checked actual drive partition.


    Thanks to this thread for saving me the usual many many hours it would have taken to reinstall so many apps/prgs. !
      My ComputerSystem Spec


 
Page 3 of 3 FirstFirst 123

Related Threads
Hi there. Applying the creators update manually to an existing Win 10 x64 installation, or at least attempting to. When using the manual upgrade exe, I receive the following error: Windows 10 will not run on this PC Here is why Windows 10 can't...
Hello, I bought new laptop (HP 250 G5) few days ago and it came without system on it so I tried to install Windows 10 from bootable DVD. I have both UEFI and Legacy modes enabled in BIOS. When I try to boot from my Interna CD/DVD ROM Drive i...
I have a 250GB GPT SSD and installed Windows 10-64bit in UEFI mode. Also, I have 1TB MBR HDD and installed Windows 7-32bit in BIOS mode. Currently, I have to go to bios setting every time and change boot priority manually in order to boot...
Clean install in BIOS Legacy Mode or UEFI? in Installation and Upgrade
Hello, currently I have the upgraded Windows 10 Pro Spanish 32-bit activated from Windows 7 Spanish OEM 32-bit on a 2011 HP ProBook 6550b LATAM which I guess has the digital entitlement since no keys were entered. I would like to clean install &...
This problem is driving me nuts. :confused: I've had Win10 installed for ages and no problems until Upgrade 1511 came along. How come Windows 10 worked all that time and now refuses to upgrade? Can anyone provide a fix for this problem: ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:07.
Find Us