Version 10.0.14372 Build 14372 is the one I am running,
I don't know what happened but it is just stuck there at 0%.

I tried several solutions that I found on this forum and googling around but no success so far
The main two that I tried several times were
stopping the wuauserv by going into CMD as an administrator and running
net stop wuauserv

then deleting all the files in C:\Windows\SoftwareDistribution

then restarting the service and requesting the update again but still at 0% even after leaving my computer on for a couple of days.

the second one was using the "Update troubleshooter" from windows which is linked both here and in the Microsoft Forums but that didn't do anything.

I tried to do both by doing slight variations during the process such as stopping/restarting the bits service after stopping /restarting the wuauserv (first method), or restarting the computer before running the commands.

But no success yet.
I don't feel reinstalling windows and installing all my programs again since I am crunching hours trying to finish a project and the only reasons why I am desperate to fix this problem is because I am getting a warning saying that my PC will restart every few hours If I don't solve this issue.

You can see the screenshots below (first image is the stuck at 0% screenshot)
- (second image is the warning from windows saying that my pc will restart every few hours)
Click image for larger version. 

Name:	win1.PNG 
Views:	1 
Size:	26.1 KB 
ID:	102576Click image for larger version. 

Name:	win2.png 
Views:	1 
Size:	9.6 KB 
ID:	102577