1.    20 Sep 2016 #1
    Join Date : Sep 2016
    Posts : 3
    Windows 10 upgraded from Windows 7 Home 64 bit

    CPU problem after Anniversary Update on Windows 10


    Apologies if this problem has been addressed before.

    On Sunday my laptop (bought new in May of this year) running Windows 10 Home 64 bit updated via Windows Updates to the Anniversary Update.
    All seemed to go well but now my CPU is running at almost 100% all the time. From the searching I have done on the Internet I see I am far from being alone in experiencing this problem.
    I am reasonably competent on computers for day to day stuff but this is a bit more technical for me. However I 'think' I may have found the culprit for this CPU problem but I don't know what to do about it and would appreciate help if anyone here knows how to fix this.
    Looking in the Task Manager I see that there are 5 instances of the Windows host process (Rundll32) running in the background each using approximately 15% of my CPU which adding them all up is a fair chunk of my CPU. What are these processes and do I need them etc; etc; How can I get them to 'back off' so to speak and give me back my CPU.

    Sorry if I am not expressing myself very well but hope you understand.
      My ComputerSystem Spec
  2.    20 Sep 2016 #2
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,360
    Win 10 Pro (1703)

    Hi, sorry to hear of your difficulty. Some posts here related, not so many.

    Here's one I found of my very earliest days with Win 10 which coincidentally may relate:
    Solved CEIP - rundll32.exe high CPU use in Win 10? - Windows 10 Forums

    If you are having difficulty controlling a rogue process gobbling CPU resources, try this unusual program, just as a temporary measure so you can use your PC and not run hot:
    BES, Battle Encoder Shirase 1.6.2 (stable) 1.7.0-alpha: Controls Per-Process CPU Usage
    It still works...

    It could help if you can post a screenshot of your task manager showing processes with highest CPU use at the top, and identify what rundll32 is doing (see the first URL). You can then do a search using that.

    Example for rundll32.exe aeinv.dll,UpdateSoftwareInventory
    Windows host process high CPU usage - Microsoft Community
      My ComputerSystem Spec
  3.    20 Sep 2016 #3
    Join Date : Sep 2016
    Posts : 3
    Windows 10 upgraded from Windows 7 Home 64 bit
    Thread Starter

    Hi dalchina thank you for replying to me.


    I had actually found that first link you provided before I posted my question and I followed the first part of the advice – that is to say I disabled the three items mentioned in the Task Scheduler Library but it didn’t appear to make make any difference. I’m not confident enough to dig around any deeper in the task schedular on my own.


    I’m going to attempt to post a screen shot of my task manager and also a screen shot I took with Process Explorer in the hope it helps you to help me...lol

    Click image for larger version. 

Name:	Task Manager.JPG 
Views:	2 
Size:	128.4 KB 
ID:	102284

    Click image for larger version. 

Name:	Process Explorer.JPG 
Views:	6 
Size:	88.3 KB 
ID:	102286
      My ComputerSystem Spec
  4.    20 Sep 2016 #4
    Join Date : Jan 2015
    UK, Midlands
    Posts : 10,360
    Win 10 Pro (1703)

    Hello, I don't actually have aeinv.dll in System32. It's present in Winsxs, but not an active part of my Windows installation. Neither is WUDFhost.exe

    Basically what you need to do is search on each of the rundll32 strings, and identify something that matches your situation.
    I'd just be doing those searches for you.

    Searching for
    rundll32.exe aeinv.dll.UpdateSoftwarelnventory
    yields a good number of results.
      My ComputerSystem Spec
  5.    20 Sep 2016 #5
    Join Date : Sep 2016
    Posts : 3
    Windows 10 upgraded from Windows 7 Home 64 bit
    Thread Starter

    OK thanks very much I'll do that.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Windows 10 Anniversary Update and Macrium Reflect Scheduler Problem
Has anyone else had a problem with Macrium Reflect Scheduler not working after installing Windows 10 Anniversary Update? Any Insiders that determined there was such a problem before the Anniversary Update was released? It seems MR uses the Task...
Backup and Restore
Windows 10 Anniversary update problem....
Hi, I am currently running Windows 10 Pro edition 10586.494 without issue,as I have not yet received the automatic update to the Anniversary Edition I decided to install it manually. I downloaded the Windows 10 upgrade assistant and it checked...
Installation and Upgrade
Problem update win 10 anniversary 75%
I have read a lot of people have this problem. at 75% the installation failed. i have try with media tool e windwos update but it's the same i have on the pc avira comodo firewall malware antibytes and malware anti exploit ...
Installation and Upgrade
Solved Anniversary Update Problem
I downloaded and installed the iso referenced in Dona Sarkar's announcement memo Win_10_1607_English_X64.iso dated 8/2/16. My winver shows 1607 build 14393.0. I expected it to be 14393.10. Anyone know what's up? The machine is an original upgrade...
Installation and Upgrade
Windows 10 Anniversary Update BSOD problem
I have a problem during the update to Windows 10 Anniversary , I get BSOD in the instalation and then I get a message : Reboot and Select proper Boot device or insert Boot Media in selected Boot Device and press a key I close my PC and I decide...
BSOD Crashes and Debugging
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:10.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums