Page 1 of 2 12 LastLast
  1.    06 Aug 2016 #1
    Join Date : Jan 2015
    Posts : 150
    Win7

    How to determine what caused Anniversary Update to fail


    I downloaded the Anniversary Update and ran it. It seemed to be doing ok - the % complete got up to 91%, including several restarts, and then I got the frowning face icone with the message "Something went wrong". After that my screen said it was restoring my previous version, which is what I am running now and seems to be OK.

    So what now? How is one supposed to figure out what caused the update to fail? I've looked at the upgrader_default.log file but don't see anything helpful in there. There are a couple of error messages with code 0x80070002 but searching that ends up at a MS page that says support for XP has ended.

    My boot drive now has a 15.5MB directory called WIndows10Upgrade that has a lot of stuff in it. Is there something in here that's worth running to see what's wrong? Or should I just stick with my current version and wait for the next "upgrade"?
      My ComputerSystem Spec
  2.    06 Aug 2016 #2
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,061
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Please post a screen shot of disk management:
    Screenshot - Take in Windows 10 - Windows 10 Forums
      My ComputerSystem Spec
  3.    06 Aug 2016 #3
    Join Date : Jan 2015
    Posts : 150
    Win7
    Thread Starter

    Click image for larger version. 

Name:	Capture.JPG 
Views:	12 
Size:	172.4 KB 
ID:	94626

    Drives C: & X: are SSD's. I see that the old 100MB hidden partition on C: has been replaced with a new 450MB Recovery Partition. I presume this has all my old (and still current) Win10 stuff in it. My current version is Build 10586.

    I found a posting that said a fix for a similar problem was to disable StarDock's WindowsBlinds add-on. I do not have this, but I do have their ObjectDock add-on. (It seems to be the best launcher app out there.) I tried again with ObjecetDock disabled, but the upgrade still failed and put me back to Build 10586.
      My ComputerSystem Spec
  4.    07 Aug 2016 #4
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,061
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    On a normal Windows 10 installation. You should have a 500MB System Reserved partition containing BCD (boot configuration data) and Recovery software and C drive. Apparently, when you installed 10586, you did format the C drive so Windows put everything in C drive (C drive marked as Active). In addition, Your disk 3 should not be marked as Active since it is not a bootable disk.
    I think you'd need a 500MB partition in front of C drive, use EasyBCD software to move the BCD to this partition then try to upgrade again.
    In addition, uninstall any anti virus software + run sfc /scannow to make sure that's there no system files corruption.
      My ComputerSystem Spec
  5.    07 Aug 2016 #5
    Join Date : Jan 2015
    Posts : 150
    Win7
    Thread Starter

    Very interesting - thanks. TO do my 7 ==>10 upgrade I performed the standard upgrade, but then reformatted my boot drive and did a clean install of 10. My 7 was really old and I didn't want to carry any of that mess forward.

    I've not used EasyBCD before, but I'll give it a try. And I should have caught the fact that Disk 3 was marked active - I'll fix that too. Will report results back here.

    Well that sure was a mistake!. I got disk 3 marked as Inactive and created a 500MB partition on C: and then used EasyBCD to copy my BCD info there. I looked at the new partition and there was real stuff in there, so I figured it was OK to reboot my system.

    What I got was the message "An operating system wasn't found." Fortunately I have a recent whole disk Aomei backup of my boot drive, so I'll restore that. Not sure what I'll do after that - probably just ignore this update since my current system runs A-OK.
    Last edited by bbinnard; 07 Aug 2016 at 03:33.
      My ComputerSystem Spec
  6.    07 Aug 2016 #6
    Join Date : Jan 2015
    Posts : 150
    Win7
    Thread Starter

    Well none of that worked. I was able to restore my C: partition but the same message occurred. I ran bootrec /fixMBR, bootrec /fixBoot, bootrec /rebuildBCD and that didn't help. I booted off the Win10 ISO disk and tried Advanced/Repair Startup Problems, but it said it couldn't fix anything.

    I thought maybe the BCD partition that I created with EasyBCD might be confusing things so I formatted that partition. The bootrec commands still didn't help. What did work was to go into the BIOS and disable all disks except my boot disk and my BD/RW drive. WHen I bootoed the Win7 ISO disk this time the Startup Repair said it was reparing something. AFter that my system booted OK, so I went back to the BIOS and re-enabled all my drives.

    Now my disks look like this:

    Click image for larger version. 

Name:	Capture.JPG 
Views:	4 
Size:	163.7 KB 
ID:	94675

    Tomorrow I'll probably delete the Empty partition and expand C: to reclaim its space.
      My ComputerSystem Spec
  7.    07 Aug 2016 #7
    Join Date : Jul 2015
    Posts : 3,656
    10 Pro

    Quote Originally Posted by topgundcp View Post
    I think you'd need a 500MB partition in front of C drive, use EasyBCD software to move the BCD to this partition then try to upgrade again.
    Apparently this has changed and the recovery partition is now recommended to be after not before the C drive. In any case it shouldn't matter where it is.
    In Windows 10 Version 1511, we are changing our recommendation to have the WinRE partition placed after the OS partition. This allows future growth of the WinRE partition during updates. Today with the WinRE partition at the front of the disk, the size of it can never be changed, making it difficult to update WinRE when needed. We will continue to support having the WinRE partition located in different parts of the disk, but we encourage you to follow the new recommendation.
    OEM deployment of Windows 10 for desktop editions

    From the latest picture it looks like you can delete F and extend C to use this space. You need to confirm that the WinRE partition that is being used is the last one. To do this please post the results of reagent /info and diskpart list partition command for that disk as described here. windows 10 Anniversary upgrade created a recovery partition - Windows 10 Forums

    If you do delete F and reclaim your space you'll probably need to re-register the RE image as the partition number will have changed.

    To do this you would mount the partition in diskpart
    Code:
    diskpart
    select disk 0
    list partition
    select partition 4 (probably)
    assign letter = t
    and then from elevated command prompt
    Code:
    C:\Windows\System32\Reagentc /setreimage /path T:\Recovery\WindowsRE /target C:\Windows
    Deploy Windows RE
      My ComputerSystem Spec
  8.    07 Aug 2016 #8
    Join Date : Jul 2014
    San Jose, California
    Posts : 2,061
    Ubuntu14.04x64 MintMate17x64 Win10Prox64

    Well that sure was a mistake!. I got disk 3 marked as Inactive and created a 500MB partition on C: and then used EasyBCD to copy my BCD info there. I looked at the new partition and there was real stuff in there, so I figured it was OK to reboot my system.
    How did you use EasyBCD ? copy BCD info won't work, you need to do as shown below where New Boot Drive is the drive you want the Boot file to be in:
    Click image for larger version. 

Name:	EasyBCD.png 
Views:	45 
Size:	284.8 KB 
ID:	94735

    FYI, Here's a normal 500MB System Reserved partition that I took a snap shot of my system. Containing WinRE.wim and BCD, marked as "Active"
    Click image for larger version. 

Name:	b.jpg 
Views:	2 
Size:	249.5 KB 
ID:	94741
    Click image for larger version. 

Name:	a.png 
Views:	1 
Size:	541.2 KB 
ID:	94739

    NOTE: It is easy to reconfigure your C drive to look like mine then you can perform the upgrade.
      My ComputerSystem Spec
  9.    07 Aug 2016 #9
    Join Date : Jan 2015
    Posts : 150
    Win7
    Thread Starter

    Well OK, I think I understand what needs to happen here. But before I do anything beyond reclaiming the 499MB of space following my C: drive I want to get more info about a few things which I'll list below. But at this point it appears the answer to my original question is "There really is no way to determine what caused the upgrade to fail."

    In my case it could have been that I had 2 disks marked as Active. Or maybe it was because my Win10 installation was done as a clean install on a freshly formatted drive. Or maybe it was some other totally random error of some obscure type.

    I realize I might have/probably did shoot myself in the foot by trying to use EasyBCD without really understanding what it was doing. I did not use the BCD Bakup/Repair function - because I thought what I needed to do was place a copy of the BCD stuff into the newly created 500MB partition. So I used the BCD Deployment function, which required me to format the 500MB partition and give it a drive letter. "Deployment" to me suggests that the BCD stuff will be put in the location you specify, and I did verify that there was a bunch of stuff in the 500MB partition after I finished the BCD Deployment function.

    Obviously there are some critical points about this BCD stuff of which I am unaware and/or do not understand.

    Before I try this again I'll want to find out about

    (1) do I need to create an empty 500MB partition on my boot drive prior to running the upgrade (I think the answer to this is no.)
    (2) what is the 450 MB partition doing on my boot drive and can I delete it/re-use it's space to make a 500MB empty partition (if needed)
    (3) in the first posting by babis49 on the thread "windows 10 Anniversary upgrade created a recovery partition", what are those 3 partitions with no drive letters, how did they get there, and which ones are really needed.
    (4) Whether or not I have to create an empty 500MB partition, should I disable all my other drives before running the upgrade
    (5) What is a good piece of software for fixing the MBR/BCD stuff if it breaks and what is the procedure for doing so
    (6) Why is the best option when the Win10 ISO disk says it cannot fix a boot/startup problem
    (7) What is in a Recovery Partition and what is it used for

    I think I have a lot of work cut out for me.
    Last edited by bbinnard; 07 Aug 2016 at 11:46.
      My ComputerSystem Spec
  10.    07 Aug 2016 #10
    Join Date : Jan 2015
    Posts : 150
    Win7
    Thread Starter

    I got my 500MB back - see image below. But I discovered there is now a 2.88BG directory called Windows10Upgrade on my E: drive. This directory has only a single file in it: 14393.0.160715-1616.rs1_release_CLIENTCombinedSL_RET_x64fre_en-us.esd.

    Naturally I have no idea how this file & directory got there, what it is supposed to be used for, or why it is there. What I'm going to do is delete it. My E: drive is a data-only drive where I put Aomei backups, BluRay disk ISO files, and rendered video files. All my temp/tmp and download files go to my X: drive which is a 64GB SSD with about 60GB free space.

    At any rate, this is what my system looks like now:

    Click image for larger version. 

Name:	Capture.JPG 
Views:	3 
Size:	178.2 KB 
ID:	94755
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Update History missing after Win10 Anniversary Update
Hi, I just downloaded and installed the Windows 10 Anniversary Update yesterday and so far I have noticed some changes in my computer that I was not aware of before the update. (1) Somehow my System Restore was set to Disabled and all of my...
Windows Updates and Activation
Windows Update does not download and install the anniversary update.
I am downloading the update manually. Have others had the same issue with windows update not showing the update? I'm not sure my WU is working because of this.
Windows Updates and Activation
w10 update caused problems with all apps
Two days ago I was happily using this machine (a dell755) which has been running W10 for about 6 months now. Up until then no issues but then there was an automatic update and after that completed I found I have lost all connectivity for my apps!!!....
Software and Apps
Update to Windows 10 caused unformatted partition?
Hi, I just updated from Win 8.1 to Win 10. Seemed to have worked as it should. But I discoverd I cannot acces my D: partition anymore; I get an notification saying the drive is unreadable and has to be formatted. The partition is located on my Main...
Installation and Upgrade
Windows Update fail
Does anyone get the following when trying to use Windows Update We couldn't get online to download your updates. We'll try again later, or you can check now. If it still doesn't work, make sure you're connected to the Internet. have tried to...
Windows Updates and Activation
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:48.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums