Windows 10: Windows fails to install updates.

  1.    05 Apr 2016 #1

    Windows fails to install updates.


    Title. Can't install any updates. I read online that I have to edit the registry. Tried but windows tells me I have no permissions.

    Thanks in advance

    EDIT: When trying to do a system restore I get this error http://puu.sh/o6XO4/12326e1edc.png
      My ComputerSystem Spec

  2.    05 Apr 2016 #2

    Permissions? See repairs in
    Tweaking.com's repair tool- file system and registry.
      My ComputerSystem Spec

  3.    05 Apr 2016 #3

    Thanks for the quick reply!

    I will try the Tweakin.com's repair tool and reply shortly if it worked!

    EDIT: Ran the repair tool, it completed, booted to windows -> Fatal error during boot -> in windows it said "UPDATES INSTALLED" but unable to rollback to a recovery point still
    Last edited by Kopppi; 05 Apr 2016 at 08:51.
      My ComputerSystem Spec

  4.    05 Apr 2016 #4

    Hi, From the above I assume you can boot to Windows.. but can't be sure. I've no idea of the history.. how you got to where you are, so I'm guessing rather.

    Now, if system restore is your only issue (please confirm) I would suggest turning system restore off, restart for good measure, turn s restore on, create a restore point, see if you can use it successfully.

    If you still have problems, please state whether Win 10 was working correctly, and what you think may have led to your current issues.

    Also, I hope you followed the cautious path with the repair tool.. and selected just the permissions related repairs.

    Note: disk imaging is a great technique allowing you to restore your PC to a previously working state relatively quickly and without technical help. Many her recommend Macrium Reflect (free) + boot medium + external storage. It also acts as a full backup of what you've imaged allowing file recovery for example.
      My ComputerSystem Spec

  5.    05 Apr 2016 #5

    Thanks for the help so far!

    I am able to boot into windows. The problem started when I got my SSD and installed windows 10 on it. After that the updates just can't complete. And yes, my problem is I need to restore an earlier recovery point (A reason I won't specify).

    I tried to create a new restore point but still unable to restore to it. My windows is working good except for the update issue.

    I only selected a few of the repairs from the tools. (Can't remember which, but the permissions and some malware thing I think)

    Thanks
      My ComputerSystem Spec

  6.    05 Apr 2016 #6

    You could try launching system restore from outside Windows: boot from Win 10 install medium and navigate via Repair, Troublehshooting to System Restore. No idea if that will actually help.

    Note, if you have to use a previous restore point, then you're denied the option of an in-place upgrade repair install (it deletes restore points, inevitable given the process).

    Simply installing (clean install) to an SSD per se should not prevent you using System restore. I do and can. So that suggests sthg else must have happened.
      My ComputerSystem Spec

  7.    05 Apr 2016 #7

    Other thing that would come to my mind would be the fact that I have been using a DLL Injector to mod some games. But If i remember correctly it started before i downloaded it
      My ComputerSystem Spec

  8.    06 Apr 2016 #8

    It could be that your Windows Updates service needs to be reset. Easy fix for that.

    In my experience WSR is getting more and more unreliable with age. I see suggestions for Macrium Reflect Free, but if you're looking to replace WSR, more of a 1-to-1 comparison would be to something like Comodo Time Machine or Rollback Rx.
      My ComputerSystem Spec


 

Related Threads
I have Windows 10 10240 RTM x64 Bit version running on my system, (Now running 32 bit version.) The issue is that windows 10 Updates fails to install. 26066 34341 sfc /scannow and those things never worked for me in any windows...
Hi, I have recently installed Windows 10 Pro 64-bit. And got few updates and installed automatically. But then the updates got stuck at 99%. Its been stuck for 4 days straight. Currently its trying to download, "Advanced Micro Devices, Inc. driver...
Hi there. Trying a Windows install on a Server box with 4 HDD's installed. This server also allows boot from a Micro SD card. I've got a 64GB micro SD card loaded as well. Fails when trying to create any partition on any of the HDD's. Works...
I can get Steam to launch, but only after having the PC be in sleep mode. I can't get Steam to start with Windows 10 either. I've been having trouble finding a solution to this issue all day, seems like I'm one of a very select few experiencing...
Not cause by virus .. this just started today. I tried a restore point of yesterday .. nothing. I have tried several suggestions from the web but nothing seems to do it? I know it would be better if i could name them but can't remember the exact...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:01.
Find Us