Windows 10: new update broke, well most things.

  1.    17 Mar 2016 #1

    new update broke, well most things.

    Just got the march 17th update and it broke most of my usb devices. Occulus rift, joysticks, steering wheel etc. basicly anything that needs any power such as leds.

    usb devices except mouse and keyboard(not sure why) keep turning on and off every few seconds so cant be used. it was all good earlier today, then got the update which we dont have any choice in , and now usb 2/3 or even powered hub makes no difference. just keeps powering up and down.

    Using evga x99 classified and no driver updates are available so any idea when this will be fixed?
      My ComputerSystem Spec

  2.    17 Mar 2016 #2

    Hi, just to confirm, what is your build number? (Run box, type winver).
    And what is the last update you have received, and what happens if you uninstall it?

    (Note, you may need to disconnect your internet to stop Windows reapplying the update whilst trying this)

    You can choose to disable specific updates if you wish.
    Windows Updates - Hide or Show in Windows 10 - Windows 10 Forums
      My ComputerSystem Spec

  3.    18 Mar 2016 #3

    version 1151 05 10586.164 win 10 home.
    I disconnected from the net and restored my pc to an earlier build and all worked fine again, then allowed it to update to the latest build and the usb ports again started giving trouble. There is no notification of the usb ports connecting/disconnecting. all looks fine in device manager. But when i have my joysticks and occulus rift plugged in, the led's keep turning randomly on and off every min or two and the devices are not usable.

    I have a gaming laptop as well, so tested the rift and joysticks on it and they all worked fine, I then allowed it to install the latest win 10 update and it too started having the same issue with usb devices. so same issue on 2 very different pc's with the latest win 10 update.

    Mind you, the keyboard and mouse are fine, but they are legacy devices? and it makes no difference if it's usb2 or 3 and even using a powered usb hub dosent help.

    So the only fix i have for the moment is to restore windows to an earlier build and use the registry hack to block windows update.
      My ComputerSystem Spec


Related Threads
Latest update broke One Drive. in Windows Updates and Activation
Since the latest update following the 1511 upgrade, my PC slowed to almost a standstill. After hours of detection, I found the culprit is One Drive, which seems never to stop trying upload files. The only solution was to unlink One Drive, which in...
Solved Dec 2 update broke sleep in Windows Updates and Activation
lost ability for computer to sleep after Dec. 2 update. Had this stopping it: \FileSystem\srvnet An active remote client has recently sent requests to this machine. Eventually found this worked: Why Wons Tech Talk
The last update ruined my dual monitor set up. As soon as the update had finished my second monitor stopped working completely. Restarting the computer will sometimes allow it to work for a few minutes, but the resolution is stuck between 800x600...
On the day Windows 10 was officially launched my Precision M3800 was "upgraded" from 8.1 and I've had no significant problems... until a few minutes ago. I suddenly lost internet connection and the troubleshooter couldn't help, so I shut down via...
So far, I cannot run a no sleep hard drive program, Task Manager, or Outlook. Oh joy as I look for other things that no longer work.'s now working again, all of it. I guess it had to ruminate and digest the update for a few hours. I did...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 12:27.
Find Us