Windows 10: 0x80070643 Error when updating Windows Defender Solved

  1.    22 Sep 2015 #1

    0x80070643 Error when updating Windows Defender

    Have had this error for a couple days now. Tried regular checks to verify system components and online image and windows update service diagnostics, cleaned up SoftwareDistribution, turned off non-Microsoft auto starting services, - all to no avail.

    Also, ran netfxsetupverifier, which gave me the only error - aspnet.mof missing, which I presume is OK.

    Any suggestions how to resolve this?
      My ComputerSystem Spec

  2.    22 Sep 2015 #2

    I was able to resolve this by MANUALLY updating the definition set. Is this the way to go in the future should the problem persist?
      My ComputerSystem Spec

  3.    25 Sep 2015 #3

    The problem still persists. The Windows Defender does not update via Windows Update, but, somehow. the definitions keep up to date, from time to time. Any idea how to fix this?

    The MpSigStub.log contains the following record pertaining to the error:

    Command: MpSigStub.exe /program "C:\WINDOWS\SoftwareDistribution\Download\Install\AM_Delta_Patch_1.207.1010.0.exe" WD /q
    Start time: 25.09.2015 20:38 (version 11.1.5128.0)
    =================================== ProductSearch ==================================
    Защитник Windows:
    Status: Active
    Product: 4.8.10240.16384
    Engine: 1.1.12101.0
    Signatures: 1.207.1010.0
    NIS Engine: 2.1.11804.0
    NIS Signatures:
    ================================ PackageDiscovery ================================
    Package files discovered:
    C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs\1.207.1010.0_TO_1.207.1041.0_MPASDLTA.VDM._P (?.?.?.?)
    C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs\1.207.1010.0_TO_1.207.1041.0_MPAVDLTA.VDM._P (?.?.?.?)
    AM BDD:
    Engine: Not included
    AS base VDM: Not included
    AV base VDM: Not included
    AS delta VDM: 1.207.1041.0
    AV delta VDM: 1.207.1041.0
    ================================ PatchApplication ================================
    Using directory C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs for temporary storage,
    ERROR 0x8499041a :
    ApplyVdmPatch(C:\ProgramData\Microsoft\Windows Defender\Definition Updates\{586068D4-34E4-42F2-BF06-792EAE753D17}\mpasdlta.vdm,
    C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs\1.207.1010.0_TO_1.207.1041.0_MPASDLTA.VDM._P, C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs\087598AE-A0F8-4488-977A-BC0D59B707D7mpasdlta.vdm)
    Watson Report: Position:
    HRESULT: 0x8499041a P1
    FailedFunction: PatchApplication P2
    Operation: AM BDD P3
    SourceComponentVersion: 11.1.5128.0 P4
    SourceComponentName: mpsigstub.exe P5
    ProductVersion: 4.8.10240.16384 P6
    ProductName: Windows Defender P7
    ERROR 0x80508015 : Failed to send error Heartbeat report for product: Windows Defender
    Set BddUpdateFailure to 1
    ERROR 0x8499041a : One or more of the packages found failed to update for Windows Defender.
    ERROR 0x8499041a : One or more of the products found failed to update; returning this error
    Deleted C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs\1.207.1010.0_TO_1.207.1041.0_MPASDLTA.VDM._P
    Deleted C:\WINDOWS\Temp\F4AECEF03EA89CC45B14960C8E7DF7AB-Sigs\1.207.1010.0_TO_1.207.1041.0_MPAVDLTA.VDM._P
    ERROR 0x8499041a : MpSigStubMain
    End time: 25.09.2015 20:38

    Any idea how to proceed forward? Cleaning up SoftwareDistribution and deleting the temporary folder indicated above does allow to update Windows Defender flawlessly, but just once. The error keeps coming back the next day.

    Update: Did exactly as suggested here and let it stay that way for a while. Miracles! The issue has been gone for good!
    Last edited by usikpa; 06 Oct 2015 at 05:29.
      My ComputerSystem Spec


Related Threads
Solved Cannot install update (KB2538243) - Error 0x80070643 in Windows Updates and Activation
I keep getting this error, I have attempted to install it several times without success. How do I get this update to install? Thanks
Hi All, I'm wondering if anyone can help. I have upgraded to windows 10 for a few weeks now and over the last couple of days it has stopped installing any windows updates, the error code that pops up is (error 0x80070643) It's also...
Hi Guys, Before I upgraded from Win 8.1 Pro to Win 10 Pro on my desktop machine I made sure that all available updates were installed. I did this religiously for some time in the run up to the upgrade. All worked well, with the exception of the...
I recently updated to windows 10 from 7. I have encountered a lot of problems with this new OS. The first thing I have noticed is that my typing is extremely unresponsive. As I am typing this only 1/ 3 of the letters I type appear on the screen. I...
Hello All, I have been updating the windows 8.1 to 10 from yesterday but each time i get stuck at preparing to install option with error code 80070057. Please help me to fix this issue.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:44.
Find Us