Page 4 of 5 FirstFirst ... 2345 LastLast

  1. Joined : Jul 2014
    San Jose, California
    Posts : 1,960
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       17 Sep 2015 #31

    @NavyLCDR
    Thank you for your response.
    Yes. My laptop currently has 2 partitions only on it. One partition has Windows 10 build 10240 and contains my boot loader files. The second partition contains Windows 10 Insider build 10532. I deleted the little 350mb system reserved partition that previously contained my boot loader files and used Macrium Reflect boot fix utility to create the boot files on my Windows partition.
    Again, Your answers to the OP so far is based on what you are running Windows in your Laptop which is a MBR partition scheme while his PC is using GPT partition scheme.

    Your advice to delete the 100MB EFI system partition and use Macrium to fix the bootrec simply does not work. Not the same in MBR partition scheme where you can have the boot manager in the reserved partition or in the C drive. With GPT, you must have a EFI system partition for Windows to boot.

    Copy the partition to the empty space, expand it to 350mb, make sure to set the new copy as the active partition
    There's several methods to do that as well. I believe Macrium Reflect does it, if need be, when fixing boot problems with Windows. Diskpart can be used. Windows disk management can be used. Any partitioning program such as Minitool Partition Wizard can do it.
    There's no such thing to set a EFI system partition as Active with GPT disk, only with MBR disk. Your advice to "Make sure the new partition active" simply does not work either. Here's an example in your response that diskpart can be used with GPT disk:

    Click image for larger version. 

Name:	a.jpg 
Views:	1 
Size:	253.7 KB 
ID:	38028

    And also cannot mark active from disk management as the option is grayed out.

    Click image for larger version. 

Name:	b.jpg 
Views:	2 
Size:	260.8 KB 
ID:	38012

    Rittercon,

    You can read the lengthy posts and procedures that topgundcp and slartybart have made, but keep in mind one thing:
    Solved Windows 10 couldn't update system reserved partition - Windows 10 Forums

    A three post thread. Problem. Three sentence solution. Problem solved.
    So where do we go from here with your three sentence solution ? Please advise
    Last edited by topgundcp; 17 Sep 2015 at 14:10.
      My System SpecsSystem Spec


  2. Joined : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       17 Sep 2015 #32

    rittercon, you're doing an admirable job!

    I think the easiest thing for you to try at this point (thanks for all of the great feedback) is to
    par 1: shrink by 160 MB
    par 2: move (0 MB before / 160 BM after) and resize to 260 MB (100 original + 160 claimed from par 1)

    I'm tempted to suggest a 450 MB resize (350 MB from par 1), but I'm curious to see if the advanced 4k scheme is the issue or if it's a Win10 EFI system partition size issue.

    I'll leave that decision up to you, it's your time and your machine. If you decide to make one stab at it,
    par 1: shrink by 350 MB
    par 2: move (0 MB before / 350 MB after) and resize to 450 MB (100 original + 350 claimed from par 1)

    I suggest doing this with a bootable Minitool Partition Wizard
    Select the 64 bit download and burn the ISO to a disc or use Rufus to put the ISO on a Flash drive
    note that Rufus flagged the vesamenu.c32 as old and offered to update it - I did that when I built a PW 9.1 flash and it solved an old monitor issue that always split screen

    I'd also like to know how your firmware is set up.
    Is the setting:
    UEFI
    Compatibility Support Module (CSM)
    Legacy (BIOS)

    I looked at the MSI page (please confirm I went to the correct page for your board)
    Type: AMI BIOS
    Release Date: 2015-06-05
    Version: 1.A
    File Size: 6.08 MB
    Description - Updated BIOS code to support 5th-Generation Intel Core Processors
    ***Support 5th-Generation Intel CPU requires VGA driver version 10.18.14.4206 or later

    What version is on your machine?

    It seems as though you're capable enough., but I'll be glad to answer any questions.
      My System SpecsSystem Spec


  3. Joined : Jul 2015
    Posts : 6,894
    Windows 10 Pro
       17 Sep 2015 #33

    rittercon said: View Post
    Have everything pending and ready to go, except making the new 360MB "active". Don't see any choices in MiniTool available to do this.
    Will this be done automatically?
    If you have successfully moved the EFT partition intact to a location where it can be expanded to 360mb, apparently GPT disks don't have active partitions, so I am guessing it would be good to go. Fingers crossed +
      My System SpecsSystem Spec


  4. Joined : Sep 2015
    Posts : 14
    Windows 8.1 64-bit
       17 Sep 2015 #34

    5th update


    Tried Navy's recommendation (post #34) since it seemed easiest. Successfully created 360MB FAT32 partition by copying and extending existing 100MB FAT32 to 360MB unallocated space taken from c drive.

    Rebooted system and tried windows 10 install; but no joy. Same error message as previously.

    MiniTool shows the new 369MB partition as a "GPT (Data Partition)" w/ "none" status, whereas the existing 100MB system partition is "GPT (EFI System partition)" w/ "Active & Boot" status.

    Click image for larger version. 

Name:	mini-4.png 
Views:	19 
Size:	853.3 KB 
ID:	38040

    Restored everything back to original and will try Slartybart's recommendation next.

    By the way, my BIOS identifies itself as "InsydeH20 Rev 3.7, with BIOS version 1.50, dated 4/18/2014.
    My chipset identifies itself as: Intel 8 Series Chipset Family SATA AHCI Controller.
    Don
    Last edited by rittercon; 17 Sep 2015 at 16:49. Reason: removed duplicate image
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Maine
    Posts : 21,025
    Windows10Pro 64Bit on 2 DeskTop Computers
       17 Sep 2015 #35

    Boy the more I read about these GPT partitions, the more they scare the crap out of me!!! Right now all mine are MBR partitions, thank God. But I just bought a used computer which is only 1 year old, and still waiting for it at present. If its partitions are GPT I am going to be real pissed I think. Chances are, one of the hard drives will be. Just seems so hard to work with, over the old MBR style.
    Making changes to my partitions is so easy. This GPT seems so dam hard it ain't funny.
      My System SpecsSystem Spec


  6. Joined : Jul 2015
    Posts : 6,894
    Windows 10 Pro
       17 Sep 2015 #36

    Rittercon,

    Do you see the 2nd partition on disk 1 that is 100mb in size and marked as Active and Boot? That is the partition that Windows 10 needs to update but can't. The reason it can't update it is because it only has 3.8mb free space. The goal is to make that partition 350mb in size with 253.8mb free space left in it so that Windows 10 can then update it. And...hmmmm, how did that get marked as Active when according to topgundcp there can't be an active partition on a GPT disk?
      My System SpecsSystem Spec


  7. Joined : Sep 2015
    Posts : 14
    Windows 8.1 64-bit
       17 Sep 2015 #37

    Maybe success this time...


    Yes- Navy: I understand. Thank you for your help and guidance (and everyone else, too!).

    Took a chance and extended the 100MB EFI system partition by "borrowing" 253MB from the 1GB Recovery partition, which showed only 391MB being used. MiniTool did this very quickly and easily. The EFI system partition now shows 353MB total, with 259MB unused.

    Click image for larger version. 

Name:	mini-5.png 
Views:	14 
Size:	855.2 KB 
ID:	38043

    Windows 10 is now downloading (I never got this far before) and is at 40%. Will let you all know what happens.

    If successful, should I put the 253MB back into the Recovery partition, or leave it in the EFI partition? I really don't know what the 1GB Recovery partition is for, or whether 771MB (vs, 1GB) is enough for whatever it does.

    Don
    Last edited by rittercon; 17 Sep 2015 at 17:26. Reason: mispelled word
      My System SpecsSystem Spec


  8. Joined : Sep 2015
    Posts : 14
    Windows 8.1 64-bit
       17 Sep 2015 #38

    Happy to announce I am the proud papa of a Windows 10 installation!
    MiniTool shows the same stats as the above in post #39, including the amount of unused space on the 771MB Reserved partition and the 353MB EFI System partition.

    Thank you everyone, but especially NAVYLCDR, Slartybart and Topgundcp; I couldn't have done this without all your help and assistance.

    Don
      My System SpecsSystem Spec


  9. Joined : Jul 2014
    San Jose, California
    Posts : 1,960
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       17 Sep 2015 #39

    how did that get marked as Active when according to topgundcp there can't be an active partition on a GPT disk?
    I said it at the beginning and I will say it again, the GPT boot process is controlled by "UEFI Windows Boot Manager" and there's no such thing as Active partition marked by disk management. Not by what you said that diskpart/Disk Management can be used to mark it active. The status "Active" shown by Minitool is not the same as shown in disk management. Just to indicate that this partition was used to boot up windows. Use another partition manager such as AOMEI Partition Manager, where do you see the partition is marked "Active" ?

    However. You are correct about increasing the EFI System partition so I give you the credit for that.

    Anyway, I am glad the problem got resolved.
    Last edited by topgundcp; 25 Sep 2015 at 13:09. Reason: More info
      My System SpecsSystem Spec


  10. Joined : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       17 Sep 2015 #40

    Glad you got it sorted Don.

    I would not change the size of the EFI system part - keep it with a bit of a buffer.
      My System SpecsSystem Spec


 
Page 4 of 5 FirstFirst ... 2345 LastLast


Similar Threads
Thread Forum
Solved Windows 10 couldn't update system reserved partition
So I'm using win 7 at the moment and I want to upgrade for DX12 but anytime I try to it just says "We couldnt't update the system reserved partition" My reserved partition is 100mb and I know you need something like 350mb or something like that but...
Installation and Setup
Solved Win 10 Upgrade Error: Couldn't Update the System Reserved Partition
I have a Vaio laptop and migrated my factory Windows 7 install to an SSD about a year ago, which apparently left me with no system reserved partition. I used these instructions to create a new system reserved partition, but I'm still getting the...
Installation and Setup
We couldn't update the system reserved partition
The update automatically tries to install but I keep getting this. It says Windows 10 couldn't be installed. We couldn't update the system reserved partition. Several times I got error code: 8000FFFF. I'm trying to update a Dell Optiplex 780 with...
Installation and Setup
Win 10 can't update System Reserved Partition
Installed a Samsung SSD on my Asus CM6730-06 desktop running Win7. the Win7 OS was migrated from the Asus Pc to Samsung SSD. Windows 7 boots and runs great off the Samsung SSD. Got a Windows 10 upgrade notice and received an automatic download of...
Installation and Setup
Can't Update System Reserved Partition
Received this message whilst trying to upgrade my Acer Laptop from Windows 7 Home Premium SP1 256 GB SSD to Windows 10 Home. 28083 I've previously upgraded my Desktop from Windows 7 Pro SP1 256 GB SSD to Windows 10 Pro & subsequently performed...
Installation and Setup
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:05.
Find Us
Twitter Facebook Google+



Windows 10 Forums