Can't update to 2004/20H2 Windows think i am running on a USB stick


  1. Posts : 19
    Microsoft Windows 10 Pro 64-bit 20H2 OS Build 19042.928
       #1

    Can't update to 2004/20H2 Windows think i am running on a USB stick


    Almost 2 years ago i cloned my OS HDD instead of using a image because i had done it in the past without problem and also due to lack of space to put the image. After the clone was done i swapped their place inside my pc and which drive to use to boot in the bios. Used the pc like that for a couple days to see if it was working with the old drive inside with the old OS before formatting it. Since everything looked fine i formatted my old drive but without me noticing it was booting using the EFI on my old drive so the next day i was greeted with a BSOD.

    I don't remember if i tried changing the boot manager in the bios never having deal with that and knowing what the EFI was that's where i made the mistake that still is a problem to this day. Using a usb drive that i that i had made using the Media Creation Tool before i used it to go into command prompt. Using my phone to find command to create a new EFI but not knowing what the hell i was doing instead of following exactly what was written, i was like that's the wrong drive letter that's not where i need it wanting to copy it after creating it. I made the mistake of entering the command so it would make the EFI on my usb drive, now i was able to boot into windows but i found out it would not boot without the usb drive now. I redid the same thing but i put it on my C: this time which was still wrong but was able to boot without the usb drive plugged in. But i was still getting message on boot that i could loose data by unplugging the OS even thought it was not longer plugged. At some point i followed all the directive and properly "i think" recreated my EFI in my EFI partition this time but windows still think its booting from a usb stick/drive.

    Hate using command prompt outside of windows when they built my pc they installed using French (France) instead of (Canada) so i get azerty keyboard layout when typing outside the OS instead of qwerty.

    Since it was working fine anyway i let it be. At some point i had the option to upgrade to 2004 but since i was not sure of the stability with it i waited then the option was not there anymore. Now trying to using the update assistant or media creation tool to update to 20H2 it tell me i can't upgrade it on a USB. I don't know if i will get the option to update it if i wait until 1909 reach it's end of life or not, this is maybe also what it preventing it from showing up in windows update. For 1903 to 1909 i had to use the enablement package past its end of life to get the update. I was not thinking this would become a problem since i was planning to build a new pc but with covid and the shortage of part i am stuck with it for now. Am not sure this is the right place to post it since it is more or less related to the update process hoping someone can help me fix it without a having to reinstall and loosing my data and having to re download and fix my game install on my other drive too i don't feel like wasting many hours doing that when i already don't have enough time.

    Sorry for the wall of text i always have been bad at writing and structure and using self taught english by playing games not that's its better in my native language lol.

    If logs or screenshot of drive partition are needed just tell me which software to use.

    1909 OS build 18363.1500
      My Computer


  2. Posts : 17,246
    Windows 11 Pro
       #2

    From the Desktop screen press

    Press Windows +R, Type in regedit and press Enter.
    Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.
    Change the value PortableOperatingSystem to “0” from 1.
    Note: If PortableOperatingSystem doesn't exists create one by right click Qword(64 bits).
      My Computer


  3. Posts : 19
    Microsoft Windows 10 Pro 64-bit 20H2 OS Build 19042.928
    Thread Starter
       #3

    There is already one PortableOperatingSystem set to 1 when i click it its 32 bits if it change anything anyway even though my system is 64 and can't create one in 64 bits because it use the same name
      My Computer


  4. Posts : 17,246
    Windows 11 Pro
       #4

    Go into your BIOS settings for your SATA ports. Is hot swap enabled for the SATA port the drive is connected to? If yes, disable hot swap. Also, check here:
    FIX: Windows 10 thinks hard drive is removable.
      My Computer


  5. Posts : 19
    Microsoft Windows 10 Pro 64-bit 20H2 OS Build 19042.928
    Thread Starter
       #5

    In the bios the only thing with the word sata i found was something to set AHCI or RAID have not found anything with the word hot swap or hot plug.


    I looked into the link and they have not release a new bios in a long time for my machine i already have the last they release, i did the command in #2 i had to look somewhere else to get it working since it was missing \ while at it i did it for all 4 port still does not work, #3 i do not have msahci in my registery, #4 was correct, #5 answer above bios seem pretty bare bone


    #6 i already have the last Intel rapid storage from dell if i were to get a new one directly from intel i would not know which one to pick, windows does not show me a tray icon with the option to eject my ssd if that matter


    No idea what a storage pool is or how to create it


    i have not yet try place it in another tray and i am using https://www.amazon.ca/Icy-Dock-2-5-I...dp/B002Z2QDNE/ for my ssd because it i am not sure i could plug sata cable to the board directly i had to get something with the sata port and screw hole at the same place as a 3.5 hdd so the tray could grab and hold it in the correct place, it still show as a Samsung SSD


    I still have some brand new sata cable in plastic bag from a even older machine but like i said i am not sure i could connect to the port on the board probably not enough space to enter my hand. Other option if we are to try connecting the drive other way is i have a usb 2 2.5 enclosure that i know that one get detected as external when i plug it it was i use(d) for my media creation tool.

    Still not working still getting "This pc can't run Windows 10 - You can't install windows on a usb flash drive using setup.

    I was already think of getting 1 or 2 regular regular HDD but if this keep going i might just get one make an image of my ssd copy on a new drive update windows it if it work and make another image to move it back into the ssd but that's a bit extreme
      My Computer


  6. Posts : 815
    Win 10
       #6

    Xutos said:
    There is already one PortableOperatingSystem set to 1 when i click it its 32 bits if it change anything anyway even though my system is 64 and can't create one in 64 bits because it use the same name
    If this already exists with 1 as a normal Dword value, change it to 0, restart the PC and start the update again.


    Friendly greetings
    Sorry for any mistakes. English is not my native language.
      My Computer


  7. Posts : 19
    Microsoft Windows 10 Pro 64-bit 20H2 OS Build 19042.928
    Thread Starter
       #7

    Changed it to 0 and got offered 20H2 in windows update and no longer am i getting message about loosing data by disconnecting hdd on portable drive on boot if i were to lose power or in this case to test it out holding the power button.


    I was really not thinking just that would work and fix both issue but before celebrating i still need to update it and see if it work, but i think it should since windows update offer it this time without having to force it with other method. I'll update and mark it as solved once its installed if it work.

    - - - Updated - - -

    Updated without problem, very intriguing setting the value to 0 worked it's like having it set to 1 before touching it was making windows think it was a USB external drive but i am not gonna complain now that it's fixed.


    Thanks a lot for the help both of you.
      My Computer


  8. Posts : 815
    Win 10
       #8

    Windows sometimes mistakenly recognizes an SSD as a USB stick.

    And then it sets that registry entry.

    I assume that it came about because you have your SSD in the docking station.

    If you encounter the error again, you will know what to do.



    You´re welcome!


    Friendly greetings
      My Computer


  9. Posts : 19
    Microsoft Windows 10 Pro 64-bit 20H2 OS Build 19042.928
    Thread Starter
       #9

    Or maybe it added that line when i put a new EFI on my usb drive the first time doing it by mistake, now after the update i look both place i had added line in the registry the one i had set to 0 and the other one with the Bus port number both deleted themselves.
      My Computer


  10. Posts : 815
    Win 10
       #10

    Xutos said:
    Or maybe it added that line when i put a new EFI on my usb drive the first time doing it by mistake,
    That could also be a plausible explanation.But we can only guess.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 17:54.
Find Us




Windows 10 Forums