Not receiving updates anymore?


  1. Posts : 45
    windows 10
       #1

    Not receiving updates anymore?


    I updated to 1903 on 8/14. Since that time I have not received any Win10 updates, except for Defender definitions.
    Manually checking for updates says I'm up to date. There was a cumulative update released last Tuesday so I thought that would show up in WU, but no.

    I have ran Windows Update troubleshooter and that says everything is ok.

    Ran Win10 in Clean Boot and that didn't change getting any updates.

    Any suggestions?
      My Computer


  2. NMI
    Posts : 970
    Windows 10 Pro, Version 20H2
       #2

    No Pause (or Defer if you have Pro) set at Windows Update, Advanced Options?
      My Computer


  3. Posts : 45
    windows 10
    Thread Starter
       #3

    NMI said:
    No Pause (or Defer if you have Pro) set at Windows Update, Advanced Options?
    I have PRO and no defer set.

    I ran DISM yesterday and that didn't fix it either.
      My Computer


  4. Posts : 25,054
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #4

    fussybob said:
    I have PRO and no defer set.
    There is a bug in 1903 Pro. If either of the Feature Update or Quality Update defer values is set to a non-zero number of days they will disappear from the Advanced options.

    If you don't see both these defer settings showing as 0 days in Advanced options then check their values in the registry. Look in the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings for the values of DeferQualityUpdatesPeriodInDays and DeferFeatureUpdatesPeriodInDays. If either of them have a value other than 0, set them to 0.
      My Computers


  5. Posts : 45
    windows 10
    Thread Starter
       #5

    Bree said:
    There is a bug in 1903 Pro. If either of the Feature Update or Quality Update defer values is set to a non-zero number of days they will disappear from the Advanced options.

    If you don't see both these defer settings showing as 0 days in Advanced options then check their values in the registry. Look in the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings for the values of DeferQualityUpdatesPeriodInDays and DeferFeatureUpdatesPeriodInDays. If either of them have a value other than 0, set them to 0.
    That fixed it!!!!

    Thank you!

    I remember having the Quality and Feature Pause in Advance settings the day I upgraded to 1903 and set them to the max deferment days. They disappeared. Others stated the same, so I thought just a bug and meant nothing. Using your Registry fix they are back, they are set to zero, and I currently have 3 updates down loading.

    Thanks again!!!
      My Computer


  6. Posts : 25,054
    10 Home x64 (21H2) (10 Pro on 2nd pc)
       #6

    fussybob said:
    That fixed it!!!!
    Thank you!


    This is a bug that MS have yet to acknowledge, despite being reported several times in the feedback hub. Find one and up-vote it, or report it yourself. MS need to be told to do something about it!
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:11.
Find Us




Windows 10 Forums