1903 update keeps failing after rebooting

  1.    #1

    1903 update keeps failing after rebooting


    Windows update prompted me to "Download and install" the 1903 update. The first few tries it kept failing at 5% but I read that battleye could cause it to fail and although I didn't have that running, I did have punkbuster so I killed that and a few other processes and after that the update went all the way to 100% and then prompted me to reboot.

    I multiboot so I used grub4dos with the first/default entry set to

    title Win 10
    hide (hd0,1)
    hide (hd0,0)
    root (hd4,0)
    makeactive
    chainloader /bootmgr

    so /bootmgr is loaded and run, just by grub4dos rather than the MBR.

    When I reboot after installing 1903 and select this entry the screen goes black but instead of booting Windows it goes back to the grub4dos menu. When I select this entry again it boots Windows and the spinning circle is displayed for a while so it seems like it's finishing the update but when I get into Windows it's still on v1803.

    So I tried with the Windows Update Assistant instead. That downloads and installs to 100% fine but again after rebooting it's still on v1803.

    If I run the Windows Update Troubleshooter it says "Potential Windows Update Database error" detected but it doesn't seem to fix it. I'd be surprised if this database error was the cause of my problem, as it's not preventing it identifying the update I need or downloading and installing it, it just seems to be reverting back to v1803 when I restart.
    Last edited by doveman; 14 Jul 2019 at 03:18.
      My ComputerSystem Spec

  2.    #2

    You can at least see if this
    Reset Windows Update in Windows 10
    clears the reported issue.

    If you inspect it, you will see it does a number of things.

    You can also download the iso, mount it, and then run setup.exe

    As to any failure, you could try inspecting the relevant logs, and attempt the update after a clean boot.

    I'd have to leave the multiboot scenario to others to comment.
      My ComputersSystem Spec

  3.    #3

    Thanks dalchina

    EDIT: OK. The script just finished as I was typing this, so I guess it just takes a while to update the group policies. I'll try the Update again now. /EDIT

    I've run that script as admin and it's been stuck for a while on "updating policy". These are the last few lines I've copied from the console

    Deleted file - C:\WINDOWS\Logs\WindowsUpdate\WindowsUpdate.20190714.043550.808.1.etl
    ERROR: The system was unable to find the specified registry key or value.
    ERROR: The system was unable to find the specified registry key or value.
    The operation completed successfully.
    ERROR: The system was unable to find the specified registry key or value.
    Updating policy...

    Looking at the script, the only part where it deletes registry keys appears to be here:

    :: Reset Windows Update policies
    reg delete "HKCU\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /f
    reg delete "HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate" /f
    reg delete "HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate" /f
    reg delete "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\WindowsUpdate" /f
    gpupdate /force

    So it may be the "gpupdate /force" line that has produced the "updating policy" and it appears to be having problems with that for some reason. I'll try logging into the Administrator account and running it from there. Incidentally I did the Windows Update and Update Assistant whilst logged in to the Administrator account as I read that could help.

    - - - Updated - - -

    OK cool it worked with Update Assistant now.

    I tried Windows Update first and clicked "Download and install" for 1903. It then downloaded a small Windows Defender update and certainly didn't download 1903 as that takes a while but it told me to restart to install the update, so I did but when I rebooted it showed the "Download and install" prompt again and clicking that again prompted me to restart to install the update (it didn't install the Windows Defender update again this time) and again after rebooting it was still prompting me to download and install it.

    So I used Update Assistant, which verified the download I already had from my previous attempt, then installed which was very quick up to 71%, then super slow to 86% and then it finished. I guess it went to 100% but it didn't show anything higher than 86% before finishing.

    I remembered my grub4dos MBR is on a different SSD to the one I'm running Windows 10 from, so I set my BIOS just to boot from the Windows 10 SSD to take the multiboot out of the equation. Obviously I don't know if it would have worked anyway without doing that but it certainly worked this way. It showed "Windows is updating" to 30%, then rebooted and went from 30%-75%, then rebooted and completed to 100% and loaded to the login screen and after logging in it said "please wait whilst we install some updates" and it's definitely on 1903 now.
      My ComputerSystem Spec

  4.    #4

    - now you can consolidate that by creating a new base disk image e.g. with Macrium Reflect (free) and thereafter update with differential images.
      My ComputersSystem Spec


 

Related Threads
Hi all! Every time Windows 10 Home decides it is time for a forced upgrade of my OS (currently on the 1709 version) I have the same nightmare. The upgrade eventually fails with the message that some windows component is not compatible. After a lot...
As per title. old Alienware M17X-R3 laptop, running previous version 100% fine. The update failed. I tried rebooting and for the last hour it’s been saying “restarting”. Any advice please?
I'd left my computer for about 10 minutes when taking a quick break before a meeting. When I returned, Windows had completely shut down. When I restarted it, I was greeted with a progress indicator on a system update being applied. Meanwhile, I...
Hello, I have new Surface book 2 13.5" for graphic design and so far it worked great until today. System updated and restarted and stuck in rebooting loop. Since then I can't do anything. I went through several hundreds of forum pages, youtube...
Windows has downloaded some update files 1607 to drive C but when rebooting it doesn't even start the update at all it just reboots as normal with the update options still present in the start menu no errors just no update attempted. I've ran the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:53.
Find Us