No MS Update/Apps Working

Page 1 of 4 123 ... LastLast

  1. Posts : 215
    Windows 10 Home x64

    No MS Update/Apps Working

    Hi, I am having the issue where if I go to to Windows update I get "We couldn't connect to the update service. We'll try again later, or you can check now. If it still doesn't work, make sure you're connected to the Internet." I tried @Brink's solution to reset the service with no luck. If I go to advanced options in Windows Update and toggle "give me updates for other Windows products when I check for updates" on it toggles itself back off. If I go to MS store and check for updates to apps it usually will either update or say everything is up to date but does neither. If I try to open Forza 3 or 4 the game crashes at the load screen where I think it checks for updates to the game (not sure, it is the screen with the version number and crashes while loading the game). Any help would be appreciated.

    Ran sfc/scannow with no problems detected.
    Ran Windows Update troubleshooter. First result gave me error: 0x800705B4
    Second run gave me info that "Bits Service" was fixed.
    Third run showed no problem.
    Still getting same result from Win Update.
    Report from Win Update troubleshooter:

    Check for Windows Update issues Issue not present
    Detects issues related to Windows Update.
    Detection details Expand
    IsPostback: False

    InformationalService Status
    Problem with BITS service : The requested service has already been started. More help is available by typing NET HELPMSG 2182.

    Microsoft Windows [Version 10.0.17763.292]
    (c) 2018 Microsoft Corporation. All rights reserved.

    C:\WINDOWS\system32>REG QUERY HKLM\SOFTWARE\Policies\Microsoft\Windows\DriverSearching /s

    DriverUpdateWizardWuSearchEnabled REG_DWORD 0x1

    C:\WINDOWS\system32>REG QUERY HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\DriverSearching /s

    SearchOrderConfig REG_DWORD 0x1


    FirstInstallDate REG_BINARY 88417F527D4DD401
    InstallDate REG_BINARY 88417F527D4DD401
    HardwareIds REG_MULTI_SZ pci\ven_8086&dev_0416&subsys_091d1025
    DriverPackageIds REG_MULTI_SZ igdlh64.inf_amd64_f010b4ce3fbcacfa

    FirstInstallDate REG_BINARY D5BB554C2F4ED401
    InstallDate REG_BINARY D5BB554C2F4ED401
    HardwareIds REG_MULTI_SZ usb\vid_0bda&pid_0129
    DriverPackageIds REG_MULTI_SZ rtsuerxd3sdo.inf_amd64_42e94529064dfaf9

    FirstInstallDate REG_BINARY E4ECC924834DD401
    InstallDate REG_BINARY E4ECC924834DD401
    HardwareIds REG_MULTI_SZ acer\lmdriver
    DriverPackageIds REG_MULTI_SZ lmdriver.inf_amd64_74267c33dccba545

    FirstInstallDate REG_BINARY 9249A2DC724DD401
    InstallDate REG_BINARY 9249A2DC724DD401
    HardwareIds REG_MULTI_SZ hdaudio\func_01&ven_8086&dev_2807&subsys_80860101
    DriverPackageIds REG_MULTI_SZ intcdaud.inf_amd64_66e0a5048e30f9c5

    FirstInstallDate REG_BINARY 12041B8D1D86D401
    InstallDate REG_BINARY 12041B8D1D86D401
    HardwareIds REG_MULTI_SZ pci\ven_168c&dev_003e&subsys_e08e105b&rev_20
    DriverPackageIds REG_MULTI_SZ netathr10x.inf_amd64_82aaf2e4080b4267

    WUSearchLibrary REG_SZ chkwudrv.dll

      My Computer

  2. dalchina's Avatar
    Posts : 31,329
    Win 10 Pro (1903)

    Hi, can you browse normally?

    You can try's free cautious repair tool (easy to find) and use only the Windows Update repair option.

    You then also have further options if needed about Windows services, for example.

    Have you tried flushing your DNS cache?
    Are you using any form of VPN or proxy server?

    Here is one solved thread with that message- you might need to consider the history of your internet connection and its configuration:
    Can't receive any Windows updates after Anniversary Update Solved - Windows 10 Forums

    Ultimately you can do an in-place upgrade repair:
    Windows 10 Update 'couldn't connect to the update service' problem Solved - Windows 10 Forums
      My Computers

  3. Posts : 215
    Windows 10 Home x64
    Thread Starter

    Okay, is the flush of the DNS cache different from wsreset? That supposedly empties WS store cache.

    No VPN or proxy, and if I check the Desktop (it is hard-wired versus Wi-fi laptop where the issue is) Windows update works fine. That desktop is on 1803 and I am on 1809 doubt that makes a difference.

    I just ran the troubleshooter for windows store apps and it gave me the same NET HELPMSG 2182 error code.

    The "Can't receive any Windows updates after Anniversary Update" link seems to be the same as Brink's .bat file that I ran (according to Ed).

    Is "in-place upgrade" same as refresh? Where I lose all apps and customization? I don't know whether to just wait it out or if this applies to me.
      My Computer

  4. dalchina's Avatar
    Posts : 31,329
    Win 10 Pro (1903)

    You could spend a while patching up the various problems- it seems there's more than one- or, as has been found quite often, simply do an in-place upgrade repair install- or even, if you wished, manually upgrade your desktop to 1809.

    You can research NET HELPMSG 2182
    - which gives a good number of results.

    HELPMSG 2182. - Microsoft Community

    - a quick scan suggests you need to fix .NET framework

    These steps did the trick for me. I needed to reinstall the .NET framework on a new Windows 10 laptop. Kept getting the dreaded Error 1935 when attempting to install apps like QuickBooks and Office 2010. When trying to turn off and reinstate the .NET framework features, I would get error code 0x80071A90. I ran the Windows Update Troubleshooter in this article, it returned HELPMSG 2182. I then disabled MacAfee anti-virus and stopped/started the services as describe above. I was able to remove and reinstall the .NET framework and get QuickBooks to install. I have been attempting to solve this issue for over two weeks now - thank you!!
      My Computers

  5. Posts : 215
    Windows 10 Home x64
    Thread Starter

    Is "in-place upgrade" same as refresh? Where I lose all apps and customization? I don't know whether to just wait it out or if this applies to me.

    The desktop is on 1803 and doing fine. My laptop on 1809 is the one that is having the update issues.
      My Computer

  6. dalchina's Avatar
    Posts : 31,329
    Win 10 Pro (1903)

    An in-place upgrade repair is essentially the same procedure as an upgrade. So you lose no programs and keep most settings. Sorry about mixing up the PCs. Make sure you get the latest 1809 iso for that.
    (Tutorial available).

    You could try the .NET fix first and see if that helps.
      My Computers

  7. Posts : 215
    Windows 10 Home x64
    Thread Starter

    Gotcha on the repair install. I have an .iso ready for that if needed will try the .net fix first. I had a restore point from 1/26 update but am pretty sure, at least for me, that restore points don't work. Apologies for being short while you are trying to help me was/am frustrated.
      My Computer

  8. Posts : 215
    Windows 10 Home x64
    Thread Starter

    While doing .net fix I get:
    C:\WINDOWS\system32>net stop bits
    The Background Intelligent Transfer Service service is not started.

    More help is available by typing NET HELPMSG 3521...same with msiserver

    Access denied when trying to rename catroot, software dist. folders even though at admin level.

    Okay ran through again was able to stop the two services and rename the files still nothing will do the upgrade then throw machine in lake. Hopefully renaming those folders won't cause any issues.
      My Computer

  9. dalchina's Avatar
    Posts : 31,329
    Win 10 Pro (1903)

    No problem- thanks.

    Repair the .NET Framework | Microsoft Docs
    Download Microsoft .NET Framework Repair Tool from Official Microsoft Download Center

    However you may be in a bit of a catch 22 scenario where you have both a Windows update and a Net framework problem, where repairing the latter requires the former to work.

    You can fiddle around trying to Windows Update with the Tweaking,com tool or other means, or you can try using this:
    No MS Update/Apps Working-1.jpg

    to remove and reinstall Net framework by unchecking boxes, restarting, checking boxes, restarting.

    I return to my argument for an in-place upgrade repair install, as if two things are astray, more could be.
      My Computers

  10. Posts : 215
    Windows 10 Home x64
    Thread Starter

    Yup...I started doing the removal of net framework and thought this will work because it started saying win is updating during reboot but the catch 22 happened and it wouldn't download. Error code 0x800F0907 where MS is basically saying do the in-place upgrade I have no clue what I did to this thing to corrupt it but whatever.

    My .iso is about 1.5 yrs old I don't think that should matter.
      My Computer

Page 1 of 4 123 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:58.
Find Us

Windows 10 Forums