Windows Updates Issue after fresh MDT Deploy or In-Place Upgrade

  1. Posts : 27
    Windows 10 Home

    Windows Updates Issue after fresh MDT Deploy or In-Place Upgrade

    Good morning, everyone.
    Our business, within the last few months, has decided to push through with a company-wide upgrade to Win 10 Pro (not Enterprise). And while the initiative to upgrade is recent, we in IT had spent the previous 8 months before that to hammer out a solid image. Things are going smoothly for the most part, we have nice image deployed, except we have an on again/off again problem with Windows Update. After the deploy or inplace upgrade I'm finding that close to half the time, Windows updates don't work. What happens is, after the machines hit the WSUS server, report in, and they download their updates, if i'm not riding the machine when it finished downloading its updates, the 'Install Now' button disappears. In the example below, I deployed this computer's new image yesterday afternoon, got everything set, and left it on to let it tag up with WSUS and download its updates. It's a Lenovo Thinkpad T580, if that matters. I come in this morning, and this is what I see:
    Windows Updates Issue after fresh MDT Deploy or In-Place Upgrade-wsus.png
    Another symptom that goes along with this is that the C:\ProgramData\USOShared\Logs folder fills up with files. When I first experienced this (and not knowing about it), this folder literally filled up the remainder of the 70GB of free space post-deploy after about 4 days. This morning, there were ~50,000 files in this folder. I rebooted to try and start updates again, and in the time i've taken to write this, 1,000 files have generated in here, approximately 1-2 files every second.
    Windows Updates Issue after fresh MDT Deploy or In-Place Upgrade-programdata.png

    So far, the only solution i've come across has been to run's Windows Update Fix, immediately followed by the Windows Update Troubleshooter Stand-alone, downloaded from Microsoft (not the built-in troubleshooter in Win 10). Sometimes I have to do this process twice, and even rarer yet, I have to re-image because I can't get it to update. After this, as near as I can tell, updates are working fine.

    Some things we do as part of the deploy is hide most of the store apps, I don't know if that makes a difference or not. I tried some of the troubleshooting steps I've seen around here, with no success. I did try to update with WUAUCLT /updatenow with no success.

    Any thoughts on this? I'd love to prevent this if I can.
    Last edited by jpjordan357; 08 Nov 2018 at 07:43.
      My Computer

  2. Posts : 42,874
    Win 10 Pro (22H2) (2nd PC is 22H2)

    Hi, Which Windows build are you using?
    Windows key + R, winver

    You may know build 1809 has been paused after a brief initial release last month.
      My Computers

  3. Posts : 27
    Windows 10 Home
    Thread Starter

    We are on Build 1803 yet. We haven't even deployed 1809 in our Dev environment yet.
      My Computer

  4. Posts : 42,874
    Win 10 Pro (22H2) (2nd PC is 22H2)

    It may be that you're experiencing problems because MS is having difficulty with their servers.

    MSFT acknowledges some Win10 Pro licenses being mistakenly deactivated - Windows 10 Forums

    - may be somehow related.. + the difficulty with not distributing 1809...which is on hold..

    I've noted 1 user had a possibly rather similar problem- 1803, two PCs, same build, one with updates pending that would not install but the other ok.

    Note that 1803 has a problem, widely reported, with setting default file type associations. Some attribute this to one update, some to having certain 3rd party programs installed.
      My Computers

  5. Posts : 27
    Windows 10 Home
    Thread Starter

    We don't update directly from Microsoft, we have WSUS servers, which push updates to the client PCs.
      My Computer

  6. Posts : 913

    Can you try this at some of affected clients:
    wuauclt /resetauthorization /detectnow
      My Computer

  7. Posts : 27
    Windows 10 Home
    Thread Starter

    I can try that when I'm in the office. I could see this potentially working on an in-place upgrade, as we do switch WSUS servers, but any theories as to why this would work on a freshly imaged machine?
      My Computer

  8. Posts : 913

    Tackleberry said:
    ...any theories as to why this would work on a freshly imaged machine?

    If you made your physical/virtual machine (acting as image source) connected to wsus then all deployed computers may share the same wsus id which should be reset.
      My Computer

  9. Posts : 1
    win 10

    The WSUS ID would be reset when it changes OUs in Active Directory and the new policy is applied, which then changes the registry entry as to where the workstation is supposed to go get its Microsoft updates. Which would indicate that when it starts reporting to WSUS and is placed in the appropriate group to receive the updates it needs and subsequently deleted from the other WSUS console, the ID would be irrelevant unless there is somewhere else in the registry or in Windows 10 that is hanging onto the information somewhere else.

    This almost appears that there might have been Windows update corruption or an excessive amount of excess files that maybe should be removed prior to upgrading? This wouldn't account for the new machines having the issues, but it might account for the upgrades behaving that way. What is UpdateSessionOrchestration.001.etl and How to Fix It? Virus or Safe?

    I wonder if some kind of 'clean-up' would be necessary prior to upgrade to see if it helps prevent the issues you are seeing.
      My Computer

  10. Posts : 27
    Windows 10 Home
    Thread Starter

    To update everyone, I haven't yet solved this, but we did just deploy a new WSUS server (Server 2016), so we'll see if this goes away.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 00:31.
Find Us

Windows 10 Forums