Windows 10: Windows update 1803 formats secondary 4TB HDD from GPT to MBR


  1. Posts : 2
    Windows 10 Home 64 bit
       24 May 2018 #1

    Windows update 1803 formats secondary 4TB HDD from GPT to MBR


    New to the group and boy do I have a good one! The other day when I booted up my desktop PC, I noticed a majority of my desktop icons had lost there images alerting me that something had went direly wrong. I opened My PC to inspect my HDD contents and I was shocked by what I discovered. My large 4TB WD HDD had been wiped, changed from GPT to MBR and re-partitioned with no file system or drive letter assigned!!!! Wondering WTF, I checked Windows Update and had noticed that the 1803 update had installed (it actually looked like it took 3 attempts before it totally took). I also noticed that my 250 GB primary drive now had a 450MB D drive that was now a boot partition which wasn't there before.
    Upset and cursing at losing all of my software installations, I decided to change the drive back to GPT figuring that the wonderful update had a glitch which somehow performed this heinous act. After firing up Disk Management, I could see the drive which was formatted now as MBR, but the odd thing here was that the partition (now only 2TB) was marked as GPT Protected Partition. When I tried right-clicking to remove the partition and then convert the drive back to GPT. Disk Management would give me no options to do anything. Very odd!!!
    Not discouraged, I fired up Power Shell with admin privileges and launched DIskPart. This failed as well. So I booted to recovery mode from my installation media and tried DiskPart there as I thought maybe the OS was blocking me somehow and that booting into this safe environment might do the trick...wrong answer. Still no luck. I could remove the partition by issuing the CLEAN command at the selected disk level, but the HDD would not initialize as GPT.
    Refusing to let a cold machine beat me, I removed the offending drive from the SATA port and attached it to my external drive adapter. Once attached and recognized by Windows, I opened up Disk Management. Now I had the ability to do everything again, so I removed all the partitions, converted from MBR to GPT and initialized the disk for the full capacity. I then removed the drive, installed it back into the desktop and fired up Windows. Looking at My PC, I could see my 250 GB C drive which houses WIndows and the Boot partition, as well as the 4TB drive which was again assigned to drive D (I had unassigned the drive letter from the boot partition). I thought all was right with the world and proceeded to get ready for hours of software installation....but then, to my horror, the disk activity went to 100% and Windows 10 itself, replaced GPT with MBR and re-partitioned the HDD locking any access in disk management to perform any corrective actions!!!!
    I am truly disgusted with this update release. I certainly am glad that I had no critical applications or files on that drive. With that being said...has anyone experienced this? I have seen many issues about this release, but have been unable to find another situation quite like mine. My motherboard is an Asus P6X58D-E which does not support UEFI and why I used the 4TB HDD as my secondary initialized as GPT with NTFS file system and my primary being a 250GB HDD initialized as MBR. This set up has worked for months under the 1709 and earlier releases. So, I am wondering if this is can or will be fixed or if I am SOL here. Any help would be appreciated and any curse you could bestow upon the OS developers at Microsoft would also be looked upon with great favor. Thank you in advance from a noob to the forum
      My ComputerSystem Spec

  2.    24 May 2018 #2

    Welcome to the forum. This seems very strange can you post a screen shot from disk manager so we can see. There doesnt seem to be any reason windows would do this and we havent come across this before. I would scan all drives for virus or malware to ensure its not the problem.
    Did you see it upgrade to 1803 as it can take 2 hours
      My ComputerSystem Spec


  3. Posts : 2
    Windows 10 Home 64 bit
    Thread Starter
       24 May 2018 #3

    OK. After rechecking, it seems that the 1803 never took:

    Click image for larger version. 

Name:	Capture0.PNG 
Views:	19 
Size:	12.5 KB 
ID:	190061

    Click image for larger version. 

Name:	Capture0.5.PNG 
Views:	19 
Size:	9.1 KB 
ID:	190062

    I scanned for Malware and Viruses and nothing was found (iolo System Shield & Malware Killer latest version with latest definitions updated this morning), so now I am leaning towards a muffed installation of the update which, for some reason did a re-install of the last 1709 update. When I initially set the computer up, I had to set up the drive as GPT using DiskPart from the recovery option of the installation media as it wouldn't work within the OS. After I did that, everything was working like clockwork up until these failed installation of 1803. Now, the OS won't even initialize the disk to GPT as it reports the disk size as too small:

    Click image for larger version. 

Name:	Capture1.PNG 
Views:	19 
Size:	59.2 KB 
ID:	190063

    Click image for larger version. 

Name:	Capture1.5.PNG 
Views:	19 
Size:	21.0 KB 
ID:	190070

    Click image for larger version. 

Name:	Capture2.PNG 
Views:	0 
Size:	129.5 KB 
ID:	190064

    As you can see, this is a 4TB HDD which Windows reports as working properly but does not report the volume info:

    Click image for larger version. 

Name:	Capture3.PNG 
Views:	20 
Size:	45.2 KB 
ID:	190066

    Click image for larger version. 

Name:	Capture4.PNG 
Views:	0 
Size:	5.1 KB 
ID:	190067

    Click image for larger version. 

Name:	Capture.PNG 
Views:	20 
Size:	50.1 KB 
ID:	190071

    I am in the midst of doing the manual 1803 update to see if it will actually install and possible fix the issue. I am not holding out much hope for this though and I am bracing myself for a total re-install. I believe I can download the 1803 media from the same page you can manually initiate the 1803 update, so I will try using that instead of my original media; however, I am a little concerned doing this with all of the things I have read about this release not activating properly.

    I am also removing the 4TB HDD and putting it in my external to run diagnostics and a scan on it to make sure it is not corrupt for some reason. It should not be as it has been in operation for less than 6 months and was an unused spare I acquired from my company's IT store liquidation.

    Please let me know your thoughts and any suggestions you may have. Thank you for responding so quickly.
      My ComputerSystem Spec

  4.    24 May 2018 #4

    I would go to disk maker site and get their free disk test software which is specifly made to test their disk see what that says about it
      My ComputerSystem Spec

  5.    25 May 2018 #5

    When you did the 1803 update, did you have an active partition on the secondary HDD which somehow caused problems with the update?
      My ComputersSystem Spec


 

Related Threads
Hi all, I have an issue. I downloaded the new update to windows 10 1803 and I used to have only two Hard Disk Drivers. C: and D: Now after the update I have E: which is an OEM Partition. Problem is every few minutes, I get a notification...
On Friday afternoon, after I rebooted my computer once again because of the memory leak I talked about in my very first thread, I discovered my computer was downloading updates. It turned out to be another feature update, which filled me with dread...
The 1803 update went through without issue. But now windows update is trying to run the update again. My system shows I am running 1803 17134.48. When I push retry, I quickly see something about unable to download before it settles to show the error...
Download: Skype app in Microsoft Store How to Check for App Updates in the Store in Windows 10
Hey guys, My windows 10 pc recently updated itself and I lost some HDMI audio functionality. When you click on the little speaker icon on the lower right side of your screen and choose playback devices. My Yamaha HDMI received is the default...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:54.
Find Us