Windows 10: Error 0xC1900101-0x20017 during 2018 feature upgrade installation Solved

Page 1 of 2 12 LastLast
  1.    06 May 2018 #1

    Error 0xC1900101-0x20017 during 2018 feature upgrade installation


    I'm trying to install the 2018 feature (1803) upgrade on a desktop running Win10 Enterprise x64 V1709-Build16299.371) with an Asus P6T-Deluxe V2 motherboard and ATI Radeon HD7700 video card.

    On running Windows, I start with evaluated administrator-permissions the setup.exe from Windows 10 Ent x64 V1803 ISO-Image. The question about loading updates online I answered with no and on second try with yes.

    The update gets to 100% installed, puts up a msg saying that it wants to reboot, spends a couple of minutes showing the blue "Restarting" screen, then reboots. BIOS is finish to and boot screen is coming.
    The reboot freezes at the point just after POST finishes where the blue Window 10 logo appears in the middle of the screen - no further activity takes place - I left it sitting for an hour without anything further happening.

    If I power off and reboot, it boots into Windows normally and puts up a notification saying that the update could not be installed.
    Click image for larger version. 

Name:	Unbenannt.PNG 
Views:	59 
Size:	9.6 KB 
ID:	187594
    Checking the system event logs shows that the update failed with a 0xC1900101-0x20017 error, which seems to be some sort of driver problem, but it doesn't indicate which driver is the issue.


    I've unplugged everything I can - the only video card, and the mouse and keyboard are the only USB devices. I also used SFC and DISM to check the existing Windows installation - unistall KIS (antivirus) - but I didn't find any errors.

    My logfile from upgrade see here: >> setuperr.log

    Any suggestions on a fix?
    Thread
    Error 0xC1900101 during 2018 feature update installation I have read and used to try to fix. Firewire-device is disabled in BIOS - But no success.
      My ComputerSystem Spec

  2.    06 May 2018 #2

    I uninstall the Intel RSAT-Software and the Intel-RAID-driver. so only Microsoft HQL-certified-Driver are used for RAID.
    Iam unhappy, no success.
      My ComputerSystem Spec

  3.    06 May 2018 #3

    Checking following steps:
    * last BIOS-Firmware is installed
    * last ATI Radeon-Driver ist installed (with supptor for Win10-V1803)
    * no warning or error on driver in hardware-control-panel was shown.

    Uninstall following programms
    * KIS (antivirus)
    * VMware workstation
    * Cisco anyConnect
    * Internet-Information-Server (IIS)
    * any Mainboard-Tools from Asus

    Disable all unneeded devices in hardware-control-panel.
    sfc /scannow
    dism /online /cleanup-image /restorehealth

    NO SUCCESS -
    Last edited by jer11848; 06 May 2018 at 12:46.
      My ComputerSystem Spec

  4.    06 May 2018 #4

    Hi jer11848,
    I have the same problem trying to update Windows 10 1709 to 1803 on a PC with Asus P6T Deluxe motherboard.
    I have uninstalled all non essential drivers, disabled all onboard devices with no success.
    One last thing I tryed is a clean install with a DVD. Even this attempt failed, the DVD was unable to complete the boot process.
    I suspect a problem with the new boot process, not with an installed driver.
      My ComputerSystem Spec

  5.    06 May 2018 #5

    The option clean install from DVD I doesn't try at the moment, because that's the last change to try. Maybe I find a unused harddisk in my storage, I will try it without affect my production-windows-installation.

    Whats error-message do you get during clean installation? Do you use a RAID too?
      My ComputerSystem Spec

  6.    06 May 2018 #6

    I got no error message. The DVD just starts booting and PC hangs before I can have any message about the install process. The DVD stops spinning and keyboard becomes unresponsive.
    I've got no RAID configured, only AHCI in BIOS.
      My ComputerSystem Spec

  7.    07 May 2018 #7

    Hi jer11848,

    I am having the exact same problem. Have tried everything you have and have had no luck. So frustrating.
      My ComputerSystem Spec

  8. Bree's Avatar
    Posts : 8,602
    10 Home x64 (1803) (10 Pro on 2nd pc)
       07 May 2018 #8

    jer11848 said: View Post
    ...the update failed with a 0xC1900101-0x20017 error, which seems to be some sort of driver problem, but it doesn't indicate which driver is the issue...

    The log files mentioned below should tell you...

    Code
    0xC1900101 - 0x20017

    Cause
    A driver has caused an illegal operation.
    Windows was not able to migrate the driver, resulting in a rollback of the operating system.
    This is a SafeOS boot failure, typically caused by drivers or non-Microsoft disk encryption software.

    Mitigation
    Ensure that all that drivers are updated.
    Open the Setuperr.log and Setupact.log files in the %windir%\Panther directory, and then locate the problem
    https://docs.microsoft.com/windows/d...res#0xc1900101
      My ComputersSystem Spec


  9. Posts : 20,009
    windows 10 professional version 1607 build 14393.969 64 bit
       07 May 2018 #9

    Open file explorer > this PC > C: > in the right upper corner search for: Setupact.log > zip > post a share link into the thread

    Run the beta log collector and post a zip into this thread.
    https://www.tenforums.com/attachment...-v2-beta10.zip
    (extract > open)
    Use the text and images in this link in case there are any problems running the beta log collector: (post #5)
    DM Log tool problem Solved - Windows 10 Forums


    What antivirus software has been installed since the last Windows upgrade?
    What non-Microsoft drive encryption software was in use since the last windows upgrade?
    For the upgrade failure was the computer in clean boot?
      My ComputerSystem Spec

  10.    08 May 2018 #10

    try to disable vt-d setting in bios.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I'm trying to install the 2018 feature update on a desktop running Win10 Home x64 with an Asus P6T motherboard and nVidia GTX650 Ti Boost video card. The update gets to 100% installed, puts up a msg saying that it wants to reboot, spends a couple of...
I had two hard drives installed on my computer and one of them died on me. I couldn't even boot up any longer but I had backed up all my data, so I was not too worried. Anyway, I had the free Windows 10 install upgrade from Windows 8. I was...
Can anyone help me with this error? I get it every time when trying to get version 1607. I have checked many times; this is not related to any drivers but to something I do not understand. Here are included my Panther and Rollback folders....
My Parents figured it was time to upgrade to ten so I made up a disc and upgraded both their computers to 10 build 10586 successfully. I had already had 10, I got new parts so I upgraded via a disk my dad made when 10 first came around, build 10240....
35046Windows 10 goes through the entire download/installation process, restarts, blue screens with a "system thread exception not handled (iastora.sys). It then restarts and shows this error for windows 10. Am I screwed? It goes back to the desktop...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:48.
Find Us