Windows 10: Windows 10 Feature Update 1709 Install Error - VirtualDrive 10 Solved

Page 1 of 2 12 LastLast
  1.    19 Dec 2017 #1

    Windows 10 Feature Update 1709 Install Error - VirtualDrive 10


    Windows 10 Feature update 1709 will not install with the error that first I need to uninstall VirtualDrive 10. The problem is I am not aware of having such a programme on my system. I uninstalled all Roxio products and also uninstalled Ashampoo burning studio 16 in case that had something to do with it. I am not aware of having any such a programme called VirtualDrive 10 on my system. I ran msinfo32 and search for the words Virtual, VirtualDrive and Virtual Drive and can't find anything. I did a registry search and there are some instances of "VirtualDrive" on my system probably relating to Roxio or maybe Faststone Virtual Drive but I am not aware of having any of these programmes actually installed. This is a great mystery to me. I am not sure where to go from here. Your thoughts would be appreciated.

    Kind regards
    Chris
    Attached Thumbnails Attached Thumbnails Virtual Drive 10 Error.JPG   Uninstall Virtual Drive 10.JPG  
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 10,553
    Windows 10 Pro x64 Build 1803
       19 Dec 2017 #2

    Hi Chris.

    This product (Farstone VitualDrive 10) appears to be a product for circumventing copy protection on games.

    By forums rules we cannot provide assistance with these tools or Windows issues that may result.


    Ken
      My ComputerSystem Spec

  3.    20 Dec 2017 #3

    Caledon Ken said: View Post
    Hi Chris.

    This product (Farstone VitualDrive 10) appears to be a product for circumventing copy protection on games.

    By forums rules we cannot provide assistance with these tools or Windows issues that may result.


    Ken
    But we are permitted to provide help to uninstall it so OP is not using such stuff.
      My ComputerSystem Spec

  4. Caledon Ken's Avatar
    Posts : 10,553
    Windows 10 Pro x64 Build 1803
       20 Dec 2017 #4

    Agree but now that he knows what it is I'm hoping he knows how.
      My ComputerSystem Spec

  5.    20 Dec 2017 #5

    Thank you both for your replies. Of course I wish to respect the forum rules. I was not aware that Farstone VirtualDrive had such a negative reputation. Its basically a virtual CD/DVD emulator programme that allowed a user to run a programme from the hard drive instead of having to put the CD/DVD in every time. I used it for legally purchased software for personal use. I uninstalled it years ago from my Win 7 machine before upgrading to Win 10. So there may be some dead registry entries left over.

    However, I am not entirely convinced that Farstone VirtualDrive is the culprit here. The Windows error message may be alluding to other Virtual Drive software like Roxio Virtual Drive or something else that I am aware of. If I delete the wrong entries in the registry I could mess up something. Windows has its own Virtual Drive modules somewhere. If there was a way to find out exactly what Windows Update doesn't like I could delete it. I will look inside the registry a bit more and see if I can find anything that should not be there. Thanks again.


    Kind Regards
    Chris
      My ComputerSystem Spec

  6. Caledon Ken's Avatar
    Posts : 10,553
    Windows 10 Pro x64 Build 1803
       20 Dec 2017 #6

    I would not be messing with registry, one members opinion.

    I've seen what you are describing, recently there is a posting on TrendMocro, where uninstalled products come up as an issue.

    I would start with the vendor and see if they have a removal tool.

    If they don't I would try a tool like Revo Uninstaller.

    In any case I would create a backup before i did anything with a toll like Macrium Reflect.

    Backup and Restore with Macrium Reflect
      My ComputerSystem Spec

  7.    20 Dec 2017 #7

    I agree with Ken... don't willy-nilly go messing with the registry...

    I know this is not gonna be popula... but use CCleaner to clean up those registry fragments ( make sure to affirm the back up prior should you need to restore)
      My ComputerSystem Spec

  8.    20 Dec 2017 #8

    If you only have leftover registry entries, Revo won't help 'cos it won't have anything to identify as an installed program. The Ccleaner scan suggested by @Superfly may well help, but I suggest you only delete the minimum number of registry entries.

    Otherwise you have two options:
    - reinstall the program to which Virtualdrive 10 relates, and then uninstall with Revo or Geek Uninstaller.
    - If you aren't sure of the program, back up the registry, then search it using a tool such as O&O registry editor which searches the whole registry rather than stopping on each found item, and delete selectively.

    There's one other possibility:
    Use a free tool such as Everything by Void Tools, Locate 32 or Ultrasearch which provide excellent find as you type results for a selected disk or partition after a quick index scan, and search for anything related to Virtual etc.

    If you can find an exe or dll, then use Revo Uninstaller, browse to that and then 'uninstall'.
      My ComputerSystem Spec

  9.    21 Dec 2017 #9

    Thank you all for your comments. I regularly use ccleaner to clean up unnecessary files and clean the registry but that did not stop the Windows update error (I must say that in all the years I have used ccleaner it has never caused me any problems; it has actually solved many issues for me).

    I found the old setup file for VirtualDrive10 and tried to install with the intention of immediately uninstalling but the setup would not launch with the message that this programme was incompatible with Win 10 (no surprises).

    I went to a Microsoft forum and was advised to download a fresh copy of Win 10 and perform a repair install and to select the option to check for updates.

    http://www.microsoft.com/en-us/softw...load/windows10
    https://answers.microsoft.com/en-us/...7-f40096ec3085

    That failed with the same error message.

    Click image for larger version. 

Name:	Windows Install Error.JPG 
Views:	15 
Size:	38.4 KB 
ID:	169054

    In the meantime I have managed to solve the problem. The solution was quite simple. On a hunch I suspected that Windows update was looking in my personal storage drives for evidence of incompatible programmes instead of just my C drive. I went to disk management and selected to put my two storage drives offline so I was just left with my C drive. I went to settings/update and security and ran windows update in the normal way and feature update 1709 installed without any problems. After rebooting to finish the update I put both drives online again and all is well. One of the drives had a "Foreign" status so I right clicked to select to get it back online.Troubleshooting Disk Management
    So basically there is a bug in Windows Update that causes it to look in other drives instead of just the C drive for evidence of incompatible programmes. I hope this information will be useful to others who encounter a similar problem.
    Kind regards
    Chris
    Last edited by Chris Nicola; 21 Dec 2017 at 09:44.
      My ComputerSystem Spec

  10. Caledon Ken's Avatar
    Posts : 10,553
    Windows 10 Pro x64 Build 1803
       21 Dec 2017 #10

    Thanks for posting this. Very helpful and great detail other should be able to follow.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Does anyone know how long it should take for the feature update of Windows 10 version 1709 to prepare to install on a PC? My own installation, courtesy of Windows Update, has taken about 90 minutes and is only 30% prepared to install. Can...
I had similar troubles when upgrading from windows 7 to windows 10 but managed to get through it by removing all usb peripherals except keyboard and mouse. I recently upgraded my motherboard, ram, cpu and graphics card. I was online with...
Solved Feature update windows 10 version 1709 in Windows Updates and Activation
It downloads then tries to install but said I need to fix issue first click on fix issue . When i click fix issue it starts over again and when done says can not update? Have done this numerous times and still wont download or install this update.
As the title of the topic suggests, the update is just stuck at 96%. This is the second time I'm trying to download this update. The first time it was stuck at 95% and now this. Is there any other way to download this update. And also, how should...
Feature update to Windows 10 version 1709 in Installation and Upgrade
I have Windows 10 version 1703 OS Build 15063.726 . The Feature update 1709 says it is downloading on my Laptop, but it hasn't moved from 0% for a full day (10 hours)...any advice would be welcome as I think it should have moved on by now.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 07:45.
Find Us