Windows 10: blu ray problems with latest build

  1.    19 Jun 2017 #1

    blu ray problems with latest build


    Every time the latest build is installed my blu-ray (films) player stops working, I get an on screen message in cyber link saying my Graphics card is incompatible. After restoring build 16199 all is o/k again.
    Tried latest Drivers from AMD.

    System
    AMD A6-6400k Cpu
    Asus A88xm-A MB
    16 Gb ddr3 Ram
    Radion RX 480 Graphics card.
    cyberlink 17 Blu-Ray software Player

    Monitors
    Asus 23"(On DVI)
    Tv sony Kd-49x8307c (HDMI)
    Huion 18" Graphics Tablet (HDMI).

    Help anyone?.
    Regards Topper.
      My ComputerSystem Spec


  2. Posts : 19,896
    windows 10 professional version 1607 build 14393.969 64 bit
       23 Jun 2017 #2

    For the problem you are describing I was not sure if my experience with clean installs and cyberlink would be relevant. So the post was edited and if possible I would have deleted it.

    After clean installs I was able to install the HP cyberlink and then was not able to play blu-ray. With frustration I download the trial cyberlink and then was able to immediately play the blu-ray. But over time by trial and error I got it to play blu-ray by this method:
    The computer had come with factory installed windows 7 professional and HP applications including cyberlink. The computer had been upgraded to windows 10. Months later a clean install was performed and a new installation of windows 10. The drivers and applications for the computers configuration and operating system were downloaded from the HP web site and it would only play dvds but not blu-ray. The cyberlink was then uninstalled. The drivers and applications were viewed for windows 7. The cyberlink application was downloaded and installed. An upgrade was then made and it played blu-ray. For the computers I also had HP recovery media including applications. On another computer with a clean install and the cyberlink blu-ray problem I installed the cyberlink from the recovery media and then was able to upgrade.

    So I don't know if the above will be of any value to you. You might try to get the older cyberlink version that was issued for windows 7 or 8 and see if it allows upgrading so that you don't have the blu-ray problem.

    Cyberlink has there own support but I had not used it. You might give that a try in case you don't find a solution.
      My ComputerSystem Spec

  3.    15 Jul 2017 #3

    In the end i purchased a Blu-ray player(£50) I can not be bothered it costs more money trying to use my pc as a player.
    My pc setup will play Blu-ray but its to much hassle,hit and miss and the quality is intermitant.
      My ComputerSystem Spec

  4.    15 Jul 2017 #4

    Did you check for program updates? The Cyberlink website lists the latest dated June 2017.
    https://www.cyberlink.com/support/po...hes_en_US.html
      My ComputerSystem Spec

  5.    15 Jul 2017 #5

    Yes did that. I will investigate later but at the moment i can not install beyond insider Build 16237.

    Thanks anyway.
      My ComputerSystem Spec

  6.    23 Jul 2017 #6

    If you want to try a free program you can try Leawo Blu-ray Player. I use it on my computer and haven't had any problems. Best Free Blu-ray Player Software for Windows - Leawo Blu-ray Player
      My ComputerSystem Spec


 

Related Threads
After installing 16215 on the tablet, now I have some issues with spanish keyboard Accented characters with the physial keyboard stopped working. Pressing the accent key plus the letter make this: ´´a instead of á in all Win32 programs Metro ones...
Latest Win10 Update problems. in General Support
Deleted.
I've been stuck on build 11102.rs1_release.160113-1800. Going to Settings. Update & Security, Check for updates says "your device is up to date". Checked for updates at least 10 times and always get the same response "Your device is up to date". ...
Somewhat unusual situation here. A machine running the latest build (11102) got badly infected by malware. It was such a major attack that I was about to reload the earlier day's image from my Windows Home Server. But it seemed even easier to...
Updated to the latest 10 update last night and Edge is almost unuseable. Takes about 5-10 minutes for the computer (esp Edge) to unfreeze and start playing nice. Anyone else having this issue?
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 10:05.
Find Us