Page 2 of 4 FirstFirst 1234 LastLast
  1.    10 Feb 2017 #11
    Join Date : Jul 2014
    Serbia
    Posts : 10,454
    W10 Insider + Linux

    Quote Originally Posted by f14tomcat View Post
    Seems it is polling around the system looking for connected devices. In old-school terms, it was sizing the attached devices. Rolled my mouse a few times up/down and all was there. All fine. Just a little jerky-jumpy while it takes inventory.
    You mean Devices ? Still same thing, not connected. AC might have different cause. At first I was blaming it on GPU drivers but it's deeper in the system.
      My ComputersSystem Spec
  2.    10 Feb 2017 #12
    Join Date : Oct 2014
    Arnold, MD
    Posts : 29,071
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
    Thread Starter

    Quote Originally Posted by CountMike View Post
    You mean Devices ? Still same thing, not connected. AC might have different cause. At first I was blaming it on GPU drivers but it's deeper in the system.
    I see what you mean! Windows insists they are not connected, but they are indeed connected or I wouldn't be typing this! Maybe it's confused and is saying they are not connected via Bluetooth. Sees all the drives, though. Weird.

    Click image for larger version. 

Name:	2017-02-10_06h27_48.png 
Views:	2 
Size:	43.4 KB 
ID:	120598
      My ComputersSystem Spec
  3.    10 Feb 2017 #13
    Join Date : Jul 2014
    Serbia
    Posts : 10,454
    W10 Insider + Linux

    There's Devices and printers lower down and that opens same as from Control panel.
      My ComputersSystem Spec
  4.    10 Feb 2017 #14
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,979
    Windows 10 Pro

    I have to say I don't care what my Settings > Devices tells me, that is a minor issue. Main thing for me is that everything works, especially for me very important casting to wireless displays.

    Click image for larger version. 

Name:	image.png 
Views:	2 
Size:	127.9 KB 
ID:	120600
    Attached Thumbnails Attached Thumbnails image.png  
      My ComputerSystem Spec
  5.    10 Feb 2017 #15
    Join Date : Jul 2014
    Serbia
    Posts : 10,454
    W10 Insider + Linux

    It's not a big issue because all that can be reached from somewhere else but may be fun to find out what's causing it and how to fix it (eventually). Learning causes and fixes also sharpens other skills.
      My ComputersSystem Spec
  6.    10 Feb 2017 #16
    Join Date : Oct 2013
    A Finnish expat in Germany
    Posts : 12,979
    Windows 10 Pro

    Quote Originally Posted by CountMike View Post
    It's not a big issue because all that can be reached from somewhere else but may be fun to find out what's causing it and how to fix it (eventually). Learning causes and fixes also sharpens other skills.
    Just to be sure there are no misunderstandings: I fully understand your point. I just wanted to tell my honest opinion. I got a deal breaking issue resolved thanks to this fix and can now cast to wireless displays. I couldn't be happier.

    That's why what Settings tells about connection status is at this point completely irrelevant to me, as long as I know the actual status being they are connected.
      My ComputerSystem Spec
  7.    10 Feb 2017 #17
    Join Date : Jun 2015
    Egypt
    Posts : 72
    Windows 10 Insider Preview

    Quote Originally Posted by f14tomcat View Post
    If you have experienced the Action Center acting weird, the tiles going nowhere, All Settings not working, Night light not working....and crashing settings with clicking Devices I have found what looks like a quick and easy workaround.

    I noticed every time I clicked Action Center in the taskbar, this error was logged.

    Code:
    Log Name:      Application
    Source:        Application Error
    Date:          2/9/2017 6:49:31 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      DESKTOP-BRKF83D
    Description:
    Faulting application name: SystemSettingsBroker.exe, version: 10.0.15031.0, time stamp: 0xdb537eff
    Faulting module name: DeviceFlows.DataModel.dll, version: 10.0.15031.0, time stamp: 0x58969f5b
    Exception code: 0xc0000409
    Fault offset: 0x00000000000052b0
    Faulting process id: 0x2754
    Faulting application start time: 0x01d2832f2865dec3
    Faulting application path: C:\Windows\System32\SystemSettingsBroker.exe
    Faulting module path: C:\Windows\System32\DeviceFlows.DataModel.dll
    Report Id: 816c09b4-4365-41a5-b2a9-0857806be9bf
    Faulting package full name: 
    Faulting package-relative application ID: 
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2017-02-09T23:49:31.620066900Z" />
        <EventRecordID>722</EventRecordID>
        <Channel>Application</Channel>
        <Computer>DESKTOP-BRKF83D</Computer>
        <Security />
      </System>
      <EventData>
        <Data>SystemSettingsBroker.exe</Data>
        <Data>10.0.15031.0</Data>
        <Data>db537eff</Data>
        <Data>DeviceFlows.DataModel.dll</Data>
        <Data>10.0.15031.0</Data>
        <Data>58969f5b</Data>
        <Data>c0000409</Data>
        <Data>00000000000052b0</Data>
        <Data>2754</Data>
        <Data>01d2832f2865dec3</Data>
        <Data>C:\Windows\System32\SystemSettingsBroker.exe</Data>
        <Data>Log Name:      Application
    Source:        Application Error
    Date:          2/9/2017 6:49:31 PM
    Event ID:      1000
    Task Category: (100)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      DESKTOP-BRKF83D
    Description:
    Faulting application name: SystemSettingsBroker.exe, version: 10.0.15031.0, time stamp: 0xdb537eff
    Faulting module name: DeviceFlows.DataModel.dll, version: 10.0.15031.0, time stamp: 0x58969f5b
    Exception code: 0xc0000409
    Fault offset: 0x00000000000052b0
    Faulting process id: 0x2754
    Faulting application start time: 0x01d2832f2865dec3
    Faulting application path: C:\Windows\System32\SystemSettingsBroker.exe
    Faulting module path: C:\Windows\System32\DeviceFlows.DataModel.dll
    Report Id: 816c09b4-4365-41a5-b2a9-0857806be9bf
    Faulting package full name: 
    Faulting package-relative application ID: 
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Application Error" />
        <EventID Qualifiers="0">1000</EventID>
        <Level>2</Level>
        <Task>100</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2017-02-09T23:49:31.620066900Z" />
        <EventRecordID>722</EventRecordID>
        <Channel>Application</Channel>
        <Computer>DESKTOP-BRKF83D</Computer>
        <Security />
      </System>
      <EventData>
        <Data>SystemSettingsBroker.exe</Data>
        <Data>10.0.15031.0</Data>
        <Data>db537eff</Data>
        <Data>DeviceFlows.DataModel.dll</Data>
        <Data>10.0.15031.0</Data>
        <Data>58969f5b</Data>
        <Data>c0000409</Data>
        <Data>00000000000052b0</Data>
        <Data>2754</Data>
        <Data>01d2832f2865dec3</Data>
        <Data>C:\Windows\System32\SystemSettingsBroker.exe</Data>
        <Data>C:\Windows\System32\DeviceFlows.DataModel.dll</Data>
        <Data>816c09b4-4365-41a5-b2a9-0857806be9bf</Data>
        <Data>
        </Data>
        <Data>
        </Data>
      </EventData>
    </Event></Data>
        <Data>816c09b4-4365-41a5-b2a9-0857806be9bf</Data>
        <Data>
        </Data>
        <Data>
        </Data>
      </EventData>
    </Event>


    I took ownership of the .dll, C:\Windows\System32\DeviceFlows.DataModel.dll , renamed it to C:\Windows\System32\DeviceFlows.DataModel_old.dll

    Then I got a copy of the same .dll from a 15025 build, copied it into C:\Windows\System32.

    Without re-booting, I checked clicking on Action Center. ALL tiles worked correctly, including Night Light. All settings took me to the Settings Applet. And Devices did NOT crash!

    I re-booted and the setting stayed. SFC /scannow will, of course, undo this and put it right back.

    This is the 15025 .dll - x64 Pro

    Attachment 120546

    I've noticed no ill effects. Just wanted to pass this along if you care to try.

    TC
    thank you! it was getting strange, first time last build i made with my own ESD only Night Light was grayed out, downloaded 15025 official ISO and Location was grayed out too along with Night Light, now after 15031 i had Night Light, Location AND Brightness grayed out, after your workaround only now Location is grayed out i'm not sure why, i can't seem to turn it on in Settings, every time i turn on the switch it goes back to off and it still grayed out in Action Center

    UPDATE: i just remembered seeing the Location icon appearing in the task bar earlier, after drive installations and a couple restarts it was gone, so i might need to make another new clean install to see what is causing it to turn off
      My ComputerSystem Spec
  8.    10 Feb 2017 #18
    Join Date : Oct 2014
    Arnold, MD
    Posts : 29,071
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
    Thread Starter

    Quote Originally Posted by gasseratef View Post
    thank you! it was getting strange, first time last build i made with my own ESD only Night Light was grayed out, downloaded 15025 official ISO and Location was grayed out too along with Night Light, now after 15031 i had Night Light, Location AND Brightness grayed out, after your workaround only now Location is grayed out i'm not sure why, i can't seem to turn it on in Settings, every time i turn on the switch it goes back to off and it still grayed out in Action Center

    UPDATE: i just remembered seeing the Location icon appearing in the task bar earlier, after drive installations and a couple restarts it was gone, so i might need to make another new clean install to see what is causing it to turn off
    @gasseratef ... there are 2 "settings" for Location to work together. Little confusing, but make sure you have each set the way you want. These are mine, and the Location tile in AC works fine.

    Click image for larger version. 

Name:	2017-02-10_07h53_51.png 
Views:	24 
Size:	29.9 KB 
ID:	120609
      My ComputersSystem Spec
  9.    10 Feb 2017 #19
    Join Date : Jun 2015
    Egypt
    Posts : 72
    Windows 10 Insider Preview

    Quote Originally Posted by f14tomcat View Post
    @gasseratef ... there are 2 "settings" for Location to work together. Little confusing, but make sure you have each set the way you want. These are mine, and the Location tile in AC works fine.

    Click image for larger version. 

Name:	2017-02-10_07h53_51.png 
Views:	24 
Size:	29.9 KB 
ID:	120609
    yes sorry if i wasn't clear
    every time i turn it on, once i leave that white pop-up window, it goes back to off
    but the Location Services below it never goes on whether it turn the Location in Change on or not
    Click image for larger version. 

Name:	1.png 
Views:	22 
Size:	12.6 KB 
ID:	120611 Click image for larger version. 

Name:	2.png 
Views:	22 
Size:	12.1 KB 
ID:	120612 Click image for larger version. 

Name:	3.png 
Views:	22 
Size:	35.8 KB 
ID:	120613
      My ComputerSystem Spec
  10.    10 Feb 2017 #20
    Join Date : Oct 2014
    Arnold, MD
    Posts : 29,071
    Triple boot - Win 10 Pro, Win 10 Pro Insider (2) - (and a sprinkling of VMs)
    Thread Starter

    Quote Originally Posted by gasseratef View Post
    yes sorry if i wasn't clear
    every time i turn it on, once i leave that white pop-up window, it goes back to off
    but the Location Services below it never goes on whether it turn the Location in Change on or not
    Gotcha...
      My ComputersSystem Spec

 
Page 2 of 4 FirstFirst 1234 LastLast


Similar Threads
Thread Forum
Customization Open Action Center in Windows 10
How to Open and Use Action Center in Windows 10 In Windows 10, action center is where to find your app notifications, as well as quick actions, which give you quick access to commonly used settings and apps. The action center will show you...
Tutorials
Action Center displays messages after the action has taken place
Action Center on my Win 10 64-bit PC sometimes works correctly and posts messages when an event occurs, e.g. an email being delivered or a USB stick being removed from a port. At other times though, the messages may not be displayed until 10 - 60...
General Support
How to get pop-up from action center?
I use the mail app from windows 10 for my e-mail.Is it possible to get a pop-up from the action center when i get a e-mail? At the moment i see only on the icon in the taskbar that a got a e-mail but without a pop-up.
Browsers and Email
Action Center
How to remove those annoying "back up files" notifications in action center when I already use an external drive
General Support
Action Center will not open
I have the icon for new notifications but when I choose to ''Open Action Center'' nothing happens, also the WIN+A keys do not open it either. Can someone tell me what the matter is? I daily see the icon while hovering over with the mouse indicate...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:29.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums