Windows 10: Anybody else having driver difficulties with Build 14926?

Page 1 of 2 12 LastLast
  1.    15 Sep 2016 #1

    Anybody else having driver difficulties with Build 14926?


    Installed the latest preview on my Dell Venue Pro 7139 last night, then spent a couple of hours cleaning up driver issues. It ate my Dell/Atheros 1537 WiFi/BlueTooth drivers completely, and rolled back Intel HD Graphics, Intel MEI, SMBus controller, memory controller, and more. I'm curious to know if it's just this machine, or if others have experienced similar difficulties.
    This used to happen back before the Insider Preview program got started, before Windows 10 was officially released on 7/29/2015. But it's been a while since I've seen these kinds of gyrations.
    Thanks,
    --Ed--
      My ComputersSystem Spec

  2.    15 Sep 2016 #2

    The only problem I have is itunes not detecting my phone. This happened awhile back and was corrected with a clean install. I Just don't feel like clean installing right now. ASUS G750

    P.S. I had to reinstall the apple usb driver.

    P.P.S. I clean-installed Thursday and all worked the first time!
    Last edited by THempleman; 23 Sep 2016 at 09:46.
      My ComputerSystem Spec


  3. Posts : 22,836
    64-bit Windows 10 Pro build 16257
       15 Sep 2016 #3

    I've been having issues with slow loading between webpages off and on so far since installing build 14926.
      My ComputersSystem Spec


  4. Posts : 624
    Windows 10 Pro Insider Preview (14971)
       16 Sep 2016 #4

    I had issues with the Intel G33 drivers - I had to go to the Microsoft Basic Display Adapter.
      My ComputerSystem Spec


  5. Posts : 22,836
    64-bit Windows 10 Pro build 16257
       18 Sep 2016 #5

    Brink said: View Post
    I've been having issues with slow loading between webpages off and on so far since installing build 14926.
    Refreshing the DNS address on the router finally sorted it.
      My ComputersSystem Spec

  6.    19 Sep 2016 #6

    Wow, Brink! That's really interesting. You'd think the DNS cache would either work or fail. Strange that it simply slowed things down. Maybe it was some non-optimal routes or something? Bizarre.
    --Ed--
      My ComputersSystem Spec


  7. Posts : 291
    Windows 10 Pro 64bit 1703 (15063.502)
       19 Sep 2016 #7

    Still can't view my NAS or my 2 My Book Live drives?
    This was NOT fixed from the last build. Why is it that MS can ruin it then fix it then ruin it AGAIN?
      My ComputerSystem Spec


  8. Posts : 22,836
    64-bit Windows 10 Pro build 16257
       19 Sep 2016 #8

    EdTittel said: View Post
    Wow, Brink! That's really interesting. You'd think the DNS cache would either work or fail. Strange that it simply slowed things down. Maybe it was some non-optimal routes or something? Bizarre.
    --Ed--
    I can only guess that it was something on the ISP's end that this toggled it to work properly again. It was odd.
      My ComputersSystem Spec

  9.    19 Sep 2016 #9

    No driver problems on my desktop.
      My ComputerSystem Spec


  10. Posts : 3,670
    Win10 Home and Pro, Win10 Insider Preview, Win7 Home, Linux Mint
       19 Sep 2016 #10

    I've had issues with Build 14915 and 14926 on a Dell Inspiron 530S Desktop with the Intel G33 display adapter and no SSE4.1 listed in the BIOS, had to back to 14901 which works well, haven't found 14905 again which worked really well.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Update: 776527785577754624 776103878567747584 Source: Announcing Windows 10 Insider Preview Build 14926 for PC and Mobile | Windows Experience Blog
wifi settings difficulties in Network and Sharing
Symptoms: 1)Under one user account, wifi settings are not preserved. If I run ms-settings:network and select "Manage wifi settings", there is no choice for "Manage known networks". 2)Under a second user account, I cannot see wifi choices at...
Why does Hotmail/Outlook have such difficulty (very, very slow and often failing to open at all) loading in Windows 10 - especially as Gmail is fine (very quick to open and never fails)??
Difficulties downloading Windows 10 in Installation and Upgrade
Hi all, I currently have Windows 8.1 and am looking to upgrade to Windows 10. I reserved a copy, and then got told it was ready to Download. I started the download and all seemed to be going fine for an hour. That was three days ago. Now, I...
I went from Windows 7 to Windows 10 yesterday. The upgrade went smoothly. But is it my imagination, or is everything now sitting on a brilliant white background? I'm getting eye-strain. Also, the new web browser (Edge, is it called?) has a...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 11:34.
Find Us