1.    02 May 2015 #1
    Join Date : May 2015
    Berkeley, CA
    Posts : 7
    Windows 10 Preview 10074

    Build 10074 not picking up/laggy on keystrokes?


    I've been noticing this since the update to 10074 (from 10069? I forget) yesterday, and at first I thought it was my laptop's much hated keyboard acting up, but it does the same thing with my external Razer Blackwidow keyboard. (am running a Lenovo Y50-70 4k)

    It _seems_ like it doesn't always register that modifier keys (shift, ctrl, alt, windows) are pressed with a key. When editing code in an editor I haven't upgraded in weeks, it's missing the Ctrl when I cut/copy/paste/undo or save, but I'll see the key I pressed in my code (like s for save, z for undo, etc.)

    VERY frustrating! Is anyone else experiencing this since upgrading to Windows 10 Pro Insider Preview Build 10074?
      My ComputerSystem Spec
  2.    02 May 2015 #2
    Join Date : May 2015
    Posts : 59
    Windows 10

    I haven't noticed anything with the keys, but I did notice a very slight (maybe half second) lag when mouse clicking tiles or buttons on the start menu before a program would open... or at least before the start menu responded. Not a big deal really, but maybe it's some kind of related input lag?

    Are you getting this lag in any specific apps? Sometimes I have slight input lag in a browser, but that's not related to Windows 10 specifically.

    Sorry I don't have more info for you. Have you checked the windows feedback tool to see if anyone else is reporting problems like this?
      My ComputerSystem Spec
  3.    03 May 2015 #3
    Join Date : May 2015
    Berkeley, CA
    Posts : 7
    Windows 10 Preview 10074
    Thread Starter

    Thanks for your reply Drybonz. I took your advice and scoured the issue with the windows feedback tool. I saw various issues (slow windows key seems to be a biggie), but nothing really approaching my issue.

    Let me give a couple more examples that have plagued me this afternoon:

    In explorer (windows desktop), when pressing ALT+TAB to switch between windows. Very often, it seems to 'lose' that I'm holding down ALT still, switching me to whatever app I had marked with ALT+TAB at the time.

    In notepad++ (notepad.exe replacement), if I simply try to mark a bunch of lines by holding down SHIFT and then pressing arrow or page down, my marked area will un-mark --- as if I stopped pressing the Shift key, and just started pressing arrow down / page down. VERY VERY frustrating! This will happen after, oh, maybe 10 lines. Using the mouse is my workaround for the moment.

    It's almost impossible to use Windows without it registering and keeping stuck modifier keys I am holding down (shift, ctrl, alt, windows).

    My editor (notepad++) in the past day will now have a couple "s" characters in a row, or a bunch of "z"s. This is when I wanted to either save what I was working on (ctrl+s), or undo something (ctrl+z). As I mentioned, this happens on both the laptop's built in keyboard, and a higher end razor 'gaming' keyboard (has a clicky feel I like - I don't use it for games).

    Thanks for listening. This is very frustrating you can imagine! I don't have a dual-boot setup, but am going to have to before I go postal, heh.
      My ComputerSystem Spec
  4.    03 May 2015 #4
    Join Date : May 2015
    Berkeley, CA
    Posts : 7
    Windows 10 Preview 10074
    Thread Starter

    I should say, I think the issue is related to Explorer.exe, as it's a hook between the normal keyboard driver and applications. I noticed others have had problems with it crashing. It's crashed on me a couple of times now, and manifests by the Windows key not working. I use the SysInternal tools "process explorer" as a taskmgr.exe replacement, and from there I just start explorer.exe again.
      My ComputerSystem Spec
  5.    03 May 2015 #5
    Join Date : May 2015
    Berkeley, CA
    Posts : 7
    Windows 10 Preview 10074
    Thread Starter

    One more (pretty important) point: I've been trying to see if there's a pattern to any of this, and my current theory is that the state of the modifier-keys is getting reset on a fixed periodic interval of about 2-3 seconds. In other words, any time in that two-three seconds the modifier keys will work and hold, and then, on the interval, it resets the state of these keys (making it so my Ctrl-Zs start showing up in my editor as "z"s, making it so my shift-arrow to mark text will stop and unmark the text, reverting to the behavior of just the arrow key w/o the shift.

    I wish this was just the built in keyboard on the Lenovo Y50-70 which I don't really like, but alas.
      My ComputerSystem Spec
  6.    03 May 2015 #6
    Join Date : May 2015
    Berkeley, CA
    Posts : 7
    Windows 10 Preview 10074
    Thread Starter

    This problem is killing my ability to do anything but the smallest tasks, so I'm a little OCD about a solution. A test I modified from another website (modified to print sequence#s and have a "stop keys" button, so I could copy the results) - Javascript Key Event Tester

    What I did: clicked on the modifiers checkbox, held down the right shift key, and then the m key until it started to repeat for a second:

    0:keydown keyCode=16 which=16 charCode=0
    1: shiftKey=true ctrlKey=false altKey=false metaKey=false
    2:keydown keyCode=77 (M) which=77 (M) charCode=0
    3: shiftKey=true ctrlKey=false altKey=false metaKey=false
    4:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)
    5: shiftKey=true ctrlKey=false altKey=false metaKey=false
    6:keyup keyCode=16 which=16 charCode=0
    7: shiftKey=false ctrlKey=false altKey=false metaKey=false
    8:keydown keyCode=77 (M) which=77 (M) charCode=0
    9: shiftKey=false ctrlKey=false altKey=false metaKey=false
    10:keypress keyCode=109 (m) which=109 (m) charCode=109 (m)
    11: shiftKey=false ctrlKey=false altKey=false metaKey=false
    12:keydown keyCode=77 (M) which=77 (M) charCode=0
    13: shiftKey=false ctrlKey=false altKey=false metaKey=false
    14:keypress keyCode=109 (m) which=109 (m) charCode=109 (m)
    15: shiftKey=false ctrlKey=false altKey=false metaKey=false
    16:keydown keyCode=77 (M) which=77 (M) charCode=0
    17: shiftKey=false ctrlKey=false altKey=false metaKey=false
    18:keypress keyCode=109 (m) which=109 (m) charCode=109 (m)
    19: shiftKey=false ctrlKey=false altKey=false metaKey=false

    everything starts off right -- my keydown event shows I'm getting a capital M, and the shiftKey is held down. As usual, somewhere in the first second or two the shiftKey goes unshifted, BUT, notice the keydown event still shows the proper key, it's only the event after that, the keydown event, that switches.

    Thanks for listening. Something tells me I'll be uninstalling this build before the night's end, as I have a new coding job tomorrow and the last thing I need is my laptop forgetting I pressed a shift, ctrl or alt key.
      My ComputerSystem Spec
  7.    03 May 2015 #7
    Join Date : May 2015
    Posts : 59
    Windows 10

    Hmm... my gut tells me that since a lot of other people aren't having this problem that you have something going on there in your system, like some third party background interference or something... but I am certainly no expert. Good luck with it... I know how irritating those little problems can be.
      My ComputerSystem Spec
  8.    04 May 2015 #8
    Join Date : May 2015
    Berkeley, CA
    Posts : 7
    Windows 10 Preview 10074
    Thread Starter

    Hey Drybonz,

    Fixed it.

    I forgot about the "go back to last preview build" option (10061), and that did the trick.

    As evidenced


    MMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMM MMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMMM

    0:keydown keyCode=16 which=16 charCode=0
    1: shiftKey=true ctrlKey=false altKey=false metaKey=false
    2:keydown keyCode=77 (M) which=77 (M) charCode=0
    3: shiftKey=true ctrlKey=false altKey=false metaKey=false
    4:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)
    5: shiftKey=true ctrlKey=false altKey=false metaKey=false
    6:keydown keyCode=77 (M) which=77 (M) charCode=0
    7: shiftKey=true ctrlKey=false altKey=false metaKey=false
    8:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)
    9: shiftKey=true ctrlKey=false altKey=false metaKey=false
    10:keydown keyCode=77 (M) which=77 (M) charCode=0
    11: shiftKey=true ctrlKey=false altKey=false metaKey=false
    12:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)
    13: shiftKey=true ctrlKey=false altKey=false metaKey=false
    14:keydown keyCode=77 (M) which=77 (M) charCode=0
    15: shiftKey=true ctrlKey=false altKey=false metaKey=false
    16:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)
    17: shiftKey=true ctrlKey=false altKey=false metaKey=false
    18:keydown keyCode=77 (M) which=77 (M) charCode=0
    19: shiftKey=true ctrlKey=false altKey=false metaKey=false
    20:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)
    21: shiftKey=true ctrlKey=false altKey=false metaKey=false
    22:keydown keyCode=77 (M) which=77 (M) charCode=0
    23: shiftKey=true ctrlKey=false altKey=false metaKey=false
    24:keypress keyCode=77 (M) which=77 (M) charCode=77 (M)


    (the shift key state would 'go away' after a couple characters in preview build 10074)


    So it's back to running 10061 for awhile (and edit a feedback I wrote on it)


    The marking code or text with shift-arrow and having the "mark" go away after a couple lines was driving me nuts!
      My ComputerSystem Spec
  9.    04 May 2015 #9
    Join Date : Nov 2014
    Oregon
    Posts : 155
    Windows 10

    I find I am getting a lot of the same thing. It does not happen with much consistency though.
      My ComputerSystem Spec
  10.    04 May 2015 #10
    Join Date : May 2015
    Posts : 59
    Windows 10

    Hey, that's great... I'm glad you were able to get things fixed, even if you had to roll back. Hopefully, they get it straightened out by the next build.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved build 10074
I had build 10074 and was having problems with the mail app. I refreshed and went back to windows 8 and then 8.1. I decided to download build 10122 but when I down loaded I was only given build 10074. After downloading I was only getting windows 7,...
Windows Insider
Any idea when build the next build AFTER 10074 comes out?
hi guys, seen the video of Build 10114 (if i am correct). so when will this come out. Since Build 10074 blocked my internal network, i had to go back to Build 10061. Numbers.....numbers
Windows Insider
Windows 10 build 10074: Everything you need to know
Read more: Windows 10 build 10074: Everything you need to know | Windows Central
Windows 10 News
Build 10074 not working as should
hi guys, my network and/or homegroup no longer work. After searching and trying to fix this (a couple of hours) i gave up, gave feedback to MS and returnde to Build 10061. Hate to do a fresh install, although i have burned the ISO. So i...
Network and Sharing
Windows 10 Build 10074 Expected at BUILD 2015
Source UPDATE: https://www.tenforums.com/windows-10-news/5698-new-windows-10-insider-preview-build-10074-now-available.html
Windows 10 News
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:41.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums