Windows 10: Upgrade from 14271 to 14316 Fails with 0x80240031 Solved

  1.    15 Apr 2016 #1

    Upgrade from 14271 to 14316 Fails with 0x80240031


    I've tried many suggestions, including removing files, system cleanup, etc but it consistently fails with the 0x80240031 error code. Other Windows updates are successful, just the 14316.

    Its not a system hardware problem as it is a triple boot system with Win7/Win10/Insider Win 10. Each are on separate drives. The Insider installation is on a separate 1GB hard drive and the only thing installed, other than the default Win 10 applications, is Malwarebytes.

    I don't see a 14316 ISO yet so I can't just download that and reinstall.
      My ComputersSystem Spec


  2. Posts : 474
    Windows 10 Pro (Mix of Builds) / Linux Mint
       15 Apr 2016 #2

    The installer is having an issue with the other disc's in the system IMO.

    My main rig has 4 1Tb drives, though 3 of them are differing storage drives, only one is the master and OS booting. I had to remove my others to perform the upgrade, and then would plug back in afterwards.

    As long as no one feels pulling your other drives and doing the upgrade may not screw with the boot manager, I'd say try that.
      My ComputerSystem Spec

  3.    15 Apr 2016 #3

    I haven't had any problem with the preview updates before, with all 3 OS discs on line. Mine are not slaves like yours.
      My ComputersSystem Spec

  4.    15 Apr 2016 #4

    Fixed. The "Updates From More Than One Place was set to "on". Setting it to "OFF" fixed the problem.

    The "on" setting must be default as I've never changed it (or even looked at it). I found the solution on a Microsoft forum.

    My suspicion is that the other Win 10 installation was causing the problem (system is triple boot with Win 7/Win 10 Pro/Win 10 Preview). When I "Retried" the update it had to download the complete update. Before changing the "Choose how updates are delivered" option, it downloaded but the download was much faster suggesting some of it was being accessed from the other Win 10 installation.

    Here is the setting panel (accessed from Advanced Options, then Choose How Updates are Delivered.
    Click image for larger version. 

Name:	Settings.JPG 
Views:	21 
Size:	53.4 KB 
ID:	74905
      My ComputersSystem Spec


  5. Posts : 474
    Windows 10 Pro (Mix of Builds) / Linux Mint
       16 Apr 2016 #5

    Ahh, that is interesting, but I'm wondering how it considered a non active partition or drive with your other install as a networked resource, or did I miss something here?

    Yeah, that should always be off IMHO.

    Glad you got it though, can you set to solved for us? Thanks.
      My ComputerSystem Spec

  6.    16 Apr 2016 #6

    It is set to "solved". I did that yesterday when I posted the fix.

    The other drive is only a thought since it was a multiple boot system with another copy of Win 10 (each OS on a separate drive).

    BTW, I'm originally from Mechanicsburg, Pa.
      My ComputersSystem Spec


 

Related Threads
I'm trying to upgrade my old laptop to windows 10. Its currently running Windows 8.1 pro x64. Resources are no problem, its a core2 duo, 8 GB RAM, discreet ATI video card and plenty of space on 1TB hard drive. Upgrade using windows update...
Not cause by virus .. this just started today. I tried a restore point of yesterday .. nothing. I have tried several suggestions from the web but nothing seems to do it? I know it would be better if i could name them but can't remember the exact...
Got this " th2_release Professional 10525 - Error 0x80240031" after download 100%. Tried downloading again with same result. Can't find any info on the web about what the problem is. Anyone have a suggestion? Thanks
Solved Windows 10 fails to upgrade. in Installation and Upgrade
Have followed instructions & downloaded upgrade only to find every time it gets to 32% it fails & will not go any further, have done this four times outcome always the same can someone help I have 74gb of hard drive free so there should be enough to...
Solved Update error 0x80240031 Build 10041 in Windows Updates and Activation
I have installed Win 10 on VMware 9.0. The original install was build 9926 64bit. I tried to Auto Update to fbl-impressive 10041 Professional, but kept getting error 0x80240031. So, I downloaded Windows10_TechnicalPreview_x64_EN-US_10041.ISO...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:01.
Find Us