RDP shows only black screen in 18227.1006 Solved

  1.    14 Nov 2018 #1

    RDP shows only black screen in 18227.1006

    I can't use RDP to access either of my Insider Preview machines right now running 18227.1006. The connection starts, and the system responds to the keyboard, but the screen is dead black. I know it's responding to the keyboard because if I enter CTRL-Shift-ESC at the remote system's keyboard, when I return to the direct host screen/keyboard Task Manager has launched. Anybody have any idea on how to fix this, or know what's going on? I'm also filing a feedback hub report on this too.
      My ComputersSystem Spec

  2. Kari's Avatar
    Posts : 15,562
    Windows 10 Pro
       16 Nov 2018 #2

    Old trick that has often worked for me. This does not resolve the issue, but as a workaround it at least allows you to work on remote host.

    When facing only black screen on remote session, press CTRL+ALT+END to open Security Options. Select Task Manager:

    Click image for larger version. 

Name:	image.png 
Views:	52 
Size:	24.3 KB 
ID:	212486

    You should now see desktop, with Task manager open. If only Task Manager is shown, restart Explorer.

      My ComputerSystem Spec

  3.    16 Nov 2018 #3

    Follow-up: I was able to get one of the two machines working as an RDP client. The Venue Pro 11 is now doing OK on the latest Insider Preview build (18282.1000). I was able to get it to respond to the keyboard with a black screen, and the CTRL-ALT-ESC sequence got me into Task Manager, followed by Alt-F-N (run box), then enter explorer.exe and display came up. So far, I have not yet been able to do likewise on the XPS 2720. Can others running 18272 or 18282 please check to see if they have problems getting an inbound RDP session to show up on the host, please?
    Thanks in advance,
      My ComputersSystem Spec

  4. Kari's Avatar
    Posts : 15,562
    Windows 10 Pro
       16 Nov 2018 #4

    I have none whatsoever issues with RDP with 18282.
      My ComputerSystem Spec

  5.    18 Nov 2018 #5

    Funny thing is the XPS 2720 will happily let me use it to set up remote sessions locally. I can do so with both 17763.134 PCs and with 18282 PCs. But if I try to remote into the XPS 2720 from either type of PC I see only a black screen, though the connection sets up correctly as far as I can tell.
    Strange! I've filed a Feedback Hub report and am hoping for the best.
      My ComputersSystem Spec

  6.    29 Nov 2018 #6

    The issue is fixed in Insider Preview 18290. I also got a Twitter confirmation from Microsoft Development MGR Jen Gentleman that the fix had been included in that Build. Apparently, there was nothing wrong with my test PCs nor was I doing something wrong. It was a temporary glitch, now apparently repaired. Thanks to all who responded to my queries about this here and elsewhere. I learned some valuable keystroke sequences and RDP troubleshooting tricks from this experience.
      My ComputersSystem Spec

  7.    11 Jan 2019 #7

    I'm running the latest insider build 18312 and am having a nightmare with something close to if not exactly this.

    I've tried:
    * No bitmap caching
    * No RDP compression
    * Logging in with 2nd user
    * CTRL+ALT+ESC, CTRL+ALT+END etc (never get anywhere)
    * No Firewall
    * Network set to PRIVATE (not public)
    * Use NL Auth (on and off)
    * Fussing with Group Policy ideas from other posts
    * Restarting Remote Access/Desktop services
    * Many reboots
    * Few other things

    Most of the time I connect to the machine but the screen is just black. One out of every 10 or so tries I can get in and see the desktop for a few second but then I get disconnected. And in these occasions I have to do a hard reset because the machine is unresponsive locally ... which sucks.

    * Win 10 Insider Build 18312.rs_prerelease.190104-1630
    * Running Windows on Macbook Pro via Parallels
    * Connecting from Win 7 machine (using Microsoft RDP app or AvianWaves RD Tabs)
    * RDP worked flawlessly for years with Win7 Pro
    * RDP worked flawlessly for months with Win10 (normal, not Insider version)

    Can anyone give me some hints/ideas to try?

    Thank you in advance for any kind soul who tries to help.
      My ComputerSystem Spec

  8.    11 Jan 2019 #8

    Just to update - I gave up and rolled back to previous version of Windows 10 (before Insider) and now RDP is working again. Guess I'll have to stay away from that for now. FWIW I only installed Insider because the MSIX Packaging Tool required it for some weird reason.
      My ComputerSystem Spec

  9. Wynona's Avatar
    Posts : 22,649
    Windows 10 Skip Ahead Preview Build 18312
       15 Jan 2019 #9

    chrisemersonnc said: View Post
    Just to update - I gave up and rolled back to previous version of Windows 10 (before Insider) and now RDP is working again. Guess I'll have to stay away from that for now. FWIW I only installed Insider because the MSIX Packaging Tool required it for some weird reason.
    Maybe it'll show up in the April 2019 update.
      My ComputerSystem Spec


Related Threads
Hello everyone, I have searched the entire internet for something similar to this problem and haven't found anything, So I decided to post here hoping you guys could help me debug this problem and help other people in the future. My system:...
I have a relatively good PC but I do not think it is a hardware problem. So when I turn on my computer the HP logo shows up in normal timing (so is this not a BIOS problem), it sits on the HP logo for about 3-5 minutes, screen goes black for about...
Asus camera shows black screen in Drivers and Hardware
when ever I try to open camera I find black screen I tried different programs and it's the same laptop came with windows 10 pre installed I have ASUS ROG GL552JX laptop USB2.0 HD UVC WebCam Hardware IDs :...
I've been using Windows 10 for just over one year. For some reason the Lock Screen/Sign-in screen shows three users. All three are me in three iterations. I find also that when trying to save some excel and word documents I receive messages saying...
I am trying to figure out what is going on with my mom's laptop. Two days ago she told me she was using her laptop and everything was fine, but then she left to do some things in the kitchen and came back a bit later to the screen off. Upon waking...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:04.
Find Us