New Windows 10 Insider Preview Fast + Skip Build 18262 (19H1) Oct. 17 Insider

Page 11 of 18 FirstFirst ... 910111213 ... LastLast
  1. CountMike's Avatar
    Posts : 18,356
    W10+Developer Insider + Linux
       #100

    slicendice said:
    Something needs to be done about the WU process. My 2 VMs has been crunching numbers for 2 hours already and still not even at 50% of installation part. This takes way too long. Used to take 35-45 minutes from start to finish.
    It doesn't use much of available resources when available and too much of some parts. There are multi-core processors for ages now and it still uses only one.
      My Computers

  2. Winuser's Avatar
    Posts : 6,988
    Windows 10 Pro Insider
       #101

    I updated my laptop this morning using Windows Update. It took 3 tries before successfully updating. I'm not sure of the total time because it downloaded over night while the laptop was in sleep mode. From the time I woke the laptop to being successfully installed took about about 90 minutes.
      My Computers

  3. Fabler2's Avatar
    Posts : 2,957
    Windows 10 preview 64-bit Home
       #102

    Over all took 7 hours to get it installed. Haven't had much time to play but Edge seems to be much faster loading pages. Only thing is I've lost all my favicons.
      My Computers

  4. cereberus's Avatar
    Posts : 12,013
    Windows10
       #103

    Kari said:
    Create a DISKPART script like shown below. DISKPART scripts are normal text files with .txt extension:

    Code:
    create vdisk file=F:\W10PRO.vhdx maximum=51200 type=expandable
    attach vdisk
    create part primary
    format quick label="Windows"
    assign letter=W
    exit

    This would create a 50 GB dynamically expanding VHD file as MBR disk, label it W10PRO.vhdx and save it on root of drive F, mounting it on host as drive W.

    Run the script from your batch file with following command:

    diskpart /s DRIVE:\FOLDER\SCRIPT.TXT
    Thansl @Kari - this worked fine. I went one stage further creating diskpart.txt on the fly using echo redirection so I could enter a vhd name as well

    Code:
    @echo off
    
    set userinp=
    
    :LOOPBACK
    
    set /p userinp= ^> Enter vhd name and press "Enter":
    
    if "%userinp%"=="" goto :LOOPBACK
    
    @echo create vdisk file="F:\hyper-v\virtual hard disks\%userinp%.vhdx" maximum=60000 type=expandable > F:\isos\updateiso\commands\diskpart.txt
    @echo select vdisk file="F:\hyper-v\virtual hard disks\%userinp%.vhdx" >> F:\isos\updateiso\commands\diskpart.txt
    @echo attach vdisk >> F:\isos\updateiso\commands\diskpart.txt
    @echo create partition primary >> F:\isos\updateiso\commands\diskpart.txt
    @echo format fs=ntfs quick label="Windows" >> F:\isos\updateiso\commands\diskpart.txt
    @echo assign letter=T >> F:\isos\updateiso\commands\diskpart.txt
    
    
    
    diskpart /s "f:\isos\updateiso\commands\diskpart.txt"
    
    
    dism /apply-image /imagefile:f:\isos\updateiso\isofiles\sources\install.wim /index:1 /applydir:T:\
    
    bcdboot T:\windows /p /d
    pause
      My Computer

  5. okecove's Avatar
    Posts : 42
    Windows 10 Pro
       #104

    meebers said:
    Worst one for me so far, usually wam/bam and it is done. This one kept changing from getting things ready to downloading and installing. Several time they were at 99% and then restarting all over again. Finally after 2 1/4 hours got the RESTART. "Your PC will restart several times" is an understatement. Sometimes 2-5 seconds in between. Now that it is up?? Macrium is complaining about an error #9 when doing an image. Macrium forums indicate that it is disk corruption. SFC /scannow (C:) completes with 100%, no errors. Tried several destination drives, same problem.
    Had this problem also. Downloaded a patch for Macrium from here.
    https://knowledgebase.macrium.com/display/KNOW7/Windows+10+Insider+Preview+Build+18234+Bug
      My Computer

  6. Kari's Avatar
    Posts : 17,434
    Windows 10 Pro
       #105

    cereberus said:
    Thansl @Kari - this worked fine. I went one stage further creating diskpart.txt on the fly using echo redirection so I could enter a vhd name as well
    But the VHD name is already given in that DISKPART script I posted?

    Code:
    create vdisk file=F:\W10PRO.vhdx maximum=51200 type=expandable
    attach vdisk
    create part primary
    format quick label="Windows"
    assign letter=W
    exit

    Anyway, my batch file, as seen in my post in TF Video thread is then:

    Code:
    start /wait diskpart /s E:\Users\Kari\Scripts\VHDConf.txt
    start /wait dism /apply-image /imagefile:I:\sources\install.wim /index:8 /applydir:W:\
    start /wait bcdboot W:\Windows
    start /wait bcdedit /set {default} description "W10 PRO EN-GB (VHD)"
    cls
    @echo off
    echo. 
    echo Windows deployed to VHD file
    echo and added to host boot menu.
    echo.
    pause
    exit

    This batch will create the VHD named as W10PRO.vhdx, mounts it on host assigning it drive letter W, deploys Windows 10 to it , and finally adds it to host boot menu.

    Kari


    EDIT: OK, I see now that I misunderstood you a bit. In your way, the DISKPART script does not need to contain VHD name, you can always enter it manually when running it. In my case, though, I find it easy enough to edit the DISKPART script whenever it will be used, changing the VHD name to whatever I want this time.
      My Computer

  7. meebers's Avatar
    Posts : 1,289
    W10 20H2 .928 & W10 Insider
       #106

    okecove said:
    Had this problem also. Downloaded a patch for Macrium from here.
    https://knowledgebase.macrium.com/display/KNOW7/Windows+10+Insider+Preview+Build+18234+Bug
    WOW! tx for that, will try that later on today. I have uninstalled Ver 7, went back to 5 and then 6 all with the same results. Was about to use an older insider version and reinstall the whole system again because I had only a vss issue that was corrected in previous builds. Will post back on results, Tx again.

    UPDATE: The patch worked and I have made an image. This patch updated the version to 7.1.3570 (EUFI)
    Last edited by meebers; 19 Oct 2018 at 11:45.
      My Computers

  8. CallMeSteven's Avatar
    Posts : 488
    Windows 10 Pro Dev Channel
       #107

    okecove said:
    Had this problem also. Downloaded a patch for Macrium from here.
    https://knowledgebase.macrium.com/display/KNOW7/Windows+10+Insider+Preview+Build+18234+Bug

    Waiting patiently for a Macrium patch to fix the mounting an image (green screen).
      My Computer

  9. cereberus's Avatar
    Posts : 12,013
    Windows10
       #108

    Kari said:
    But the VHD name is already given in that DISKPART script I posted?

    Code:
    create vdisk file=F:\W10PRO.vhdx maximum=51200 type=expandable
    attach vdisk
    create part primary
    format quick label="Windows"
    assign letter=W
    exit

    Anyway, my batch file, as seen in my post in TF Video thread is then:

    Code:
    start /wait diskpart /s E:\Users\Kari\Scripts\VHDConf.txt
    start /wait dism /apply-image /imagefile:I:\sources\install.wim /index:8 /applydir:W:\
    start /wait bcdboot W:\Windows
    start /wait bcdedit /set {default} description "W10 PRO EN-GB (VHD)"
    cls
    @echo off
    echo. 
    echo Windows deployed to VHD file
    echo and added to host boot menu.
    echo.
    pause
    exit

    This batch will create the VHD named as W10PRO.vhdx, mounts it on host assigning it drive letter W, deploys Windows 10 to it , and finally adds it to host boot menu.

    Kari


    EDIT: OK, I see now that I misunderstood you a bit. In your way, the DISKPART script does not need to contain VHD name, you can always enter it manually when running it. In my case, though, I find it easy enough to edit the DISKPART script whenever it will be used, changing the VHD name to whatever I want this time.
    Sure you can manually edit diskpart script. I am developing a general script where I mount an iso, add drivers, install OS to vhds etc, and I wanted it to be interactive. I actually set up default names if I just press enter.

    Funny thing it is years since I did this - routine in old days and I have forgotten how much I have forgotten!
      My Computer


  10. Posts : 282
    win 7 8 10
       #109

    first machine didn't take update but it did second time, second machine no problems on update
    has anyone tried to see macrium mounts yets
      My Computer


 
Page 11 of 18 FirstFirst ... 910111213 ... LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:10.
Find Us




Windows 10 Forums