NVIDIA GRAPHICS FIRMWARE UPDATE TOOL FOR DISPLAYPORT 1.3 AND 1.4

Page 5 of 5 FirstFirst ... 345

  1. Posts : 11
    Windows 10 Pro for Workstations X64
       #40

    After I did this update, my Quadro M4000 lost a ton of 2d performance according to passmark. Before the update, I was getting around an 850 score in 2D performance. Now itís around 675. Nothing Iíve tried has worked to restore the higher scores I once had. Even when I changed windows performance settings from windows selects to performance, it doesnít change the score much now... 25 points. Before the update, it amounted to almost 200 points in improvement with 2D performance. Video drivers donít help. Any ideas???
      My ComputerSystem Spec

  2.    #41

    Hi HHH03
    If you want back, you need to reflash your original VGA Bios.
    You can find your VBIOS and NVFLASH here: VGA Bios Collection | TechPowerUp
      My ComputerSystem Spec


  3. Posts : 11
    Windows 10 Pro for Workstations X64
       #42

    Iíve tried that too. It didnít help. Unless thereís a way to do a clean re-flash of the VBIOS. I used the nvflash tool and it definitely changed the VBIOS because thereís a Oem version and a later NVidia version bios... (Iím not sure which one I should use... the NVidia version is about 1 year newer.... the oems are Dell and HP. They have different file numbers but are the same bios version.) Iíll admit Iím new to re-flashing VBIOS and the tool has a lot of features that can be used. I forgot to mention in my first thread... it hasnít affected 3D performance. Itís just as fast as ever or even faster. Only the 2D part has slowed down.
      My ComputerSystem Spec

  4.    #43

    HHH03 said: View Post
    Iíve tried that too. It didnít help. Unless thereís a way to do a clean re-flash of the VBIOS. I used the nvflash tool and it definitely changed the VBIOS because thereís a Oem version and a later NVidia version bios... (Iím not sure which one I should use... the NVidia version is about 1 year newer.... the oems are Dell and HP. They have different file numbers but are the same bios version.) Iíll admit Iím new to re-flashing VBIOS and the tool has a lot of features that can be used. I forgot to mention in my first thread... it hasnít affected 3D performance. Itís just as fast as ever or even faster. Only the 2D part has slowed down.
    What exactly gpu do you have?
      My ComputerSystem Spec


  5. Posts : 11
    Windows 10 Pro for Workstations X64
       #44

    Quadro M4000. I seemed to have solved the problem to my surprise. The problem must of have been my windows install. I did a complete clean reinstall, all the updates and HP drivers. I used NVidiaís latest video driver. To my surprise, the computer ran faster than ever. The 2D performance was outstanding.... close to a 900 score on the Passmark test. Even the memory test was higher than ever. So... the NVidia display port update didnít directly slow my video performance down unless it somehow changed the UEFI setup. If that was the case, then a clean reinstall fixed the problem.
      My ComputerSystem Spec

  6.    #45

    HHH03 said: View Post
    Quadro M4000. I seemed to have solved the problem to my surprise. The problem must of have been my windows install. I did a complete clean reinstall, all the updates and HP drivers. I used NVidia’s latest video driver. To my surprise, the computer ran faster than ever. The 2D performance was outstanding.... close to a 900 score on the Passmark test. Even the memory test was higher than ever. So... the NVidia display port update didn’t directly slow my video performance down unless it somehow changed the UEFI setup. If that was the case, then a clean reinstall fixed the problem.
    Glad to hear that, enjoy!
      My ComputerSystem Spec


  7. Posts : 11
    Windows 10 Pro for Workstations X64
       #46

    I have discovered the problem with the loss of my 2D video performance. Unfortunately itís not a simple as Iíd hoped. The latest windows updates, I donít know which one specifically because I was afraid to install them. I have build 17763.379 now and everything is fine with it. I know there is a newer build... that one seems be be the problem. It will totally slow down your computer,,,, at least it did mine. It causes mouse problems and doesnít play nicely with video drivers. Itís possible it wonít affect your computer specifically. But if you experienced what I have... this may be your culprit.
      My ComputerSystem Spec


  8.    #47

    does this work on cards without a display port on them i have gigabyte geforce gtx 750 TI it has HDMI and other ports i ran it to see if i needed a new GOP firmware did not update it as i did not want to mess anything up.
      My ComputerSystem Spec

  9.    #48

    go ahead, it's compatible, although no display port on the card, but if needed, it might update some part of your vbios.
    It has been extremely tested by nvidia, I dont see any risk there
      My ComputerSystem Spec


  10. Posts : 345
    Windows 10 Pro x64 Version 1803
       #49

    What are the benefits of this update if one is using DVI? I have a Gigabyte 1070 Windforce OC.
      My ComputerSystem Spec


 
Page 5 of 5 FirstFirst ... 345

Related Threads
Hi, forums I just updated my windows 10 to version 1803 and It has brought some issues. First, my HDMI port is not working, I am on a laptop btw so it's an integrated graphics card. I also can not access my Nvidia control panel because it gives...
I have a newly bought acer E 15 laptop with i5-8th gen 4GB RAM DDR3L Intel UHD 620 and a dedicated nVidia MX150 2GB GDDR5 Graphics Card. I wan't to use nVidia as my PRIMARY GRAPGICS CARD. 182864 All I can see here is Intel UHD 620 as my...
After the recent Win10 update, my nvidia graphics cards were updated too (Titan+1070) and since whenever I use Blender 3D (and I suppose any other graphics software including games but I haven't tried) audio (ie. background music) is making random...
One of the updates from today (KB3176495 or KB3176931) caused my DisplayPort monitors to be completely undetectable to Windows 10. I'm using an Nvidia 980 ti and the HDMI port appears to be working fine. The graphics drivers are up to date and have...
what is this update and it fails to install.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:42.
Find Us