Windows Client Guidance against speculative execution vulnerabilities

Page 25 of 75 FirstFirst ... 15232425262735 ... LastLast

  1. Posts : 26,343
    Win11 Pro, Win10 Pro N, Win10 Home, Windows 8.1 Pro, Ubuntu
       #240

    Phew! I switched over to Coffee Lake just in time it seems
    And my other two PC's are at an age, where they won't be getting a new BIOS, so...(they are just back up systems anyhow).
      My Computers


  2. Posts : 2,292
    Windows 10 Pro (64 bit)
       #241

    What an awful time to be a pc enthusiast. The latest revelations now kind of make me glad ASUS has not released a BIOS update addressing this yet for the z170 pro gamer as mine is a 6700k skylake machine
      My Computer


  3. Posts : 853
    Windows 10 Pro 21H1 build 19043.1706
       #242

    Likewise, Z170-P / 6700K Skylake here, presumably they now have to redo the microcode to fix the problem, this could go on for a long time!

    Interesting times ahead.
      My Computers


  4. Posts : 2,557
    Windows 10 pro x64-bit
       #243

    Like I mentioned in one of my previous posts, that was one of my biggest fears. By being hasty in providing a microcode fix for this issue (Spectre & Meltdown), that could end up doing more harm than good. This is an excerpt from @johngalt's article above:

    The bad news: Intel has previously warned that the microcode update it issued to provide some processor-based mitigation for some kinds of Spectre attack was causing machines with Haswell and Broadwell processors to reboot. It turns out that the problems are more widespread than previously reported: the chip company is now saying that Ivy Bridge, Sandy Bridge, Skylake, and Kaby Lake systems are affected, too.

    Unless my olfactory sense is deteriorating, I am starting to "smell a rat" about the whole shebang. This problem with all processors has been around for more than 23 years, how come it has suddenly blown out of proportion just now?. Some articles about Spectre & Meltdown are even already talking about buying a new PC. I don't have the wherewithal to buy a new PC every 2-3 years..The one I am using right now was bought brand new in June 2015.
      My Computers


  5. Posts : 1,020
    Windows 10 Pro 20H2 19042.572
       #244

    Hmmm Since I have a 6700k on a Z170 board and have applied the bios fix from Gigabyte 2 days ago, every thing seems to be running just fine. As far as performance, as far as I'm concerned, this cpu always idling in my machine. The only time I can get it generate any heat is to run Prime95.
      My Computers


  6. Posts : 3,298
    Windows 10 Pro x64
       #245

    I'm not convinced it's a good idea to announce existence of a major widespread PC problem before there's a workable fix for it. Hand wringing while we wait is of no benefit to anybody. Of course, I realize there are always those who take great pride in getting credited for finding flaws and will shout their discoveries from the rooftops.
      My Computer


  7. Posts : 19,209
    W11+W11 Developer Insider + Linux
       #246

    What caused Meltodwn was actually a performance enhancing feature, I'm not sure about Spectre.
      My Computers


  8. Posts : 1,871
    W10 pro x64 20H2 Build 19042.610
       #247

    Back to post #1 and others showing PS code. What am I doing wrong.


    I've tried to run this on both my main W10 PC and another running W8.1

    In both cases I get the same errors. What am I doing wrong ?

    Code:
    Windows PowerShell
    Copyright (C) 2014 Microsoft Corporation. All rights reserved.
    
    PS C:\Windows\system32> Set-ExecutionPolicy Unrestricted -Scope Process -Force
    PS C:\Windows\system32> Install-Module SpeculationControl -Force
    Install-Module : The term 'Install-Module' is not recognized as the name of a cmdlet, function, script file, or
    operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
    again.
    At line:1 char:1
    + Install-Module SpeculationControl -Force
    + ~~~~~~~~~~~~~~
        + CategoryInfo          : ObjectNotFound: (Install-Module:String) [], CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException
    
    PS C:\Windows\system32>
      My Computer


  9. Posts : 17,636
    Windows 10 Pro
       #248

    Mooly said:
    I've tried to run this on both my main W10 PC and another running W8.1

    In both cases I get the same errors. What am I doing wrong ?
    It's Import-Module, not Install-Module. A syntax error in your PowerShell command line.
      My Computer


  10. Posts : 14,893
    Windows 10 Pro
       #249

    Kari said:
    It's Import-Module, not Install-Module. A syntax error in your PowerShell command line.
    Not according to the first post
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:03.
Find Us




Windows 10 Forums