Windows 10: VMware-usb storage device not recognized

Page 1 of 2 12 LastLast
  1.    09 Dec 2017 #1

    VMware-usb storage device not recognized


    I'm running Windows XP in Workstation Player on a Windows 10 laptop.

    My USB CD/DVD drive is able to mount in the Player. So is a flash drive.

    My Western Digital ssd (My Passport Ultra) is listed in "Removable devices", but fails to mount, giving this error:

    Click image for larger version. 

Name:	USB Device Not Recognized.JPG 
Views:	25 
Size:	30.4 KB 
ID:	167429

    In the Virtual Machine settings, the USB controller is using usb 2.0.

    The WD ssd is compatible with usb 3.0 and 2.0, and is supported by Windows XP. My desktop computer running Win XP has no problem mounting the drive.

    The device manager in virtual Win XP shows it as an "unknown device."

    I've read everything I can find on the problem, and tried a number of suggestions from the knowledge base at VMware as well as solutions via google searches.

    Perhaps the WD ssd just won't work on the free version of VM Workstation Player (v. 14).

    Anyone have any suggestions?

      My ComputerSystem Spec

  2.    09 Dec 2017 #2

    Hi there

    Check the USB configuration -- you might have set USB configuration to USB 2 or even earlier -- you probably need to set it to USB 3.

    screenshot below this is for vmware workstation but same is true for vmplayer --otherwise edit the .vmx file for the VM.

    Click image for larger version. 

Name:	snapshot2.png 
Views:	0 
Size:	99.2 KB 
ID:	167463


      My ComputerSystem Spec

  3.    09 Dec 2017 #3

    Hi Jim,

    Yes, I've tried that and I just tried it again.

    Click image for larger version. 

Name:	setting usb 3.JPG 
Views:	2 
Size:	100.4 KB 
ID:	167466

    With usb 3.0, the WD drive doesn't even show up in "Removable devices."

    I read something about Win XP not able to "see" usb 3.0 devices.

    I took a snippet of notepad loaded with .vmx settings.

    Click image for larger version. 

Name:	notepad showing vmx settings.JPG 
Views:	24 
Size:	52.9 KB 
ID:	167474

    The virtual machine is now set to usb 3.0. This screenshot shows "speed="2". "

    Does this tell you anything? Is this where I would edit the .vmx file?
      My ComputerSystem Spec

  4.    09 Dec 2017 #4

    XP never had USB 3 drivers afaik.
      My ComputerSystem Spec

  5.    09 Dec 2017 #5

    Thanks Cereberus.

    As I said, the WD drive uses both 2.0 and 3.0 and it is compatible with Win XP. It's in the documentation. I can mount the drive on my desktop Win XP machine, I just can't get it to mount on the XP virtual machine running within my laptop's Win 10 OS using either usb 2 or usb 3.

    The drive does show up in the "removable devices" list using usb 2.0, but will not mount. It does not even show up using usb 3.
      My ComputerSystem Spec

  6.    09 Dec 2017 #6

    Hi there

    how about really old --go back to USB 1.1

    the other thing you could do is to see if you can source some XP USB drivers --the SP3 (final officlal update) had some USB stuff in it. Install the USB drivers directly on the VM.

      My ComputerSystem Spec

  7.    09 Dec 2017 #7

    I did install SP 3 using a .cab file to update my copy of XP.

    How might I find the drivers from the .cab file?

    I think I already tried usb 1.1, but can try again.

    In your VM, are you having no usb issues? You're probably running something more recent than Win XP, though.
      My ComputerSystem Spec

  8.    09 Dec 2017 #8

    Hi there
    @Paul Bacon
    I have a few XP VM's -- I'll load them up tomorrow and see how my USB 3 devices connect.

    just going to a pub tonight with some colleagues and going to drink a load of Gluwein (like Hot mulled wine but a bit nicer !!) --it's -3 deg (Celsius) here --no snow but COLD (Wind chill factor) tonight !!!!

    Note though I'm running CENTOS 7.2 Linux Host with Vmware workstation 14.

      My ComputerSystem Spec

  9.    09 Dec 2017 #9

    Have fun Jim! I'm about to start cocktails here.

    As we speak, here in US, New Hampshire (northeast coast), we're having our first snow fall. Oh boy we go again.
      My ComputerSystem Spec

  10.    11 Dec 2017 #10

    Hi there
    @Paul Bacon

    In your VMWARE click the Upgrade Virtual machine and choose VMware workstation 14
    Now you can connect USB 3 devices -- you'll have to connect via a USB2 port though -although I haven't finished testing USB 3 ports yet -- may be possible to use USB 3 ports connect somehow.

    Note also I think on XP you can't use HDD's or partitions > 2TB -- not sure with XP and GPT. No problem though accessing SAMBA (from Linux server) HDD's -- got some RAID arrays on the server with one at 9TB --XP can access it just fine.

    I'll test the SSD with a SATA-->USB2 connector and plug it into a USB3 port and see what happens
    will do that later as have some appointments today.

    I've got an SSD (250 GB) connected to an XP VM which reads / writes perfectly -- connected using a SATA-->USB3 connector but plugged in to a USB 2 port.

    Here's the XP VM - afraid Icelandic XP but the image should be clear enough.

    Note I'm running CENTOS 7.2 (Linux) as the HOST but shouldn't make any difference as far as the VM is concerned.

    Click image for larger version. 

Name:	xpvm.png 
Views:	2 
Size:	1.45 MB 
ID:	167738

      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
Hi, I sporadically gets the "USB Device Not Recognized Device Descriptor Request Failed"; however, while I have 6 USB devices connected, none of them seem to be the cause of the error. When I use devmgmt.msc to get the Hardware Ids, the value is...
When my girlfriend connects external USB device to any of the USB ports on Windows 10 Home she gets message: USB Device Not Recognized. She can not charge USB device via USB port. I went to device manager and under USB Controllers I see...
Hello everyone.. Yesterday my laptop pushed a new Win 10 update, and all went fine, or at least I think so. But today I see that my Sony WALKMAN - which I used with no problem until now, can't be recognized anymore. Basically it just shows as...
USB device not recognized in Drivers and Hardware
I have a Lenovo Android phone which after it self-upgraded it's software (customized Android UI) does not get recognized when it's plugged into my Lenovo G50 notebook. When plugged in, Windows gives "USB device not recognized" and the phone cannot...
USB device not recognized in Drivers and Hardware
I have a USB port on my motherboard that never worked. I had the problem with Windows 7 complaining about it, but something I did got Windows 7 to be quiet. Now I have Windows 10. Action Center is popping a steady stream - and I do mean...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:38.
Find Us