Windows 10: VMware-getting "device guard" error in spite Solved

  1.    04 Dec 2017 #1

    VMware-getting "device guard" error in spite


    I keep getting this error in attempting to open VM Player v14.

    Click image for larger version. 

Name:	Error opening Player.JPG 
Views:	18 
Size:	36.5 KB 
ID:	166770

    I was using Hyper-V for a few days and decided to try out VMware Player using Brink's tutorial. I tried using cmd "bcdedit" to turn off Hyper-V, and got this result:

    Click image for larger version. 

Name:	Error CMD hyperV.JPG 
Views:	18 
Size:	41.2 KB 
ID:	166771

    Then, as I had saved a system image before working on Hyper-V, I restored that system image. I'm still getting that first error. I went to the link to follow VMware's instructions, but I couldn't run their code because access was denied to the boot configuration data store:

    Click image for larger version. 

Name:	Trying to opend bcdedit.JPG 
Views:	18 
Size:	40.3 KB 
ID:	166772

    I have virtualization enabled in the BIOS and hyper-v is uninstalled via "turn Windows features on or off".

    Could someone walk me through this troubleshooting? I've tried a number of things already, but no success.
      My ComputerSystem Spec

  2. Kari's Avatar
    Posts : 15,013
    Windows 10 Pro
       04 Dec 2017 #2

    You are running BCDEDIT in normal user mode Command Prompt. BCDEDIT requires elevated Command Prompt (tutorial).

    That is also clearly told in Brink's tutorial you referred to. Extract from a warning at the beginning of said tutorial:

    warning   Warning
    To be able to run a VM in VMware Workstation Player and no longer can run a VM in Hyper-V, you will need to perform the steps below to turn off hypervisorlaunchtype.

    A) Open an elevated command prompt.
    B) Enter bcdedit /set hypervisorlaunchtype off into the command prompt, and press Enter.
    C) Restart the computer to apply.
    (From Install Windows 10 as Virtual Machine in VMware Player Virtualization Tutorials)
      My ComputerSystem Spec

  3.    04 Dec 2017 #3

    Okay Kari, I'll follow the tutorial.

    I thought I was using an elevated cmd because I'm the administrator, but obviously I'm mistaken.

    I'll be back :).

    Thank you sir!
      My ComputerSystem Spec

  4. Kari's Avatar
    Posts : 15,013
    Windows 10 Pro
       04 Dec 2017 #4

    Paul Bacon said: View Post
    I thought I was using an elevated cmd because I'm the administrator, but obviously I'm mistaken.
    It's not the same thing. Your user account is something called local administrator account, your screenshots revealed that you had run Command Prompt in user mode, as you. Running an application, program, command or tool elevated means that instead of your local admin account it will be run with highest priviliges, as built-in administrator.

    You can start an application elevated by right clicking it and selecting Run as administrator, or for instance in case of Command Prompt by pressing WIN + R to open RUN prompt, typing cmd and pressing CTRL + SHIFT + ENTER (pressing ENTER alone starts it in normal user mode).

    Tutorial: Open Elevated Command Prompt in Windows 10 General Tips Tutorials

    Kari
      My ComputerSystem Spec

  5.    05 Dec 2017 #5

    Kari, thanks to your links I'm now using an elevated cmd.

    I followed the instructions in the VMware knowledge base article. Upon reboot I disabled 2 items at the prompts. The first time I opened the Player I got this error:

    Click image for larger version. 

Name:	Remove Hyper-V role.JPG 
Views:	2 
Size:	28.4 KB 
ID:	166848

    Then I went back and re-did steps 1 and 2 in the article. I had already done that yesterday, and the settings were still correct. Now I'm back to this error when I click on Play (the green arrow.)

    Click image for larger version. 

Name:	Error opening Player.JPG 
Views:	17 
Size:	36.5 KB 
ID:	166849

    Do you think I should start from scratch? --enable Hyper-V again, then follow the KnowledgeBase article to the letter?
      My ComputerSystem Spec

  6.    05 Dec 2017 #6

    Never mind Kari. I got it. I ran the hypervisorlaunchtype off.

    I think I'm in business! Thank you for your help!
      My ComputerSystem Spec


 

Related Threads
I just got this error message. I haven't added any new USB devices, and I don't think any have gone bad. So, to do trouble-shooting,Is there any way to enumerate USB logical ports and the devices that are attached? I haven't added any new USB...
I have Windows 10 Ver. 1703 update KB4020102. It seems like the computer is shutting down the screen after about an hour of no activity. I checked my power settings (a custom one) and the setting is to never shut down the display. (When I went to...
Hi All I'm hoping someone who knows something about Device Guard and virtualisation can help me with a question I have. I recently rebuilt my desktop with Windows 10 Enterprise 64bit Creators Update. I use VMware Workstation Pro 12.5 daily for...
I had to buy a new (SSD) HD and had trouble booting from a disc until I enabled Legacy Mode and disabled Secure Boot in BIOS. Now whenever I boot up I get a "No Boot Device Found" message until I hit "Enter" at which point i'm allowed entry into my...
Hi This error i'm having seems very common (seen videos and such) but I can't seem to get this problem fixed. Everything was running fine, until last Sunday. Then the mouse started to have this problem - It doesn't matter what USB port it's in...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:18.
Find Us