Slow download speed after creating External Virtual Switch

Page 2 of 2 FirstFirst 12
  1.    12 Apr 2018 #11

    But how to recover the lost time?

    dtbullock said: View Post
    Cynically, one is tempted to feel that Intel needed a quick & dirty way to help out a US intel agency hit a target
    So I'm wondering if anyone has an email address where I can invoice Intel for the lost time (at least 6 hours) chasing down the matter? Or maybe the NSA has a 'Incidental Victims of Compelled Technology Provider Interventions Fund' I could claim against? (I guess, complicated by not being a US citizen ...)

      My ComputerSystem Spec

  2.    13 Apr 2018 #12

    I've been experiencing the same thing lately. I just deleted ALL of my Hyper-V switches on this PC and I'll report back in if it results in improved Internet performance. So far, it already seems like a noticeable improvement.
      My ComputersSystem Spec

  3.    28 May 2018 #13

    I had the same problem, I was only getting 25 kbps connection. I checked the network bridge adapter and lo and behold, the ipv4 setting was unchecked. I ticked the box and clicked ok, and immediately the speed when back to normal. Maybe just a fluke, but hey it worked for me.
      My ComputerSystem Spec

  4.    31 May 2018 #14

    dtbullock said: View Post
    I had a similar issue (I was not so thorough as to check all the resource usage graphs though!). In my case, the Hyper-V host (Win 10 Pro) experienced slow networking on downloads only (uploads were just fine), after creating an External Hyper-V virtual switch. Trashing the Hyper-V switch reliably restored download performance.

    My physical adapter is an 'Intel(R) Ethernet Connection (2) I219-V #2'.

    ... I finally wondered if one of the protocols bound to the Hyper-V switch was interfering with it. Recall, that when Hyper-V sets up an external switch, it automatically (and blindly) migrates almost all the protocols bound to that NIC, to the new virtual NIC.

    Spotting 'Intel(R) Technology Access Filter Driver' enabled, I reasoned that it may not apply to a Hyper-V virtual NIC, and turned it off.
    Success! Full download speed returned!
    Wow, thank you so much. I had to register to the forum to say this . This was driving me insane, and none of the advices I found helped much, but you found the solution for me. Thanks and

    Best regards,

      My ComputerSystem Spec

Page 2 of 2 FirstFirst 12

Related Threads
Hi this is my first post but I am really confused as to an issue with hyper-V Whenever I go to open the virtual switch manager, it says; The operation on computer 'DESKTOP-V1A0142' failed: Generic error. Is there anyway to fix this. I have not...
I have a question about my router, it's a Linksys 1900AC. It broadcasts 2.4 and 5. My laptop does not have a receiver to pick up the 5. My average download speed connected to 2.4 is around 10Mbp/s. I'm paying for 150Mbp/s. If I connect my wife's...
I get the error "bind failed: General access denied error" when I try to create an external virtual switch. 67920 I tried running Hyper-V with as admin without success. Kevin
creation of virtual switch seems to be proceeding but stops and I get a message similar to this: "Error applying virtual switch properties changes" Failed while adding virtual switch connections External ethernet adapter "'realtek pcie gbe'...
I've been working to get some speed back on my laptop but I haven't been able to understand where or how I can get the text that needs to be pasted in the .bat file. I've looked and looked and can't find a clear answer anywhere.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:30.
Find Us