Windows 10: Can't mount ISO''s with Windows Explorer anymore.

Page 3 of 3 FirstFirst 123

  1. Posts : 19
    Windows 10 Pro x64
    Thread Starter
       13 May 2017 #21

    OldMike65 said: View Post
    Ok, was just a thought , on another note, I am running the exact same version of Windows you are, 1607 Build 14393.1198 and mine has no problems mounting ANY ISO no matter where its located. Using Explorer. Or Winrar, or 7-zip, so having those last 2 programs does not interfere with Explorer being able to mount ISO's at all.
    Don't sound like a Windows 10 issue to me......sounds like something is messed up on your system. Maybe try doing a repair install, or Run Dism to check for errors, SFC .......unless you have already tried.
    I tried system file checker and chkdsk as well with no errors.
      My ComputerSystem Spec

  2.    14 May 2017 #22

    See my #15
    Otherwise do you have anything like Magic ISO or Power ISO installed- something that changes associations for ISOs? (Slim chance...)

    Otherwise as I think I said, it's either an in-place upgrade repair install, or upgrade to the Creator's build.
      My ComputerSystem Spec

  3.    14 May 2017 #23

    Ok you could try running Dism to check for errors

    DISM /Online /Cleanup-Image /StartComponentCleanup /ResetBase

    If that does nothing, then a Repair Install might be your last choice, watch the video, read the tutorial This will NOT remove any personal files or programs.
    Repair Install Windows 10 with an In-place Upgrade Windows 10 Installation Upgrade Tutorials


    Only other thing maybe, have you changed any setting in your bios recently?? I see you have a custom built pc, so if you made any changes in your bios that might have affected your Windows. Just a long shot....
      My ComputersSystem Spec

  4.    14 May 2017 #24

    One thought- test whether mounting an iso works under a new user profile - create one for test purposes.

    If so, it's very unlikely an in-place repair install or upgrade will help with this.
      My ComputerSystem Spec

  5.    14 May 2017 #25

    Nikorasu said: View Post
    Please help. I used to be able to Mount ISO's with Windows Explorer but I can't anymore. When I right click an ISO and click mount I get an error
    Attachment 134799


    I don't know when the problem started either as I haven't mounted an ISO using Windows Explorer in awhile. I've been using Winrar. I changed the default app to open ISO's to Windows Explorer yet I still can't mount the ISO. it does it with every ISO I tried.
    Hi there
    Actually the reason might be quite simple.

    In your Virtual Machine configuration have you actually defined it as having ANY CD / DVD devices -- simply add one - you can leave off the connect at power on.

    Click image for larger version. 

Name:	snapshot13.png 
Views:	0 
Size:	378.9 KB 
ID:	134967

    Now try again.

    Cheers
    jimbo.
      My ComputerSystem Spec


  6. Posts : 1,925
    Windows 10 x86 14383 Insider Pro and Core 10240
       14 May 2017 #26

    There's a simple answer to this:

    If an Image File like an ISO, or VHD is not contiguous (i.e. in a single piece, not fragmented around the disk) it may not be able to be mounted.

    If copied elsewhere there's a good chance it will be contiguous and mountable.
      My ComputersSystem Spec


 
Page 3 of 3 FirstFirst 123

Related Threads
How to Mount or Unmount ISO and IMG Files in Windows 10 An ISO or IMG file, also called a disc image, is a single file that’s a copy of an entire data CD or DVD. When you mount an .ISO or .IMG file, it will be added as a CD/DVD drive in This...
Hi When I right click on mouse for properties with explorer, it doesnt work anymore for files or HD! No reaction at all. Annoying problem, how to fix that? Txs Serros
Good morning all, Usually I don't ever post anything - google seems to solve it for me. But this time every solution has failed. Hardware: Dlink DNS-320 Nas, running most current firmware, Acer Iconia W700i running the most upto date Windows...
Sorry for my bad english http://www.eightforums.com/images/smilies/010.png hope you understand I recently mount a ISO file on my computer, it work, then i unmount that ISO and a some hours later i needed that ISO again, so I tried to mount and...
Hi everyone, I am experiencing several problems since I downloaded Windows 10. At the beginning everything looked fine after the download. Once I have set up OneDrive on my Microsoft account the problems started. 1. When starting the computer...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:10.
Find Us