Windows 10: VMware - Force VM to use "Internal" Virtual Nic and not installed Nic

  1.    15 Feb 2017 #1

    VMware - Force VM to use "Internal" Virtual Nic and not installed Nic


    Hi there

    Anybody know how to get VMware to use its own Virtual NIC for Windows rather than the hardware Nic's / Wifi Nic's when VM's are running on the same machine as the Host.

    I've got HOST W10 PRO
    Two VM's -- centos and Linux Mint running on same local machine as the Host.

    Windows-> to either of the Linux machines or either of the Linux machines to windows - Max data transfer I get is about 12 MB/s (50 Mib/s). That's about right for the wifi adapter I'm using.

    Strange thing is from VM1 to VM2 (or the other way around) data transfer from the SAME HDD is around 80 MB/s (320 Mib/s) or so -- so nearly 7 (yes SEVEN) times faster.


    Seems Windows wants to use the physical hardware nic while the Linux machines are using "Virtual Ethernet adapter" 1 Gib/s which is what I want. I.e Disk I/O through computers I/O bus and not via networking.

    Must be something in Windows setting for this - note I can't use Host only networking as I want all 3 machines to be able to access each other.

    Any ideas folks.

    Cheers
    jimbo
      My ComputerSystem Spec

  2.    15 Feb 2017 #2

    2019058, check out that kb article from vmware.
      My ComputerSystem Spec


  3. Posts : 445
    Microsoft Windows 10 Pro 32-bit 10586
       15 Feb 2017 #3

    Have you tried poking around in the Virtual Network editor, You can add a virtual nic or hardware nic



    1. Open a VMware Workstation window.
    2. Choose Edit > Virtual Network Settings.
    3. The Virtual Network Editor appears, with the Summary tab active.
      Click image for larger version. 

Name:	2015-02-12-12_31_34-Virtual-Network-Editor.jpg 
Views:	11 
Size:	53.5 KB 
ID:	121279
      My ComputerSystem Spec


 

Related Threads
With my continuing efforts to assist my brother in tailoring his new ThinkPad (X1 Yoga) laptop, I've recently discovered an unexpected problem relating to Microsoft Office, and specifically (at this point), with Word. As indicated in this post's...
Hi, I have 1 HDD connected to one USB 3.0 Port. When I connect a second HDD to another USB 3.0 Port, windows automatically Disconnects/Reconnects the First HDD. I can listen the Motor of the HDD going down, exactly as if I removed the Power...
Hello, Im getting a BSOD randomly, and its a error called "Video Scheduler Internal Error". Been getting it frequently, tried lot of different fixes. Thought I did it when I managed to fix the AMDA00 Error thing, then I could use the pc again,...
Hello, Usually, for test environments with a few machines I used to make NAT Networks on VirtualBox since version 4.3 when they introduced that option. Now, I'm trying to do something similar with VMWare. I noted that in VMWare (in the Virtual...
Hi everybody, I've upgraded my ASUS U36SG from Windows 8.1 Professional to Windows 10 Enterprise. Everything went fine unless the issue "no audio output devices are installed", I've tried almost all the solutions you guys provided for that...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:47.
Find Us