Windows 10: Set up Vista on Hyper-V under Windows 10, cannot connect to internet Solved

  1.    19 Sep 2016 #1

    Set up Vista on Hyper-V under Windows 10, cannot connect to internet


    Dell XPS 8500 host running Windows 10 Pro x64 build 14393, Vista Ultimate SP1 x64 Gen 1 guest.

    I installed Vista in a Gen 1 VM but it cannot find a network adapter. I have tried both of my connectors (Ethernet external and WiFi external) but no effect. I have deleted the network adapter in Settings and added it back but no effect.

    I had Vista running this way fine a few months ago so I used the archived .vhdx file in a second Gen 1 VM but it didn't do any better than the clean install in the first VM.

    Obviously I am missing a step that I have forgotten. Advice appreciated.
      My ComputerSystem Spec


  2. Posts : 12,376
    Windows 10 Pro
       20 Sep 2016 #2

    You need to add and use a legacy network adapter with Vista and older guest operating systems. See tutorial Part Five, especially steps 5.4 to 5.6: Hyper-V virtualization - Setup and Use in Windows 10 - Windows 10 Forums
      My ComputerSystem Spec

  3.    20 Sep 2016 #3

    That was what I forgot. Thanks!
      My ComputerSystem Spec


 

Related Threads
Hi, I realise that this problem has been asked many times over the Internet, however I am at my wits end over this problem. I would like to have Windows 10, but I have downloaded it four times, and each time I am unable to connect to the Internet,...
I have installed a Win10 Hyper-v machine in my windows 10 system and cannot get this thing to connect to the internet I can get as far as the router, in other words from the VM I can ping the router; in reality it doesn't matter what IP address I...
:sick: Hi, since yesterday my Hyper-V stoped work. I have no clue of whats going on. I tried to uninstall and install it again, but didn't work. Does someone knows how to purge hyper-v configuration when remove/uninstall it? Because it seems...
Just upgraded from Windows 10 build 10056 to the new 10061 build. Cannot connect the my wired ethernet network adapter since upgrading....Project Spartan works just fine; however, Internet Explorer, Mozilla, Tor, etc will not connect. Resorted to...
System specs are below. Virtualization is turned on in BIOS. Hyper-V is installed. When I start Hyper-V Manager it's not connected to a server. I click Connect to Server->Local Computer and get the error message (see below). I can see none of...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:18.
Find Us