Windows 10: Unable to Install Hyper-V Platform Role Solved


  1. Posts : 2
    Windows 10 Pro 64-Bit Version 1511 Build 10586.545
       04 Sep 2016 #1

    Unable to Install Hyper-V Platform Role


    Hi,


    I am trying to install the Hyper-V role through the Control Panel - Programs and Features - Turn a Windows Feature On or Off.


    When I check the box for Hyper-V, it searches for the files, acquires them, and applies the changes. It then says "Windows completed the requested changes" and asks me to reboot.


    As the computer is turning off, it shows that Windows is working on updates. It gets to 30% and power cycles the computer. When it is booting back up, it shows Windows is working on updates. However, when it gets to around 90% - 96% it will say:


    "We couldn't install the features, undoing changes, don't turn off the system."


    After that message is displayed, it will power cycle the computer again. This time, when it is coming back up, it will display:


    "We couldn't complete the updates, undoing changes, don't turn off the system."


    After that message is shown, I can login to the computer and it is back to the way it was, before I tried to install Hyper-V.


    Now, I get two messages in the System Event Log after this cycle has occurred:


    Error 1:
    The HvHost service terminated with the following error:
    A device attached to the system is not functioning.
    Source: Service Control Manager
    Event ID: 7023
    Param1 HvHost
    Param2 %%31



    Error 2
    The VMSP service failed to start due to the following error:
    A device attached to the system is not functioning.
    Source: Service Control Manager
    Event ID: 7000
    param1 VMSP
    param2 %%31





    ____________________________________________________________________________________________________ ____________________


    OS is Windows 10 Pro 64-Bit, Version 1511 Build 10586.545


    CPU is an Intel i7-6700k. This chip supports SLAT.


    Mobo is an Asus Z170-A. I have made sure that Intel Virtualization is Enabled in the Bios.


    Coreinfo and Systeminfo both show a YES in all Hyper-V requirements categories.


    ____________________________________________________________________________________________________ ____________________



    I have tried uninstalling Antivirus programs and attempting to install Hyper-V Role, but the same issue occurred.


    I have run multiple sfc /scannow and no issues can be found.


    I have run multiple Dism /Online /Cleanup-Image /ScanHealth and no issues can be found.


    I have run multiple Dism /Online /Cleanup-Image /CheckHealth and no issues can be found.


    I have tried toggling DEP On/Off and it did not help.


    I have checked for Windows updates, and I am on the latest version for version 1511.


    I have tried disabling all network adapters and installing the role, and it did not help.


    I have tried installing the role while in safe mode, and it did not help.


    I have tried toggling VT-d on and off in the bios, and it did not help.


    I have tried toggling Windows Firewall on and off, and it did not help.


    ____________________________________________________________________________________________________ ____________________


    I'm not sure what else I can try here. I can't seem to update to the Windows Anniversary Update (not sure what happens, it blue screens too fast and I can't see the error message).


    Any help is appreciated,


    Thanks
    Last edited by KoopaBoss2014; 05 Sep 2016 at 09:22.
      My System SpecsSystem Spec


  2. Posts : 2
    Windows 10 Pro 64-Bit Version 1511 Build 10586.545
       05 Sep 2016 #2

    I was able to get the Anniversary Update installed by:

    Deactivating my Windows 10 pro license Key. Restart Machine.
    Reactivating my Windows 10 pro license Key. Restart machine.
    Turn off machine. Unplug all non-C drives.
    Turn on computer. Download and Install Anniversary Update.
    Restart machine.

    Once that was done, I could install the Hyper-V role.
      My System SpecsSystem Spec


 

Related Threads
Hello, i am having trouble installing the Windows 10 mobile emulator for Visual Studio 2015 First I got this message when I attemped to install the first time (see screenshot 1) Dropbox - install microsoft emulator 1st try.PNG So I went...
I get the error "bind failed: General access denied error" when I try to create an external virtual switch. 67920 I tried running Hyper-V with as admin without success. Kevin
If there is a tutorial already, I cannot find it here as most of the hyper-V references are about getting Hyper-V working. I have: - Physical Notebook running Windows 10 Home (with key of course) - Physical Notebook running Window 10 Edu...
Hi, I have a problem where I could not enable/install Hyper V on my computer. I tried for looking to this problem but could not find anything about this problem. I followed the methodes to enable it but couldn't found Hyper V in the list. ...
Hi there Trying to install programs while connected via RDP (the normal way of accessing your HYPER-V VM remotely). Cannot install programs. This seems a bit daft - I can't always be at the console of the HOST machine - I usually access VM's...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:52.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums